summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-tv/mythfrontend/mythfrontend-0.16.ebuild5
-rw-r--r--media-tv/mythtv/mythtv-0.16.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/media-tv/mythfrontend/mythfrontend-0.16.ebuild b/media-tv/mythfrontend/mythfrontend-0.16.ebuild
index d388f7fbe3a7..2c59baba3e1a 100644
--- a/media-tv/mythfrontend/mythfrontend-0.16.ebuild
+++ b/media-tv/mythfrontend/mythfrontend-0.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/mythfrontend-0.16.ebuild,v 1.9 2004/12/05 00:52:43 iggy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/mythfrontend-0.16.ebuild,v 1.10 2004/12/16 21:34:37 cardoe Exp $
inherit myth flag-o-matic
@@ -151,6 +151,9 @@ src_unpack() {
# Fix bugs 40964 and 42943.
filter-flags -fforce-addr -fPIC
+ # fix bug 67832, fix can be removed for 0.17 when its released
+ is-flag "-march=pentium4" && replace-flags "-O3" "-O2"
+
myth_src_unpack
sed -i '32i #include <cmath>' ${S}/libs/libmythtv/dvbdiseqc.cpp
}
diff --git a/media-tv/mythtv/mythtv-0.16.ebuild b/media-tv/mythtv/mythtv-0.16.ebuild
index 8e4806c3e4d9..e055bc35a85e 100644
--- a/media-tv/mythtv/mythtv-0.16.ebuild
+++ b/media-tv/mythtv/mythtv-0.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.16.ebuild,v 1.9 2004/12/05 00:46:13 iggy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.16.ebuild,v 1.10 2004/12/16 21:33:07 cardoe Exp $
inherit myth flag-o-matic eutils
@@ -144,6 +144,9 @@ src_unpack() {
# Fix bugs 40964 and 42943.
filter-flags -fforce-addr -fPIC
+ # fix bug 67832, fix can be removed for 0.17 when its released
+ is-flag "-march=pentium4" && replace-flags "-O3" "-O2"
+
myth_src_unpack
epatch ${FILESDIR}/${P}-cx88.patch