summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-fs/udev-init-scripts/udev-init-scripts-22.ebuild30
-rw-r--r--sys-fs/udev-init-scripts/udev-init-scripts-9999.ebuild30
2 files changed, 30 insertions, 30 deletions
diff --git a/sys-fs/udev-init-scripts/udev-init-scripts-22.ebuild b/sys-fs/udev-init-scripts/udev-init-scripts-22.ebuild
index bff18255ba38..15c13c9a95c8 100644
--- a/sys-fs/udev-init-scripts/udev-init-scripts-22.ebuild
+++ b/sys-fs/udev-init-scripts/udev-init-scripts-22.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev-init-scripts/udev-init-scripts-22.ebuild,v 1.4 2013/01/29 15:54:28 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev-init-scripts/udev-init-scripts-22.ebuild,v 1.5 2013/01/29 17:31:13 williamh Exp $
EAPI=4
@@ -16,7 +16,7 @@ HOMEPAGE="http://www.gentoo.org"
LICENSE="GPL-2"
SLOT="0"
-IUSE="build"
+IUSE=""
if [ "${PV}" != "9999" ]; then
SRC_URI="http://dev.gentoo.org/~williamh/dist/${P}.tar.bz2"
@@ -37,27 +37,27 @@ src_prepare()
pkg_postinst()
{
- # If we are building stages, add udev and udev-mount to the sysinit runlevel
- # automatically.
- if use build
+ # Add udev and udev-mount to the sysinit runlevel automatically if this is
+ # the first install of this package.
+ if [[ -z ${REPLACING_VERSIONS} ]]
then
- if [[ -x "${ROOT}"/etc/init.d/udev \
- && -d "${ROOT}"/etc/runlevels/sysinit ]]
+ if [[ -x "${ROOT}"etc/init.d/udev \
+ && -d "${ROOT}"etc/runlevels/sysinit ]]
then
- ln -s /etc/init.d/udev "${ROOT}"/etc/runlevels/sysinit/udev
+ ln -s "${ROOT}"etc/init.d/udev "${ROOT}"/etc/runlevels/sysinit/udev
fi
- if [[ -x "${ROOT}"/etc/init.d/udev-mount \
- && -d "${ROOT}"/etc/runlevels/sysinit ]]
+ if [[ -x "${ROOT}"etc/init.d/udev-mount \
+ && -d "${ROOT}"etc/runlevels/sysinit ]]
then
- ln -s /etc/init.d/udev-mount \
- "${ROOT}"/etc/runlevels/sysinit/udev-mount
+ ln -s "${ROOT}"etc/init.d/udev-mount \
+ "${ROOT}"etc/runlevels/sysinit/udev-mount
fi
fi
# Warn the user about adding the scripts to their sysinit runlevel
- if [[ -e "${ROOT}"/etc/runlevels/sysinit ]]
+ if [[ -e "${ROOT}"etc/runlevels/sysinit ]]
then
- if [[ ! -e "${ROOT}"/etc/runlevels/sysinit/udev ]]
+ if [[ ! -e "${ROOT}"etc/runlevels/sysinit/udev ]]
then
ewarn
ewarn "You need to add udev to the sysinit runlevel."
@@ -66,7 +66,7 @@ pkg_postinst()
ewarn "Run this command:"
ewarn "\trc-update add udev sysinit"
fi
- if [[ ! -e "${ROOT}"/etc/runlevels/sysinit/udev-mount ]]
+ if [[ ! -e "${ROOT}"etc/runlevels/sysinit/udev-mount ]]
then
ewarn
ewarn "You need to add udev-mount to the sysinit runlevel."
diff --git a/sys-fs/udev-init-scripts/udev-init-scripts-9999.ebuild b/sys-fs/udev-init-scripts/udev-init-scripts-9999.ebuild
index e7a10c5ffa83..1413eb590dee 100644
--- a/sys-fs/udev-init-scripts/udev-init-scripts-9999.ebuild
+++ b/sys-fs/udev-init-scripts/udev-init-scripts-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev-init-scripts/udev-init-scripts-9999.ebuild,v 1.17 2013/01/28 05:14:15 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev-init-scripts/udev-init-scripts-9999.ebuild,v 1.18 2013/01/29 17:31:13 williamh Exp $
EAPI=4
@@ -16,7 +16,7 @@ HOMEPAGE="http://www.gentoo.org"
LICENSE="GPL-2"
SLOT="0"
-IUSE="build"
+IUSE=""
if [ "${PV}" != "9999" ]; then
SRC_URI="http://dev.gentoo.org/~williamh/dist/${P}.tar.bz2"
@@ -37,27 +37,27 @@ src_prepare()
pkg_postinst()
{
- # If we are building stages, add udev and udev-mount to the sysinit runlevel
- # automatically.
- if use build
+ # Add udev and udev-mount to the sysinit runlevel automatically if this is
+ # the first install of this package.
+ if [[ -z ${REPLACING_VERSIONS} ]]
then
- if [[ -x "${ROOT}"/etc/init.d/udev \
- && -d "${ROOT}"/etc/runlevels/sysinit ]]
+ if [[ -x "${ROOT}"etc/init.d/udev \
+ && -d "${ROOT}"etc/runlevels/sysinit ]]
then
- ln -s /etc/init.d/udev "${ROOT}"/etc/runlevels/sysinit/udev
+ ln -s "${ROOT}"etc/init.d/udev "${ROOT}"/etc/runlevels/sysinit/udev
fi
- if [[ -x "${ROOT}"/etc/init.d/udev-mount \
- && -d "${ROOT}"/etc/runlevels/sysinit ]]
+ if [[ -x "${ROOT}"etc/init.d/udev-mount \
+ && -d "${ROOT}"etc/runlevels/sysinit ]]
then
- ln -s /etc/init.d/udev-mount \
- "${ROOT}"/etc/runlevels/sysinit/udev-mount
+ ln -s "${ROOT}"etc/init.d/udev-mount \
+ "${ROOT}"etc/runlevels/sysinit/udev-mount
fi
fi
# Warn the user about adding the scripts to their sysinit runlevel
- if [[ -e "${ROOT}"/etc/runlevels/sysinit ]]
+ if [[ -e "${ROOT}"etc/runlevels/sysinit ]]
then
- if [[ ! -e "${ROOT}"/etc/runlevels/sysinit/udev ]]
+ if [[ ! -e "${ROOT}"etc/runlevels/sysinit/udev ]]
then
ewarn
ewarn "You need to add udev to the sysinit runlevel."
@@ -66,7 +66,7 @@ pkg_postinst()
ewarn "Run this command:"
ewarn "\trc-update add udev sysinit"
fi
- if [[ ! -e "${ROOT}"/etc/runlevels/sysinit/udev-mount ]]
+ if [[ ! -e "${ROOT}"etc/runlevels/sysinit/udev-mount ]]
then
ewarn
ewarn "You need to add udev-mount to the sysinit runlevel."