summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/iptables/ChangeLog8
-rw-r--r--sys-apps/iptables/files/digest-iptables-1.2.71
-rw-r--r--sys-apps/iptables/iptables-1.2.7.ebuild58
3 files changed, 66 insertions, 1 deletions
diff --git a/sys-apps/iptables/ChangeLog b/sys-apps/iptables/ChangeLog
index f580ecc6dadb..17f05fcf6772 100644
--- a/sys-apps/iptables/ChangeLog
+++ b/sys-apps/iptables/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/iptables
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iptables/ChangeLog,v 1.4 2002/07/14 19:20:18 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iptables/ChangeLog,v 1.5 2002/08/17 13:57:49 aliz Exp $
+
+*iptables-1.2.7.ebuild (17 Aug 2002)
+
+ 17 Aug 2002; Daniel Ahlberg <aliz@gentoo.org> iptables-1.2.7.ebuild :
+ Version bump. Christian Parpart <cparpart@surakware.net> brought this to
+ our attention.
*iptables-1.2.6a-r1.ebuild (14 July 2002)
diff --git a/sys-apps/iptables/files/digest-iptables-1.2.7 b/sys-apps/iptables/files/digest-iptables-1.2.7
new file mode 100644
index 000000000000..fd9edd586c38
--- /dev/null
+++ b/sys-apps/iptables/files/digest-iptables-1.2.7
@@ -0,0 +1 @@
+MD5 3b25c9516071076d69458a144a5060c0 iptables-1.2.7.tar.bz2 118619
diff --git a/sys-apps/iptables/iptables-1.2.7.ebuild b/sys-apps/iptables/iptables-1.2.7.ebuild
new file mode 100644
index 000000000000..a02293338bc0
--- /dev/null
+++ b/sys-apps/iptables/iptables-1.2.7.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iptables/iptables-1.2.7.ebuild,v 1.1 2002/08/17 13:57:49 aliz Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Kernel 2.4 firewall, NAT and packet mangling tools"
+SRC_URI="http://netfilter.samba.org/files/${P}.tar.bz2"
+HOMEPAGE="http://www.iptables.org"
+KEYWORDS="x86 ppc sparc sparc64"
+SLOT="0"
+# iptables is dependent on kernel sources. Strange but true.
+DEPEND="virtual/glibc"
+LICENSE="GPL-2"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e "s/-O2/${CFLAGS}/g" -e "s:/usr/local::g" Makefile.orig > Makefile
+}
+
+src_compile() {
+ # iptables and libraries are now installed to /sbin and /lib, so that
+ # systems with remote network-mounted /usr filesystems can get their
+ # network interfaces up and running correctly without /usr.
+
+ # use make, not emake
+ make \
+ LIBDIR=/lib \
+ BINDIR=/sbin \
+ MANDIR=/usr/share/man \
+ INCDIR=/usr/include \
+ KERNEL_DIR=/usr/src/linux \
+ || die
+}
+
+src_install() {
+ dodir /usr/{lib,share/man/man8,sbin}
+ make \
+ LIBDIR=${D}/lib \
+ BINDIR=${D}/sbin \
+ MANDIR=${D}/usr/share/man \
+ INCDIR=${D}/usr/include \
+ install || die
+
+ dodoc COPYING KNOWN_BUGS
+ dodir /var/lib/iptables
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/iptables.init iptables
+ insinto /etc/conf.d
+ newins ${FILESDIR}/iptables.confd iptables
+}
+
+pkg_postinst() {
+ einfo "This package now includes an initscript which loads and saves"
+ einfo "rules stored in /var/lib/iptables/rules-save"
+ einfo "This location can be changed in /etc/conf.d/iptables"
+}