summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/kadu/ChangeLog6
-rw-r--r--net-im/kadu/kadu-0.4.1-r1.ebuild16
-rw-r--r--net-im/kadu/kadu-0.4.1.ebuild16
-rw-r--r--net-im/kadu/kadu-0.4.2.ebuild16
4 files changed, 29 insertions, 25 deletions
diff --git a/net-im/kadu/ChangeLog b/net-im/kadu/ChangeLog
index 0d2ea89ed89c..02f230ccd0e9 100644
--- a/net-im/kadu/ChangeLog
+++ b/net-im/kadu/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-im/kadu
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/kadu/ChangeLog,v 1.56 2007/02/11 18:16:25 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/kadu/ChangeLog,v 1.57 2007/04/15 22:38:20 opfer Exp $
+
+ 15 Apr 2007; Christian Faulhammer <opfer@gentoo.org> kadu-0.4.1.ebuild,
+ kadu-0.4.1-r1.ebuild, kadu-0.4.2.ebuild:
+ moved from USE flag tcltk to tk, see bug 17808
11 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> kadu-0.4.1.ebuild,
kadu-0.4.1-r1.ebuild, kadu-0.4.2.ebuild, kadu-0.4.3.ebuild,
diff --git a/net-im/kadu/kadu-0.4.1-r1.ebuild b/net-im/kadu/kadu-0.4.1-r1.ebuild
index dc68ffa0d08f..b53542ab5dab 100644
--- a/net-im/kadu/kadu-0.4.1-r1.ebuild
+++ b/net-im/kadu/kadu-0.4.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/kadu/kadu-0.4.1-r1.ebuild,v 1.4 2007/02/11 18:16:25 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/kadu/kadu-0.4.1-r1.ebuild,v 1.5 2007/04/15 22:38:20 opfer Exp $
inherit flag-o-matic eutils
@@ -37,7 +37,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="X debug alsa arts esd voice speech nas oss spell ssl tcltk xosd amarok extraicons extramodules mail"
+IUSE="X debug alsa arts esd voice speech nas oss spell ssl tk xosd amarok extraicons extramodules mail"
DEPEND="=x11-libs/qt-3*
media-libs/libsndfile
@@ -49,12 +49,12 @@ DEPEND="=x11-libs/qt-3*
spell? ( app-dicts/aspell-pl )
ssl? ( dev-libs/openssl )
speech? ( app-accessibility/powiedz )
- tcltk? ( >=dev-lang/tcl-8.4.0 >=dev-lang/tk-8.4.0 )
+ tk? ( >=dev-lang/tcl-8.4.0 >=dev-lang/tk-8.4.0 )
xosd? ( x11-libs/xosd )"
SRC_URI="http://kadu.net/download/stable/${P}.tar.bz2
amarok? ( http://scripts.one.pl/amarok/stable/0.4.0/amarok-${AMAROK}.tar.gz )
- tcltk? ( http://scripts.one.pl/tcl4kadu/files/stable/${PV}/tcl_scripting-${TCL}.tar.gz )
+ tk? ( http://scripts.one.pl/tcl4kadu/files/stable/${PV}/tcl_scripting-${TCL}.tar.gz )
extraicons? (
http://biprowod.wroclaw.pl/kadu/kadu-theme-alt_cryst.tar.bz2
http://www.kadu.net/download/additions/kadu-theme-crystal-16.tar.bz2
@@ -123,7 +123,7 @@ src_unpack() {
enable_module spell spellchecker
enable_module xosd xosd_notify
enable_module mail mail
- enable_module tcltk "tcl_scripting"
+ enable_module tk "tcl_scripting"
enable_module extramodules weather
enable_module extramodules ext_info
@@ -159,7 +159,7 @@ src_compile() {
module_config desktop_docking m
if use extramodules; then
- if use !tcltk; then
+ if use ! tk; then
ewarn "script_chess depends on module_tcl_scripting;"
ewarn "It won't be installed."
fi
@@ -167,7 +167,7 @@ src_compile() {
# Firewall
if use extramodules; then
- if use !tcltk; then
+ if use ! tk; then
ewarn "script_firewall depends on module_tcl_scripting;"
ewarn "It won't be installed."
fi
@@ -222,7 +222,7 @@ src_install() {
# Installing additional scripts and plugins
# Chess and Firewall
if use extramodules; then
- if use tcltk; then
+ if use tk; then
einfo "Installing Chess script"
insinto /usr/share/kadu/modules/data/tcl_scripting/scripts
doins ${WORKDIR}/KaduChess/{data,pics,KaduChess.tcl}
diff --git a/net-im/kadu/kadu-0.4.1.ebuild b/net-im/kadu/kadu-0.4.1.ebuild
index 84aaec2eff97..c3d2fee92a74 100644
--- a/net-im/kadu/kadu-0.4.1.ebuild
+++ b/net-im/kadu/kadu-0.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/kadu/kadu-0.4.1.ebuild,v 1.7 2007/02/11 18:16:25 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/kadu/kadu-0.4.1.ebuild,v 1.8 2007/04/15 22:38:20 opfer Exp $
inherit flag-o-matic eutils
@@ -37,7 +37,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE="X debug alsa arts esd voice speech nas oss spell ssl tcltk xosd amarok extraicons extramodules mail"
+IUSE="X debug alsa arts esd voice speech nas oss spell ssl tk xosd amarok extraicons extramodules mail"
DEPEND="=x11-libs/qt-3*
media-libs/libsndfile
@@ -49,13 +49,13 @@ DEPEND="=x11-libs/qt-3*
spell? ( app-dicts/aspell-pl )
ssl? ( dev-libs/openssl )
speech? ( app-accessibility/powiedz )
- tcltk? ( >=dev-lang/tcl-8.4.0 >=dev-lang/tk-8.4.0 )
+ tk? ( >=dev-lang/tcl-8.4.0 >=dev-lang/tk-8.4.0 )
xosd? ( x11-libs/xosd )"
SRC_URI="http://kadu.net/download/stable/${P}.tar.bz2
http://biprowod.wroclaw.pl/kadu/smieci/tabs-${VTABS}.tar.bz2
amarok? ( http://scripts.one.pl/amarok/stable/0.4.0/amarok-${VAMAROK}.tar.gz )
- tcltk? ( http://scripts.one.pl/tcl4kadu/files/snapshots/tcl_scripting-${VTCL}.tar.gz )
+ tk? ( http://scripts.one.pl/tcl4kadu/files/snapshots/tcl_scripting-${VTCL}.tar.gz )
extraicons? (
http://biprowod.wroclaw.pl/kadu/kadu-theme-alt_cryst.tar.bz2
http://www.kadu.net/download/additions/kadu-theme-crystal-16.tar.bz2
@@ -121,7 +121,7 @@ src_unpack() {
enable_module spell spellchecker
enable_module xosd xosd_notify
enable_module mail mail
- enable_module tcltk "tcl_scripting"
+ enable_module tk "tcl_scripting"
enable_module extramodules weather
enable_module extramodules ext_info
@@ -157,7 +157,7 @@ src_compile() {
module_config desktop_docking m
if use extramodules; then
- if use !tcltk; then
+ if use ! tk; then
ewarn "script_chess depends on module_tcl_scripting;"
ewarn "It won't be installed."
fi
@@ -165,7 +165,7 @@ src_compile() {
# Firewall
if use extramodules; then
- if use !tcltk; then
+ if use ! tk; then
ewarn "script_firewall depends on module_tcl_scripting;"
ewarn "It won't be installed."
fi
@@ -220,7 +220,7 @@ src_install() {
# Installing additional scripts and plugins
# Chess and Firewall
if use extramodules; then
- if use tcltk; then
+ if use tk; then
einfo "Installing Chess script"
insinto /usr/share/kadu/modules/data/tcl_scripting/scripts
doins ${WORKDIR}/KaduChess/{data,pics,KaduChess.tcl}
diff --git a/net-im/kadu/kadu-0.4.2.ebuild b/net-im/kadu/kadu-0.4.2.ebuild
index efc3b778a821..443083577227 100644
--- a/net-im/kadu/kadu-0.4.2.ebuild
+++ b/net-im/kadu/kadu-0.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/kadu/kadu-0.4.2.ebuild,v 1.8 2007/02/11 18:16:25 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/kadu/kadu-0.4.2.ebuild,v 1.9 2007/04/15 22:38:20 opfer Exp $
inherit flag-o-matic eutils
@@ -38,7 +38,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc x86"
-IUSE="debug alsa arts esd voice speech nas oss spell ssl tcltk
+IUSE="debug alsa arts esd voice speech nas oss spell ssl tk
xosd amarok extraicons extramodules mail config_wizard"
DEPEND="=x11-libs/qt-3*
@@ -57,13 +57,13 @@ DEPEND="=x11-libs/qt-3*
spell? ( app-dicts/aspell-pl )
ssl? ( dev-libs/openssl )
speech? ( app-accessibility/powiedz )
- tcltk? ( >=dev-lang/tcl-8.4.0 >=dev-lang/tk-8.4.0 )
+ tk? ( >=dev-lang/tk-8.4.0 )
xosd? ( x11-libs/xosd )"
SRC_URI="http://kadu.net/download/stable/${P}.tar.bz2
amarok? ( http://scripts.one.pl/amarok/stable/0.4.0/amarok-${AMAROK}.tar.gz )
- tcltk? ( http://scripts.one.pl/tcl4kadu/files/stable/${PV}/tcl_scripting-${TCL}.tar.gz )
+ tk? ( http://scripts.one.pl/tcl4kadu/files/stable/${PV}/tcl_scripting-${TCL}.tar.gz )
extraicons? (
http://biprowod.wroclaw.pl/kadu/kadu-theme-alt_cryst.tar.bz2
http://www.kadu.net/download/additions/kadu-theme-crystal-16.tar.bz2
@@ -132,7 +132,7 @@ src_unpack() {
enable_module spell spellchecker
enable_module xosd xosd_notify
enable_module mail mail
- enable_module tcltk "tcl_scripting"
+ enable_module tk "tcl_scripting"
enable_module extramodules weather
enable_module extramodules ext_info
@@ -167,7 +167,7 @@ src_compile() {
( module_config sound m; module_config config_wizard m )
if use extramodules; then
- if use !tcltk; then
+ if use ! tk; then
ewarn "script_chess depends on module_tcl_scripting;"
ewarn "It won't be installed."
fi
@@ -175,7 +175,7 @@ src_compile() {
# Firewall
if use extramodules; then
- if use !tcltk; then
+ if use ! tk; then
ewarn "script_firewall depends on module_tcl_scripting;"
ewarn "It won't be installed."
fi
@@ -232,7 +232,7 @@ src_install() {
# Installing additional scripts and plugins
# Chess and Firewall
if use extramodules; then
- if use tcltk; then
+ if use tk; then
einfo "Installing Chess script"
insinto /usr/share/kadu/modules/data/tcl_scripting/scripts
doins ${WORKDIR}/KaduChess/{data,pics,KaduChess.tcl}