summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/rsync/files/digest-rsync-2.6.02
-rw-r--r--net-misc/rsync/files/digest-rsync-2.6.0-r13
-rw-r--r--net-misc/rsync/rsync-2.6.0-r1.ebuild75
-rw-r--r--net-misc/rsync/rsync-2.6.0-r2.ebuild6
-rw-r--r--net-misc/rsync/rsync-2.6.0.ebuild71
-rw-r--r--sys-libs/readline/readline-4.3-r5.ebuild7
-rw-r--r--sys-libs/readline/readline-4.3-r6.ebuild7
7 files changed, 10 insertions, 161 deletions
diff --git a/net-misc/rsync/files/digest-rsync-2.6.0 b/net-misc/rsync/files/digest-rsync-2.6.0
deleted file mode 100644
index 8ced31bf6984..000000000000
--- a/net-misc/rsync/files/digest-rsync-2.6.0
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 3f24bf31aec0a657eb3b6844c3f09f21 rsync-2.6.0.tar.gz 464920
-MD5 a399e227a18ea3f2eb5aa2b401006d2d rsync-2.5.6-proxy-auth-1.patch 4353
diff --git a/net-misc/rsync/files/digest-rsync-2.6.0-r1 b/net-misc/rsync/files/digest-rsync-2.6.0-r1
deleted file mode 100644
index 42e8d077802b..000000000000
--- a/net-misc/rsync/files/digest-rsync-2.6.0-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 3f24bf31aec0a657eb3b6844c3f09f21 rsync-2.6.0.tar.gz 464920
-MD5 a399e227a18ea3f2eb5aa2b401006d2d rsync-2.5.6-proxy-auth-1.patch 4353
-MD5 16cbffdcd9c6c318761c6c0d86400197 rsync-2.6.0-acl.diff.bz2 60721
diff --git a/net-misc/rsync/rsync-2.6.0-r1.ebuild b/net-misc/rsync/rsync-2.6.0-r1.ebuild
deleted file mode 100644
index 27be92b68b8d..000000000000
--- a/net-misc/rsync/rsync-2.6.0-r1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/rsync-2.6.0-r1.ebuild,v 1.5 2004/07/01 21:50:14 squinky86 Exp $
-
-inherit eutils flag-o-matic gcc
-
-DESCRIPTION="File transfer program to keep remote files into sync"
-HOMEPAGE="http://rsync.samba.org/"
-SRC_URI="http://rsync.samba.org/ftp/rsync/${P}.tar.gz
- http://www.imada.sdu.dk/~bardur/personal/patches/${PN}-proxy-auth/${PN}-2.5.6-proxy-auth-1.patch
- acl? ( http://www.saout.de/misc/${P}-acl.diff.bz2 )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha arm ~hppa ~amd64 ~ia64 ~ppc64 s390"
-IUSE="build static acl"
-
-RDEPEND="virtual/libc
- !build? ( >=dev-libs/popt-1.5 )"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4
- acl? ( sys-apps/acl )"
-
-src_unpack() {
- unpack "${P}.tar.gz"
- cd ${S}
- epatch "${DISTDIR}/${PN}-2.5.6-proxy-auth-1.patch"
- use acl && epatch ${DISTDIR}/${P}-acl.diff.bz2
-
- # change confdir to /etc/rsync rather than just /etc (the --sysconfdir
- # configure option doesn't work
- sed -i \
- -e 's|/etc/rsyncd.conf|/etc/rsync/rsyncd.conf|g' rsync.h \
- || die "sed rsync.h failed"
- # yes, updating the man page is very important.
- sed -i \
- -e 's|/etc/rsyncd|/etc/rsync/rsyncd|g' rsyncd.conf.5 \
- || die "sed rsyncd.conf.5 failed"
-}
-
-src_compile() {
- [ "`gcc-version`" == "2.95" ] && append-ldflags -lpthread
- use static && append-ldflags -static
- export LDFLAGS
- econf $(use_with build included-popt) \
- $(use_with acl acl-support) || die
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- insinto /etc/conf.d && newins "${FILESDIR}/rsyncd.conf.d" rsyncd
- exeinto /etc/init.d && newexe "${FILESDIR}/rsyncd.init.d" rsyncd
- if ! use build ; then
- dodir /etc/rsync
- dodoc NEWS OLDNEWS README TODO tech_report.tex
- if [ ! -e /etc/rsync/rsyncd.conf ] ; then
- insinto /etc/rsync
- doins "${FILESDIR}/rsyncd.conf"
- fi
- else
- rm -rf "${D}/usr/share"
- fi
-}
-
-pkg_postinst() {
- ewarn "Please make sure you do NOT disable the rsync server running"
- ewarn "in a chroot. Please check /etc/rsync/rsyncd.conf and make sure"
- ewarn "it says: use chroot = yes"
-
- einfo 'This patch enables usage of user:pass@proxy.foo:port'
- einfo 'in the RSYNC_PROXY environment variable to support'
- einfo 'the "Basic" proxy authentication scheme if you are'
- einfo 'behind a password protected HTTP proxy.'
-}
diff --git a/net-misc/rsync/rsync-2.6.0-r2.ebuild b/net-misc/rsync/rsync-2.6.0-r2.ebuild
index d8d09ce8ca27..05bc1ed9720a 100644
--- a/net-misc/rsync/rsync-2.6.0-r2.ebuild
+++ b/net-misc/rsync/rsync-2.6.0-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/rsync-2.6.0-r2.ebuild,v 1.10 2004/07/14 02:30:56 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/rsync-2.6.0-r2.ebuild,v 1.11 2004/07/27 14:31:34 vapier Exp $
-inherit eutils flag-o-matic gcc
+inherit eutils flag-o-matic gcc gnuconfig
DESCRIPTION="File transfer program to keep remote files into sync"
HOMEPAGE="http://rsync.samba.org/"
@@ -37,6 +37,8 @@ src_unpack() {
sed -i \
-e 's|/etc/rsyncd|/etc/rsync/rsyncd|g' rsyncd.conf.5 \
|| die "sed rsyncd.conf.5 failed"
+
+ gnuconfig_update
}
src_compile() {
diff --git a/net-misc/rsync/rsync-2.6.0.ebuild b/net-misc/rsync/rsync-2.6.0.ebuild
deleted file mode 100644
index e4b4943da067..000000000000
--- a/net-misc/rsync/rsync-2.6.0.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/rsync-2.6.0.ebuild,v 1.7 2004/07/01 21:50:14 squinky86 Exp $
-
-inherit eutils flag-o-matic gcc
-
-DESCRIPTION="File transfer program to keep remote files into sync"
-HOMEPAGE="http://rsync.samba.org/"
-SRC_URI="http://rsync.samba.org/ftp/rsync/${P}.tar.gz
- http://www.imada.sdu.dk/~bardur/personal/patches/${PN}-proxy-auth/${PN}-2.5.6-proxy-auth-1.patch"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ppc sparc mips alpha hppa amd64 ia64 ppc64 s390"
-IUSE="build static"
-
-RDEPEND="virtual/libc
- !build? ( >=dev-libs/popt-1.5 )"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
-
-src_unpack() {
- unpack "${P}.tar.gz"
- cd ${S}
- epatch "${DISTDIR}/${PN}-2.5.6-proxy-auth-1.patch"
-
- # change confdir to /etc/rsync rather than just /etc (the --sysconfdir
- # configure option doesn't work
- sed -i \
- -e 's|/etc/rsyncd.conf|/etc/rsync/rsyncd.conf|g' rsync.h \
- || die "sed rsync.h failed"
- # yes, updating the man page is very important.
- sed -i \
- -e 's|/etc/rsyncd|/etc/rsync/rsyncd|g' rsyncd.conf.5 \
- || die "sed rsyncd.conf.5 failed"
-}
-
-src_compile() {
- [ "`gcc-version`" == "2.95" ] && append-ldflags -lpthread
- use static && append-ldflags -static
- export LDFLAGS
- econf $(use_with build included-popt) || die
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- insinto /etc/conf.d && newins "${FILESDIR}/rsyncd.conf.d" rsyncd
- exeinto /etc/init.d && newexe "${FILESDIR}/rsyncd.init.d" rsyncd
- if ! use build ; then
- dodir /etc/rsync
- dodoc NEWS OLDNEWS README TODO tech_report.tex
- if [ ! -e /etc/rsync/rsyncd.conf ] ; then
- insinto /etc/rsync
- doins "${FILESDIR}/rsyncd.conf"
- fi
- else
- rm -rf "${D}/usr/share"
- fi
-}
-
-pkg_postinst() {
- ewarn "Please make sure you do NOT disable the rsync server running"
- ewarn "in a chroot. Please check /etc/rsync/rsyncd.conf and make sure"
- ewarn "it says: use chroot = yes"
-
- einfo 'This patch enables usage of user:pass@proxy.foo:port'
- einfo 'in the RSYNC_PROXY environment variable to support'
- einfo 'the "Basic" proxy authentication scheme if you are'
- einfo 'behind a password protected HTTP proxy.'
-}
diff --git a/sys-libs/readline/readline-4.3-r5.ebuild b/sys-libs/readline/readline-4.3-r5.ebuild
index 3bf8bd0ca88e..4031c27a3155 100644
--- a/sys-libs/readline/readline-4.3-r5.ebuild
+++ b/sys-libs/readline/readline-4.3-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-4.3-r5.ebuild,v 1.11 2004/06/24 23:09:19 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-4.3-r5.ebuild,v 1.12 2004/07/27 14:29:18 vapier Exp $
inherit eutils gnuconfig
@@ -31,12 +31,11 @@ src_unpack() {
do
epatch ${DISTDIR}/${PN}${PV/\.}-${x}
done
+
+ gnuconfig_update
}
src_compile() {
- # Detect mips systems properly
- use mips && gnuconfig_update
-
econf --with-curses || die
emake || die
diff --git a/sys-libs/readline/readline-4.3-r6.ebuild b/sys-libs/readline/readline-4.3-r6.ebuild
index 745bad3f08bd..af997e575d4b 100644
--- a/sys-libs/readline/readline-4.3-r6.ebuild
+++ b/sys-libs/readline/readline-4.3-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-4.3-r6.ebuild,v 1.1 2004/07/11 02:32:29 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-4.3-r6.ebuild,v 1.2 2004/07/27 14:29:18 vapier Exp $
inherit eutils gnuconfig
@@ -32,12 +32,11 @@ src_unpack() {
epatch ${DISTDIR}/${PN}${PV/\.}-${x}
done
use macos && epatch ${FILESDIR}/macos.patch
+
+ gnuconfig_update
}
src_compile() {
- # Detect mips systems properly
- use mips && gnuconfig_update
-
econf --with-curses || die
emake || die