summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/cogl/ChangeLog9
-rw-r--r--media-libs/cogl/cogl-1.10.4.ebuild5
-rw-r--r--media-libs/cogl/cogl-1.12.0.ebuild102
-rw-r--r--media-libs/cogl/files/cogl-1.12.0-fix-experimental-doc-build.patch33
-rw-r--r--media-libs/cogl/metadata.xml2
5 files changed, 146 insertions, 5 deletions
diff --git a/media-libs/cogl/ChangeLog b/media-libs/cogl/ChangeLog
index a63ccc8e8b47..271ccd5c3ee2 100644
--- a/media-libs/cogl/ChangeLog
+++ b/media-libs/cogl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/cogl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/cogl/ChangeLog,v 1.16 2012/12/05 23:58:06 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/cogl/ChangeLog,v 1.17 2012/12/16 22:03:51 tetromino Exp $
+
+*cogl-1.12.0 (16 Dec 2012)
+
+ 16 Dec 2012; Alexandre Rostovtsev <tetromino@gentoo.org> cogl-1.10.4.ebuild,
+ +cogl-1.12.0.ebuild, +files/cogl-1.12.0-fix-experimental-doc-build.patch,
+ metadata.xml:
+ Version bump for gnome-3.6. Switch to global introspection USE flag.
05 Dec 2012; Alexandre Rostovtsev <tetromino@gentoo.org> cogl-1.10.4.ebuild:
Accidentally set wrong subslot.
diff --git a/media-libs/cogl/cogl-1.10.4.ebuild b/media-libs/cogl/cogl-1.10.4.ebuild
index 8ac5c6e7bfe6..a4950d521974 100644
--- a/media-libs/cogl/cogl-1.10.4.ebuild
+++ b/media-libs/cogl/cogl-1.10.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/cogl/cogl-1.10.4.ebuild,v 1.4 2012/12/05 23:58:06 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/cogl/cogl-1.10.4.ebuild,v 1.5 2012/12/16 22:03:51 tetromino Exp $
EAPI="5"
CLUTTER_LA_PUNT="yes"
@@ -46,7 +46,7 @@ DEPEND="${COMMON_DEPEND}
src_prepare() {
DOCS="NEWS README"
EXAMPLES="examples/{*.c,*.jpg}"
- # XXX: think about kms-egl, gles, quartz, sdl, wayland
+ # XXX: think about kms-egl, quartz, sdl, wayland
G2CONF="${G2CONF}
--disable-examples-install
--disable-profile
@@ -62,6 +62,7 @@ src_prepare() {
$(use_enable introspection)
$(use_enable pango cogl-pango)
$(use_enable doc gtk-doc)"
+ # Really need --enable-gtk-doc for docs
# USE=doc build failure; in 1.12.x; bug #436308
epatch "${FILESDIR}/${PN}-1.10.4-cogl-clipping.xml.patch"
diff --git a/media-libs/cogl/cogl-1.12.0.ebuild b/media-libs/cogl/cogl-1.12.0.ebuild
new file mode 100644
index 000000000000..04a4e6a676ff
--- /dev/null
+++ b/media-libs/cogl/cogl-1.12.0.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/cogl/cogl-1.12.0.ebuild,v 1.1 2012/12/16 22:03:51 tetromino Exp $
+
+EAPI="5"
+CLUTTER_LA_PUNT="yes"
+
+# Inherit gnome2 after clutter to download sources from gnome.org
+inherit eutils clutter gnome2 multilib virtualx
+
+DESCRIPTION="A library for using 3D graphics hardware to draw pretty pictures"
+HOMEPAGE="http://www.clutter-project.org/"
+
+LICENSE="LGPL-2.1+ FDL-1.1+"
+SLOT="1.0/11"
+IUSE="doc examples +introspection +opengl gles2 +pango"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~x86"
+
+# XXX: need uprof for optional profiling support
+COMMON_DEPEND=">=dev-libs/glib-2.28.0:2
+ x11-libs/cairo:=
+ >=x11-libs/gdk-pixbuf-2:2
+ x11-libs/libdrm:=
+ x11-libs/libX11
+ >=x11-libs/libXcomposite-0.4
+ x11-libs/libXdamage
+ x11-libs/libXext
+ >=x11-libs/libXfixes-3
+ virtual/glu
+ virtual/opengl
+ gles2? ( media-libs/mesa[gles2] )
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ pango? ( >=x11-libs/pango-1.20.0[introspection?] )"
+# before clutter-1.7, cogl was part of clutter
+RDEPEND="${COMMON_DEPEND}
+ !<media-libs/clutter-1.7"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? ( app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/gtk-doc-1.13 )
+ test? ( app-admin/eselect-opengl
+ media-libs/mesa[classic] )"
+# Need classic mesa swrast for tests, llvmpipe causes a test failure
+
+src_prepare() {
+ DOCS="NEWS README"
+ EXAMPLES="examples/{*.c,*.jpg}"
+ # XXX: think about kms-egl, quartz, sdl, wayland
+ G2CONF="${G2CONF}
+ --disable-examples-install
+ --disable-profile
+ --disable-maintainer-flags
+ --enable-cairo
+ --enable-gdk-pixbuf
+ $(use_enable opengl glx)
+ $(use_enable opengl gl)
+ $(use_enable gles2)
+ $(use_enable gles2 cogl-gles2)
+ $(use_enable gles2 xlib-egl-platform)
+ "$(usex gles2 --with-default-driver=gles2 "")"
+ --enable-glib
+ --enable-deprecated
+ $(use_enable introspection)
+ $(use_enable pango cogl-pango)
+ $(use_enable doc gtk-doc)"
+ # Really need --enable-gtk-doc for docs
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=684731
+ epatch "${FILESDIR}/${PN}-1.12.0-fix-experimental-doc-build.patch"
+ gnome2_src_prepare
+}
+
+src_test() {
+ # Use swrast for tests, llvmpipe is incomplete and "test_sub_texture" fails
+ # NOTE: recheck if this is needed after every mesa bump
+ if [[ "$(eselect opengl show)" != "xorg-x11" ]]; then
+ ewarn "Skipping tests because a binary OpenGL library is enabled. To"
+ ewarn "run tests for ${PN}, you need to enable the Mesa library:"
+ ewarn "# eselect opengl set xorg-x11"
+ return
+ fi
+ LIBGL_DRIVERS_PATH="${EROOT}/usr/$(get_libdir)/mesa" Xemake check
+}
+
+src_install() {
+ clutter_src_install
+
+ # Remove silly examples-data directory
+ rm -rvf "${ED}/usr/share/cogl/examples-data/" || die
+}
+
+pkg_preinst() {
+ gnome2_pkg_preinst
+ preserve_old_lib /usr/$(get_libdir)/libcogl.so.9
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ preserve_old_lib_notify /usr/$(get_libdir)/libcogl.so.9
+}
diff --git a/media-libs/cogl/files/cogl-1.12.0-fix-experimental-doc-build.patch b/media-libs/cogl/files/cogl-1.12.0-fix-experimental-doc-build.patch
new file mode 100644
index 000000000000..9bd80183b164
--- /dev/null
+++ b/media-libs/cogl/files/cogl-1.12.0-fix-experimental-doc-build.patch
@@ -0,0 +1,33 @@
+Author: Dimitri <mitya@mageia.org>
+
+Build breaks on cogl-2.0-experimental docs
+
+https://bugzilla.gnome.org/show_bug.cgi?id=684731
+
+--- a/cogl/cogl-context.h
++++ b/cogl/cogl-context.h
+@@ -72,19 +72,19 @@
+ * help applications control the lifetime a context without us needing to
+ * introduce special api to handle the breakup of internal circular
+ * references due to internal resources and caches associated with the
+- * context.
++ * context.</note>
+ *
+- * One a context has been destroyed then all directly or indirectly
++ * <note>One a context has been destroyed then all directly or indirectly
+ * dependant resources will be in an inconsistent state and should not
+- * be manipulated or queried in any way.
++ * be manipulated or queried in any way.</note>
+ *
+- * For applications that rely on the operating system to clean up
++ * <note>For applications that rely on the operating system to clean up
+ * resources this policy shouldn't affect them, but for applications
+ * that need to carefully destroy and re-create Cogl contexts multiple
+ * times throughout their lifetime (such as Android applications) they
+ * should be careful to destroy all context dependant resources, such as
+ * framebuffers or textures etc before unrefing and destroying the
+- * context.<note>
++ * context.</note>
+ */
+
+ #ifdef COGL_ENABLE_EXPERIMENTAL_API
diff --git a/media-libs/cogl/metadata.xml b/media-libs/cogl/metadata.xml
index e7297b672f22..8ba968705519 100644
--- a/media-libs/cogl/metadata.xml
+++ b/media-libs/cogl/metadata.xml
@@ -4,8 +4,6 @@
<herd>gnome</herd>
<use>
<flag name="gles2">Enable OpenGL ES 2.0 support</flag>
- <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg>
- for introspection</flag>
<flag name="pango">Build cogl-pango library for <pkg>x11-libs/pango</pkg>
integration</flag>
</use>