summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/slop/ChangeLog7
-rw-r--r--dev-ruby/slop/slop-3.0.2.ebuild24
2 files changed, 30 insertions, 1 deletions
diff --git a/dev-ruby/slop/ChangeLog b/dev-ruby/slop/ChangeLog
index 8bcc25b7b50c..0e7fa955f18d 100644
--- a/dev-ruby/slop/ChangeLog
+++ b/dev-ruby/slop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/slop
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/slop/ChangeLog,v 1.6 2012/01/28 09:37:47 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/slop/ChangeLog,v 1.7 2012/01/28 10:25:07 graaff Exp $
+
+*slop-3.0.2 (28 Jan 2012)
+
+ 28 Jan 2012; Hans de Graaff <graaff@gentoo.org> +slop-3.0.2.ebuild:
+ Version bump.
28 Jan 2012; Hans de Graaff <graaff@gentoo.org> -slop-2.1.0.ebuild,
-slop-2.4.0.ebuild:
diff --git a/dev-ruby/slop/slop-3.0.2.ebuild b/dev-ruby/slop/slop-3.0.2.ebuild
new file mode 100644
index 000000000000..6ead51d8d1ab
--- /dev/null
+++ b/dev-ruby/slop/slop-3.0.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/slop/slop-3.0.2.ebuild,v 1.1 2012/01/28 10:25:07 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple option parser with an easy to remember syntax and friendly API."
+HOMEPAGE="https://github.com/injekt/slop"
+SRC_URI="https://github.com/injekt/slop/tarball/v${PV} -> ${P}.tgz"
+RUBY_S="injekt-slop-*"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64"
+
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"