summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/mico/ChangeLog12
-rwxr-xr-xnet-misc/mico/files/gtk-config2
-rw-r--r--net-misc/mico/files/mico-2.3.13-gcc43.patch25
-rw-r--r--net-misc/mico/files/mico-2.3.13-nolibcheck.patch32
-rw-r--r--net-misc/mico/metadata.xml12
-rw-r--r--net-misc/mico/mico-2.3.13.ebuild93
6 files changed, 176 insertions, 0 deletions
diff --git a/net-misc/mico/ChangeLog b/net-misc/mico/ChangeLog
new file mode 100644
index 000000000000..9b3f1f0399c4
--- /dev/null
+++ b/net-misc/mico/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for net-misc/mico
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mico/ChangeLog,v 1.15 2009/02/09 16:49:04 haubi Exp $
+
+*mico-2.3.13 (09 Feb 2009)
+
+ 09 Feb 2009; Michael Haubenwallner <haubi@gentoo.org>
+ +files/mico-2.3.13-gcc43.patch, +files/mico-2.3.13-nolibcheck.patch,
+ +files/gtk-config, +metadata.xml, +mico-2.3.13.ebuild:
+ added mico-2.3.13 (#257984), without bluetooth/wireless/sl3ac, with gcc43
+ patch from Malcolm MacLeod <mmacleod@webmail.co.za>
+
diff --git a/net-misc/mico/files/gtk-config b/net-misc/mico/files/gtk-config
new file mode 100755
index 000000000000..14cfa421b380
--- /dev/null
+++ b/net-misc/mico/files/gtk-config
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec pkg-config gtk+-2.0 $(printf "%s" "$*" | sed s:--version:--modversion:)
diff --git a/net-misc/mico/files/mico-2.3.13-gcc43.patch b/net-misc/mico/files/mico-2.3.13-gcc43.patch
new file mode 100644
index 000000000000..eb9578f31058
--- /dev/null
+++ b/net-misc/mico/files/mico-2.3.13-gcc43.patch
@@ -0,0 +1,25 @@
+Patch to compile with gcc-4.3, thanks to Malcolm MacLeod <mmacleod@webmail.co.za>
+
+diff -ru mico.orig/include/mico/throw.h mico/include/mico/throw.h
+--- mico.orig/include/mico/throw.h 2008-07-25 15:41:44.000000000 +0200
++++ mico/include/mico/throw.h 2009-02-09 16:16:54.000000000 +0100
+@@ -25,7 +25,7 @@
+ #define __mico_throw_h__
+
+ #include <stdarg.h>
+-#include <string.h>
++#include <cstring>
+
+ #ifdef HAVE_EXCEPTIONS
+ #define MICO_CATCHANY(x) try { x; } catch (...) {}
+diff -ru mico.orig/orb/fast_array.cc mico/orb/fast_array.cc
+--- mico.orig/orb/fast_array.cc 2008-07-25 15:41:43.000000000 +0200
++++ mico/orb/fast_array.cc 2009-02-09 16:17:29.000000000 +0100
+@@ -40,6 +40,7 @@
+
+ #endif // FAST_PCH
+
++#include <limits.h>
+
+ using namespace std;
+
diff --git a/net-misc/mico/files/mico-2.3.13-nolibcheck.patch b/net-misc/mico/files/mico-2.3.13-nolibcheck.patch
new file mode 100644
index 000000000000..158ed2affbd9
--- /dev/null
+++ b/net-misc/mico/files/mico-2.3.13-nolibcheck.patch
@@ -0,0 +1,32 @@
+don't check for libbsd and libelf, they aren't needed anywhere.
+
+--- configure.in.orig 2009-02-02 14:34:14.000000000 +0100
++++ configure.in 2009-02-02 14:37:45.000000000 +0100
+@@ -1237,9 +1237,7 @@
+
+
+ AC_CHECK_LIB(socket, open)
+-AC_CHECK_LIB(bsd, open)
+
+-AC_CHECK_LIB(elf, open)
+ AC_CHECK_LIB(dl, open)
+ AC_CHECK_LIB(dld, open)
+ AC_CHECK_LIB(ld, open)
+--- configure.orig 2009-02-02 14:34:02.000000000 +0100
++++ configure 2009-02-02 14:36:34.000000000 +0100
+@@ -5864,6 +5864,7 @@
+ echo $ac_n "checking for open in -lbsd""... $ac_c" 1>&6
+ echo "configure:5866: checking for open in -lbsd" >&5
+ ac_lib_var=`echo bsd'_'open | sed 'y%./+-%__p_%'`
++eval ac_cv_lib_$ac_lib_var=no
+ if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+@@ -5915,6 +5916,7 @@
+ echo $ac_n "checking for open in -lelf""... $ac_c" 1>&6
+ echo "configure:5917: checking for open in -lelf" >&5
+ ac_lib_var=`echo elf'_'open | sed 'y%./+-%__p_%'`
++eval ac_cv_lib_$ac_lib_var=no
+ if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
diff --git a/net-misc/mico/metadata.xml b/net-misc/mico/metadata.xml
new file mode 100644
index 000000000000..c137100eac39
--- /dev/null
+++ b/net-misc/mico/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd></herd>
+ <maintainer>
+ <email>haubi@gentoo.org</email>
+ <name>Michael Haubenwallner</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+</pkgmetadata>
+
diff --git a/net-misc/mico/mico-2.3.13.ebuild b/net-misc/mico/mico-2.3.13.ebuild
new file mode 100644
index 000000000000..d94bb9ea6a0d
--- /dev/null
+++ b/net-misc/mico/mico-2.3.13.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mico/mico-2.3.13.ebuild,v 1.1 2009/02/09 16:49:04 haubi Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="A freely available and fully compliant implementation of the CORBA standard"
+HOMEPAGE="http://www.mico.org/"
+SRC_URI="http://www.mico.org/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="gtk postgres qt3 ssl tcl threads X"
+
+# doesn't compile:
+# bluetooth? ( net-wireless/bluez-libs )
+
+RDEPEND="
+ gtk? ( >=x11-libs/gtk+-2 )
+ postgres? ( dev-db/postgresql )
+ qt3? ( =x11-libs/qt-3* )
+ ssl? ( dev-libs/openssl )
+ tcl? ( dev-lang/tcl )
+ X? ( x11-libs/libXt )
+"
+DEPEND="${RDEPEND}
+ >=sys-devel/flex-2.5.2
+ >=sys-devel/bison-1.22
+"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}" || die "failed to cd to '${S}'"
+
+ epatch "${FILESDIR}"/${P}-nolibcheck.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
+
+src_compile() {
+ tc-export CC CXX
+
+ if use gtk; then
+ # set up gtk-1 wrapper for gtk-2
+ mkdir "${T}"/path || die "failed to create temporary path"
+ cp "${FILESDIR}"/gtk-config "${T}"/path || die "failed to dupe gtk-config"
+ chmod +x "${T}"/path/gtk-config || die "failed to arm gtk-config"
+ export PATH="${T}"/path:${PATH}
+ fi
+
+ # Don't know which version of JavaCUP would suffice, but there is no
+ # configure argument to disable checking for JavaCUP.
+ # So we override the configure check to not find 'javac'.
+ export ac_cv_path_JAVAC=no
+
+ # '--without-ssl' just does not add another search path - the only way
+ # to disable openssl utilization seems to override the configure check.
+ use ssl || export ac_cv_lib_ssl_open=no
+
+ # '--without-*' or '--with-*=no' does not disable some features, the value
+ # needs to be empty instead. This applies to: bluetooth, gtk, pgsql, qt, tcl.
+ # But --without-x works.
+
+ # moc is searched within PATH, not within QTDIR.
+ use qt3 && export MOC="${QTDIR}"/bin/moc
+
+ # bluetooth and wireless both don't compile cleanly
+ econf \
+ --disable-mini-stl \
+ $(use_enable threads) \
+ --with-gtk=$(use gtk && echo /usr) \
+ --with-pgsql=$(use postgres && echo /usr) \
+ --with-qt=$(use qt3 && echo "${QTDIR}") \
+ --with-tcl=$(use tcl && echo /usr) \
+ $(use_with X x /usr) \
+ --with-bluetooth='' \
+ --disable-wireless
+
+ emake || die "make failed"
+}
+
+src_install() {
+ emake INSTDIR="${D}"/usr SHARED_INSTDIR="${D}"/usr install || die "install failed"
+
+ dodir /usr/share || die
+ mv "${D}"/usr/man "${D}"/usr/share || die
+ dodir /usr/share/doc/${PF} || die
+ mv "${D}"/usr/doc "${D}"/usr/share/doc/${PF} || die
+
+ dodoc BUGS CHANGES* CONVERT FAQ README* ROADMAP TODO VERSION WTODO || die
+}