summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/faac/ChangeLog9
-rw-r--r--media-libs/faac/faac-1.28-r1.ebuild7
-rw-r--r--media-libs/faac/files/faac-1.28-altivec.patch40
3 files changed, 51 insertions, 5 deletions
diff --git a/media-libs/faac/ChangeLog b/media-libs/faac/ChangeLog
index 62c65375371e..b36fab7913ca 100644
--- a/media-libs/faac/ChangeLog
+++ b/media-libs/faac/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/faac
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/faac/ChangeLog,v 1.80 2010/09/16 00:54:42 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/faac/ChangeLog,v 1.81 2011/03/06 11:29:18 xarthisius Exp $
+
+ 06 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> faac-1.28-r1.ebuild,
+ +files/faac-1.28-altivec.patch:
+ Add workaround for altivec wrt #306881. Thanks to Andrew John Hughes
+ <gnu_andrew@member.fsf.org> for report and thorough analysis.
16 Sep 2010; Samuli Suominen <ssuominen@gentoo.org> faac-1.28-r1.ebuild:
USE="static-libs" and punt .la files.
diff --git a/media-libs/faac/faac-1.28-r1.ebuild b/media-libs/faac/faac-1.28-r1.ebuild
index 7c9cfde1307e..74bda8406624 100644
--- a/media-libs/faac/faac-1.28-r1.ebuild
+++ b/media-libs/faac/faac-1.28-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/faac/faac-1.28-r1.ebuild,v 1.10 2010/09/16 00:54:42 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/faac/faac-1.28-r1.ebuild,v 1.11 2011/03/06 11:29:18 xarthisius Exp $
EAPI=2
inherit autotools eutils
@@ -18,7 +18,8 @@ RDEPEND=">=media-libs/libmp4v2-1.9.0"
DEPEND="${RDEPEND}"
src_prepare() {
- epatch "${FILESDIR}"/${P}-external-libmp4v2.patch
+ epatch "${FILESDIR}"/${P}-external-libmp4v2.patch \
+ "${FILESDIR}"/${P}-altivec.patch
eautoreconf
epunt_cxx
}
diff --git a/media-libs/faac/files/faac-1.28-altivec.patch b/media-libs/faac/files/faac-1.28-altivec.patch
new file mode 100644
index 000000000000..ae461efc30d3
--- /dev/null
+++ b/media-libs/faac/files/faac-1.28-altivec.patch
@@ -0,0 +1,40 @@
+http://bugs.gentoo.org/306881
+
+--- configure.in
++++ configure.in
+@@ -33,7 +33,12 @@
+ AC_CHECK_DECLS([MP4Create, MP4MetadataDelete],
+ AC_CHECK_LIB(mp4v2, MP4MetadataDelete, external_mp4v2=yes,
+ external_mp4v2=no, -lstdc++),
+- external_mp4v2=no, [#include <mp4v2/mp4v2.h>])
++ external_mp4v2=no, [
++ #if defined(__ALTIVEC__)
++ #undef bool
++ #endif
++ #include <mp4v2/mp4v2.h>
++ ])
+
+ if test x$external_mp4v2 = xyes; then
+ AC_MSG_NOTICE([*** Building with external mp4v2 ***])
+--- frontend/main.c
++++ frontend/main.c
+@@ -30,6 +30,9 @@
+ #endif
+
+ #ifdef HAVE_LIBMP4V2
++#if defined(__ALTIVEC__)
++# undef bool
++#endif
+ # include <mp4v2/mp4v2.h>
+ #endif
+
+--- common/mp4v2/mpeg4ip.h
++++ common/mp4v2/mpeg4ip.h
+@@ -123,7 +123,6 @@
+ #ifdef __cplusplus
+ extern "C" {
+ #endif
+-char *strcasestr(const char *haystack, const char *needle);
+ #ifdef __cplusplus
+ }
+ #endif