summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-java/jexcelapi/ChangeLog11
-rw-r--r--dev-java/jexcelapi/Manifest2
-rw-r--r--dev-java/jexcelapi/files/2.5.1-jikes.patch17
-rw-r--r--dev-java/jexcelapi/files/digest-jexcelapi-2.5.11
-rw-r--r--dev-java/jexcelapi/jexcelapi-2.5.1.ebuild51
-rw-r--r--dev-java/jexcelapi/metadata.xml11
6 files changed, 93 insertions, 0 deletions
diff --git a/dev-java/jexcelapi/ChangeLog b/dev-java/jexcelapi/ChangeLog
new file mode 100644
index 000000000000..cb34e66f0ecb
--- /dev/null
+++ b/dev-java/jexcelapi/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-java/jexcelapi
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jexcelapi/ChangeLog,v 1.1 2005/01/23 14:50:15 luckyduck Exp $
+
+*jexcelapi-2.5.1 (23 Jan 2005)
+
+ 23 Jan 2005; Jan Brinkmann <luckyduck@gentoo.org> +metadata.xml,
+ +files/2.5.1-jikes.patch, +jexcelapi-2.5.1.ebuild:
+ Initial import, ebuild based on the contribution of Eddy Mulyono
+ <eddymulyono@mail.com>. fixes #76209.
+
diff --git a/dev-java/jexcelapi/Manifest b/dev-java/jexcelapi/Manifest
new file mode 100644
index 000000000000..a2c68c75ccc0
--- /dev/null
+++ b/dev-java/jexcelapi/Manifest
@@ -0,0 +1,2 @@
+MD5 81b76371e7806a69ef839346e1d7c212 jexcelapi-2.5.1.ebuild 865
+MD5 862d1074e51b2c7387bbe2d6fcf2dbee files/digest-jexcelapi-2.5.1 68
diff --git a/dev-java/jexcelapi/files/2.5.1-jikes.patch b/dev-java/jexcelapi/files/2.5.1-jikes.patch
new file mode 100644
index 000000000000..413575950289
--- /dev/null
+++ b/dev-java/jexcelapi/files/2.5.1-jikes.patch
@@ -0,0 +1,17 @@
+diff -uprN jexcelapi.orig/src/jxl/write/biff/CompoundFile.java jexcelapi/src/jxl/write/biff/CompoundFile.java
+--- jexcelapi.orig/src/jxl/write/biff/CompoundFile.java 2005-01-23 15:39:35.389297104 +0100
++++ jexcelapi/src/jxl/write/biff/CompoundFile.java 2005-01-23 15:40:59.715477576 +0100
+@@ -169,11 +169,11 @@ final class CompoundFile extends BaseCom
+ */
+ private static final class ReadPropertyStorage
+ {
+- PropertyStorage propertyStorage;
++ jxl.biff.BaseCompoundFile.PropertyStorage propertyStorage;
+ byte[] data;
+ int number;
+
+- ReadPropertyStorage(PropertyStorage ps, byte[] d, int n)
++ ReadPropertyStorage(jxl.biff.BaseCompoundFile.PropertyStorage ps, byte[] d, int n)
+ {
+ propertyStorage = ps;
+ data = d;
diff --git a/dev-java/jexcelapi/files/digest-jexcelapi-2.5.1 b/dev-java/jexcelapi/files/digest-jexcelapi-2.5.1
new file mode 100644
index 000000000000..24ed8103769a
--- /dev/null
+++ b/dev-java/jexcelapi/files/digest-jexcelapi-2.5.1
@@ -0,0 +1 @@
+MD5 e9965a51f3c91b1a0103dc41833b5589 jexcelapi_2_5_1.tar.gz 1409973
diff --git a/dev-java/jexcelapi/jexcelapi-2.5.1.ebuild b/dev-java/jexcelapi/jexcelapi-2.5.1.ebuild
new file mode 100644
index 000000000000..18056f377291
--- /dev/null
+++ b/dev-java/jexcelapi/jexcelapi-2.5.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jexcelapi/jexcelapi-2.5.1.ebuild,v 1.1 2005/01/23 14:50:15 luckyduck Exp $
+
+inherit eutils java-pkg
+
+MY_P="${P//-/_}"
+MY_P="${MY_P//./_}"
+
+DESCRIPTION="A Java API to read, write, and modify Excel spreadsheets"
+HOMEPAGE="http://jexcelapi.sourceforge.net/"
+SRC_URI="mirror://sourceforge/jexcelapi/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="2.5"
+KEYWORDS="~x86 ~amd64"
+
+IUSE="doc jikes"
+DEPEND=">=virtual/jdk-1.3
+ dev-java/ant-core
+ jikes? ( dev-java/jikes )"
+RDEPEND=">=virtual/jre-1.3"
+RESTRICT="nomirror"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-jikes.patch
+
+ rm -rf jxl.jar docs
+}
+
+src_compile() {
+ local antflags="jxl"
+ use doc && antflags="${antflags} docs"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+
+ cd ${S}/build
+ ant ${antflags} || die "ant failed"
+}
+
+src_install() {
+ mv jxl.jar ${PN}.jar
+ java-pkg_dojar ${PN}.jar
+
+ java-pkg_dohtml index.html tutorial.html
+ use doc && java-pkg_dohtml -r docs/*
+}
diff --git a/dev-java/jexcelapi/metadata.xml b/dev-java/jexcelapi/metadata.xml
new file mode 100644
index 000000000000..1f0ef76d3211
--- /dev/null
+++ b/dev-java/jexcelapi/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+
+<longdescription>
+
+ Java Excel API is a mature, open source java API enabling developers to read, write, and modifiy Excel spreadsheets dynamically. Now java developers can read Excel spreadsheets, modify them with a convenient and simple API, and write the changes to any output stream (e.g. disk, HTTP, database, or any socket).
+
+</longdescription>
+</pkgmetadata>