summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/eog/ChangeLog6
-rw-r--r--media-gfx/eog/eog-0.6-r2.ebuild49
-rw-r--r--media-gfx/eog/files/digest-eog-0.6-r21
3 files changed, 55 insertions, 1 deletions
diff --git a/media-gfx/eog/ChangeLog b/media-gfx/eog/ChangeLog
index 3f4c9f301eee..70bc37248350 100644
--- a/media-gfx/eog/ChangeLog
+++ b/media-gfx/eog/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/eog
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/ChangeLog,v 1.1 2002/02/01 21:53:29 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/ChangeLog,v 1.2 2002/02/19 21:20:08 azarah Exp $
+
+ 19 Feb 2002; M.Schlemmer <azarah@gentoo.org> eog-0.6-r2.ebuild :
+
+ Fix SANDBOX errors for locale files and schema files.
*eog-0.6-r1 (1 Feb 2002)
diff --git a/media-gfx/eog/eog-0.6-r2.ebuild b/media-gfx/eog/eog-0.6-r2.ebuild
new file mode 100644
index 000000000000..6210ff3f0f1e
--- /dev/null
+++ b/media-gfx/eog/eog-0.6-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/eog-0.6-r2.ebuild,v 1.1 2002/02/19 21:20:08 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Eye of GNOME"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/eog/${P}.tar.gz"
+HOMEPAGE="http://www.gnome.org/gnome-office/eog.shtml"
+
+RDEPEND="virtual/glibc
+ >=gnome-base/gconf-1.0.4-r2
+ >=gnome-base/bonobo-1.0.9-r1"
+
+DEPEND="${RDEPEND}
+ virtual/glibc
+ nls? ( sys-devel/gettext )
+ >=dev-util/intltool-0.11"
+
+
+src_compile() {
+
+ local myconf
+
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=/var/lib \
+ GCONF_CONFIG_SOURCE="xml::${D}/etc/gconf/gconf.xml.defaults" \
+ install || die
+
+ dodoc AUTHORS COPYING DEPENDS ChangeLog HACKING NEWS README \
+ TODO MAINTAINERS
+}
+
diff --git a/media-gfx/eog/files/digest-eog-0.6-r2 b/media-gfx/eog/files/digest-eog-0.6-r2
new file mode 100644
index 000000000000..941eb438c206
--- /dev/null
+++ b/media-gfx/eog/files/digest-eog-0.6-r2
@@ -0,0 +1 @@
+MD5 e843959ff17f847e27a3219ac6cafcc7 eog-0.6.tar.gz 425084