summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/mesa/ChangeLog6
-rw-r--r--media-libs/mesa/mesa-6.4.2-r2.ebuild9
-rw-r--r--media-libs/mesa/mesa-6.5-r3.ebuild9
3 files changed, 21 insertions, 3 deletions
diff --git a/media-libs/mesa/ChangeLog b/media-libs/mesa/ChangeLog
index b76270380ea3..ce46d6374af7 100644
--- a/media-libs/mesa/ChangeLog
+++ b/media-libs/mesa/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/mesa
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.89 2006/06/21 06:07:43 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.90 2006/06/30 06:16:05 spyderous Exp $
+
+ 30 Jun 2006; Donnie Berkholz <spyderous@gentoo.org>; mesa-6.4.2-r2.ebuild,
+ mesa-6.5-r3.ebuild:
+ Add hardened USE flag to deactivate assembly code.
21 Jun 2006; Donnie Berkholz <spyderous@gentoo.org>; mesa-6.5-r3.ebuild:
(#130951) Fix libGLU symlink (Torsten Veller).
diff --git a/media-libs/mesa/mesa-6.4.2-r2.ebuild b/media-libs/mesa/mesa-6.4.2-r2.ebuild
index f90bf8c03cf0..1594536b4cf0 100644
--- a/media-libs/mesa/mesa-6.4.2-r2.ebuild
+++ b/media-libs/mesa/mesa-6.4.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-6.4.2-r2.ebuild,v 1.7 2006/04/16 20:21:31 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-6.4.2-r2.ebuild,v 1.8 2006/06/30 06:16:05 spyderous Exp $
inherit eutils toolchain-funcs multilib flag-o-matic portability
@@ -31,6 +31,7 @@ IUSE_VIDEO_CARDS="
video_cards_via"
IUSE="${IUSE_VIDEO_CARDS}
debug
+ hardened
motif"
RDEPEND="dev-libs/expat
@@ -190,6 +191,12 @@ src_unpack() {
echo "ASM_SOURCES =" >> ${HOSTCONF}
fi
+ if use hardened; then
+ einfo "Deactivating assembly code for hardened build"
+ echo "ASM_FLAGS =" >> ${HOSTCONF}
+ echo "ASM_SOURCES =" >> ${HOSTCONF}
+ fi
+
# Kill this; we don't want /usr/X11R6/lib ever to be searched in this
# build.
echo "EXTRA_LIB_PATH =" >> ${HOSTCONF}
diff --git a/media-libs/mesa/mesa-6.5-r3.ebuild b/media-libs/mesa/mesa-6.5-r3.ebuild
index c022cb04595c..baf721980887 100644
--- a/media-libs/mesa/mesa-6.5-r3.ebuild
+++ b/media-libs/mesa/mesa-6.5-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-6.5-r3.ebuild,v 1.2 2006/06/21 06:07:43 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-6.5-r3.ebuild,v 1.3 2006/06/30 06:16:05 spyderous Exp $
inherit eutils toolchain-funcs multilib flag-o-matic portability
@@ -31,6 +31,7 @@ IUSE_VIDEO_CARDS="
video_cards_via"
IUSE="${IUSE_VIDEO_CARDS}
debug
+ hardened
motif
nptl"
@@ -181,6 +182,12 @@ src_unpack() {
# Set drivers to everything on which we ran add_drivers()
echo "DRI_DIRS = ${DRI_DRIVERS}" >> ${HOSTCONF}
+ if use hardened; then
+ einfo "Deactivating assembly code for hardened build"
+ echo "ASM_FLAGS =" >> ${HOSTCONF}
+ echo "ASM_SOURCES =" >> ${HOSTCONF}
+ fi
+
if use sparc; then
einfo "Sparc assembly code is not working; deactivating"
echo "ASM_FLAGS =" >> ${HOSTCONF}