summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/sphinx/ChangeLog6
-rw-r--r--app-misc/sphinx/files/sphinx-2.0.1_beta-darwin8.patch22
-rw-r--r--app-misc/sphinx/sphinx-2.0.1_beta.ebuild6
3 files changed, 31 insertions, 3 deletions
diff --git a/app-misc/sphinx/ChangeLog b/app-misc/sphinx/ChangeLog
index 110196cfd845..2a7116688e80 100644
--- a/app-misc/sphinx/ChangeLog
+++ b/app-misc/sphinx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/sphinx
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/ChangeLog,v 1.35 2011/05/13 18:28:58 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/ChangeLog,v 1.36 2011/05/29 15:31:35 grobian Exp $
+
+ 29 May 2011; Fabian Groffen <grobian@gentoo.org> sphinx-2.0.1_beta.ebuild,
+ +files/sphinx-2.0.1_beta-darwin8.patch:
+ Fixed for and keyworded ~ppc-macos and ~x86-macos
*sphinx-2.0.1_beta (13 May 2011)
diff --git a/app-misc/sphinx/files/sphinx-2.0.1_beta-darwin8.patch b/app-misc/sphinx/files/sphinx-2.0.1_beta-darwin8.patch
new file mode 100644
index 000000000000..e0dcd54097fd
--- /dev/null
+++ b/app-misc/sphinx/files/sphinx-2.0.1_beta-darwin8.patch
@@ -0,0 +1,22 @@
+Darwin8 has no backtrace functionalities yet
+
+--- src/sphinxutils.cpp
++++ src/sphinxutils.cpp
+@@ -1364,6 +1364,9 @@
+ }
+ sphSafeInfo ( iFD, "Stack bottom = 0x%p, thread stack size = 0x%x", pMyStack, iStackSize );
+
++#ifndef SIGRETURN_FRAME_OFFSET
++ sphLogFatal ( "Cannot get stack frame pointer on this architecture" );
++#else
+ while ( pMyStack && !bSafe )
+ {
+ sphSafeInfo ( iFD, "begin of manual backtrace:" );
+@@ -1421,6 +1424,7 @@
+
+ break;
+ }
++#endif
+
+ #if HAVE_BACKTRACE
+ sphSafeInfo ( iFD, "begin of system backtrace:" );
diff --git a/app-misc/sphinx/sphinx-2.0.1_beta.ebuild b/app-misc/sphinx/sphinx-2.0.1_beta.ebuild
index e06c936f09a4..f34c9e9fe078 100644
--- a/app-misc/sphinx/sphinx-2.0.1_beta.ebuild
+++ b/app-misc/sphinx/sphinx-2.0.1_beta.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/sphinx-2.0.1_beta.ebuild,v 1.1 2011/05/13 18:28:58 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/sphinx-2.0.1_beta.ebuild,v 1.2 2011/05/29 15:31:35 grobian Exp $
EAPI=3
inherit eutils autotools
@@ -18,7 +18,7 @@ SRC_URI="http://sphinxsearch.com/files/${MY_P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~ppc-macos ~x86-macos"
IUSE="debug id64 mysql odbc postgres stemmer test"
RDEPEND="mysql? ( virtual/mysql )
@@ -39,6 +39,8 @@ src_unpack() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-darwin8.patch
+
# drop nasty hardcoded search path breaking Prefix
sed -i -e '/\/usr\/local\//d' configure.ac || die
eautoreconf