summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/dgs/ChangeLog6
-rw-r--r--app-text/dgs/dgs-0.5.10-r1.ebuild14
-rw-r--r--app-text/dgs/files/dgs-0.5.10-tcpd-gentoo.diff28
3 files changed, 38 insertions, 10 deletions
diff --git a/app-text/dgs/ChangeLog b/app-text/dgs/ChangeLog
index 903b02445250..7e9c424ba9f8 100644
--- a/app-text/dgs/ChangeLog
+++ b/app-text/dgs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/dgs
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dgs/ChangeLog,v 1.13 2004/04/03 14:52:23 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dgs/ChangeLog,v 1.14 2004/04/15 17:54:06 usata Exp $
+
+ 16 Apr 2004; Mamoru KOMACHI <usata@gentoo.org> dgs-0.5.10-r1.ebuild,
+ files/dgs-0.5.10-tcpd-gentoo.diff:
+ Real fix for tcpd IUSE flag issue. See bug #34016 and #34037
03 Apr 2004; Mamoru KOMACHI <usata@gentoo.org> dgs-0.5.10-r1.ebuild:
Added tcpd IUSE flag check. Thanks to Cory Visi <cory@visi.name> for the
diff --git a/app-text/dgs/dgs-0.5.10-r1.ebuild b/app-text/dgs/dgs-0.5.10-r1.ebuild
index 52e3afc296d6..ce0584548926 100644
--- a/app-text/dgs/dgs-0.5.10-r1.ebuild
+++ b/app-text/dgs/dgs-0.5.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dgs/dgs-0.5.10-r1.ebuild,v 1.23 2004/04/07 21:41:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dgs/dgs-0.5.10-r1.ebuild,v 1.24 2004/04/15 17:54:06 usata Exp $
inherit gnuconfig eutils
@@ -17,24 +17,20 @@ RDEPEND="=dev-libs/glib-1.2*
virtual/x11"
DEPEND="${RDEPEND}
sys-apps/texinfo
+ sys-devel/autoconf
tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
-pkg_setup() {
- if has_version 'sys-apps/tcp-wrappers' && ! use tcpd ; then
- ewarn "tcp-wrappers will be detected by the package and support will be enabled"
- ewarn "The package presently provides no way to disable tcp-wrappers support if you don't want it"
- fi
-}
-
src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${P}-gs-time_.h-gentoo.diff
+ epatch ${FILESDIR}/${P}-tcpd-gentoo.diff
use amd64 && gnuconfig_update
}
src_compile() {
- econf --with-x || die
+ WANT_AUTOCONF=2.1 autoconf
+ econf --with-x `use_enable tcpd` || die
make || die
}
diff --git a/app-text/dgs/files/dgs-0.5.10-tcpd-gentoo.diff b/app-text/dgs/files/dgs-0.5.10-tcpd-gentoo.diff
new file mode 100644
index 000000000000..fe80988f0b6c
--- /dev/null
+++ b/app-text/dgs/files/dgs-0.5.10-tcpd-gentoo.diff
@@ -0,0 +1,28 @@
+diff -urN dgs-0.5.10.ORIG/configure.in dgs-0.5.10/configure.in
+--- dgs-0.5.10.ORIG/configure.in 2000-05-08 12:38:17.000000000 +0900
++++ dgs-0.5.10/configure.in 2004-04-16 02:14:40.029905480 +0900
+@@ -163,9 +163,13 @@
+ # TCP wrappers check from gnome-core
+ #--------------------------------------------------------------------
+
++AC_ARG_ENABLE(tcpd,
++ [ --disable-tcpd Disable tcpd support.],,
++ enable_tcpd=yes)
+ AC_CHECK_HEADERS(tcpd.h)
+ AC_CHECK_HEADERS(syslog.h)
+ AC_MSG_CHECKING("whether to use TCP wrappers")
++if test "x$enable_tcpd" = "xyes"; then
+ LIBWRAP_PATH=""
+ for I in $LDFLAGS $LIBS -L/usr/lib -L/usr/local/lib; do
+ case "$I" in
+@@ -246,6 +250,10 @@
+ AC_DEFINE(HAVE_HOSTS_ACCESS)
+ fi
+ AC_SUBST(LIBWRAP_LIBS)
++else
++ AC_MSG_RESULT(no)
++ enable_tcpd=no
++fi
+
+ #--------------------------------------------------------------------
+ # For now we assume that gcc will be used to compile ghostscript.