summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/ncmpcpp/ChangeLog12
-rw-r--r--media-sound/ncmpcpp/ncmpcpp-0.3.2.ebuild42
-rw-r--r--media-sound/ncmpcpp/ncmpcpp-0.3.4.ebuild42
-rw-r--r--media-sound/ncmpcpp/ncmpcpp-0.5.ebuild65
4 files changed, 75 insertions, 86 deletions
diff --git a/media-sound/ncmpcpp/ChangeLog b/media-sound/ncmpcpp/ChangeLog
index d54b27237db8..0483331b09b3 100644
--- a/media-sound/ncmpcpp/ChangeLog
+++ b/media-sound/ncmpcpp/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/ncmpcpp
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ncmpcpp/ChangeLog,v 1.22 2009/10/21 12:21:07 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ncmpcpp/ChangeLog,v 1.23 2010/01/02 14:38:55 yngwin Exp $
+
+*ncmpcpp-0.5 (02 Jan 2010)
+
+ 02 Jan 2010; Ben de Groot <yngwin@gentoo.org> -ncmpcpp-0.3.2.ebuild,
+ -ncmpcpp-0.3.4.ebuild, +ncmpcpp-0.5.ebuild:
+ Version bump. Add new dependency on libmpdclient. Force USE=visualizer on
+ for USE=fftw. Use dodoc to install documentation. Fixes bug 299283.
+ Remove obsolete versions.
21 Oct 2009; Markus Meier <maekke@gentoo.org> ncmpcpp-0.3.5.ebuild:
x86 stable, bug #285872
diff --git a/media-sound/ncmpcpp/ncmpcpp-0.3.2.ebuild b/media-sound/ncmpcpp/ncmpcpp-0.3.2.ebuild
deleted file mode 100644
index de603a6bc247..000000000000
--- a/media-sound/ncmpcpp/ncmpcpp-0.3.2.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ncmpcpp/ncmpcpp-0.3.2.ebuild,v 1.2 2009/05/03 15:04:59 maekke Exp $
-
-EAPI="2"
-inherit eutils
-
-DESCRIPTION="An ncurses mpd client, ncmpc clone with some new features, written in C++"
-HOMEPAGE="http://unkart.ovh.org/ncmpcpp"
-SRC_URI="http://unkart.ovh.org/${PN}/${P}.tar.bz2"
-LICENSE="GPL-2"
-IUSE="clock curl taglib unicode"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-DEPEND="sys-libs/ncurses[unicode?]
- curl? ( net-misc/curl )
- taglib? ( media-libs/taglib )"
-RDEPEND="$DEPEND"
-
-src_configure() {
- econf $(use_enable unicode) $(use_enable clock) \
- $(use_with curl) $(use_with taglib)
-}
-
-src_install() {
- emake install DESTDIR="${D}" docdir="/usr/share/doc/${PF}" \
- || die "install failed"
- prepalldocs
-}
-
-pkg_postinst() {
- echo
- elog "Example configuration files have been installed at"
- elog "${ROOT}usr/share/doc/${PF}"
- elog "${P} uses ~/.ncmpcpp/config and ~/.ncmpcpp/keys"
- elog "as user configuration files."
- echo
- elog "This version of ncmpcpp uses features from mpd-0.14, so"
- elog "we recommend you use this with >=mpd-0.14_alpha1."
- echo
-}
diff --git a/media-sound/ncmpcpp/ncmpcpp-0.3.4.ebuild b/media-sound/ncmpcpp/ncmpcpp-0.3.4.ebuild
deleted file mode 100644
index e96db06e031f..000000000000
--- a/media-sound/ncmpcpp/ncmpcpp-0.3.4.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ncmpcpp/ncmpcpp-0.3.4.ebuild,v 1.1 2009/05/19 22:07:06 yngwin Exp $
-
-EAPI="2"
-inherit eutils
-
-DESCRIPTION="An ncurses mpd client, ncmpc clone with some new features, written in C++"
-HOMEPAGE="http://unkart.ovh.org/ncmpcpp"
-SRC_URI="http://unkart.ovh.org/${PN}/${P}.tar.bz2"
-LICENSE="GPL-2"
-IUSE="clock curl taglib unicode"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="sys-libs/ncurses[unicode?]
- curl? ( net-misc/curl )
- taglib? ( media-libs/taglib )"
-RDEPEND="$DEPEND"
-
-src_configure() {
- econf $(use_enable unicode) $(use_enable clock) \
- $(use_with curl) $(use_with taglib)
-}
-
-src_install() {
- emake install DESTDIR="${D}" docdir="/usr/share/doc/${PF}" \
- || die "install failed"
- prepalldocs
-}
-
-pkg_postinst() {
- echo
- elog "Example configuration files have been installed at"
- elog "${ROOT}usr/share/doc/${PF}"
- elog "${P} uses ~/.ncmpcpp/config and ~/.ncmpcpp/keys"
- elog "as user configuration files."
- echo
- elog "This version of ncmpcpp uses features from mpd-0.14, and optionally"
- elog "from 0.15, so we recommend you use this with >=mpd-0.14."
- echo
-}
diff --git a/media-sound/ncmpcpp/ncmpcpp-0.5.ebuild b/media-sound/ncmpcpp/ncmpcpp-0.5.ebuild
new file mode 100644
index 000000000000..5a8a68dccdde
--- /dev/null
+++ b/media-sound/ncmpcpp/ncmpcpp-0.5.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ncmpcpp/ncmpcpp-0.5.ebuild,v 1.1 2010/01/02 14:38:55 yngwin Exp $
+
+EAPI="2"
+inherit bash-completion eutils
+
+DESCRIPTION="An ncurses mpd client, ncmpc clone with some new features, written in C++"
+HOMEPAGE="http://unkart.ovh.org/ncmpcpp"
+SRC_URI="http://unkart.ovh.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+IUSE="bash-completion clock curl fftw iconv outputs taglib +threads unicode visualizer"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+DEPEND="sys-libs/ncurses[unicode?]
+ >=media-libs/libmpdclient-2.1
+ curl? ( net-misc/curl )
+ visualizer? ( fftw? ( sci-libs/fftw:3.0 ) )
+ iconv? ( virtual/libiconv )
+ taglib? ( media-libs/taglib )"
+RDEPEND="$DEPEND"
+
+pkg_setup() {
+ if ( use fftw && ! use visualizer ); then
+ die "USE=fftw requires USE=visualizer enabled"
+ fi
+}
+
+src_configure() {
+ econf $(use_enable clock) \
+ $(use_enable outputs) \
+ $(use_enable unicode) \
+ $(use_enable visualizer) \
+ $(use_with curl) \
+ $(use_with fftw) \
+ $(use_with iconv) \
+ $(use_with threads) \
+ $(use_with taglib)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+
+ # use dodoc instead of upstream's doc install which does not compress
+ rm -rf "${D}"/usr/share/doc/${PN}
+ dodoc AUTHORS NEWS doc/config doc/keys || die "dodoc failed"
+
+ dobashcompletion doc/${PN}-completion.bash ${PN}
+}
+
+pkg_postinst() {
+ echo
+ elog "Example configuration files have been installed at"
+ elog "${ROOT}usr/share/doc/${PF}"
+ elog "${P} uses ~/.ncmpcpp/config and ~/.ncmpcpp/keys"
+ elog "as user configuration files."
+ echo
+ if use visualizer; then
+ elog "If you want to use the visualizer, you need mpd with fifo enabled."
+ echo
+ fi
+ bash-completion_pkg_postinst
+}