summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/protobuf-c/ChangeLog7
-rw-r--r--dev-libs/protobuf-c/protobuf-c-1.0.2.ebuild25
2 files changed, 31 insertions, 1 deletions
diff --git a/dev-libs/protobuf-c/ChangeLog b/dev-libs/protobuf-c/ChangeLog
index 2ddb77947a49..d06945de271a 100644
--- a/dev-libs/protobuf-c/ChangeLog
+++ b/dev-libs/protobuf-c/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/protobuf-c
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf-c/ChangeLog,v 1.10 2014/08/13 17:37:58 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf-c/ChangeLog,v 1.11 2014/10/07 06:51:28 radhermit Exp $
+
+*protobuf-c-1.0.2 (07 Oct 2014)
+
+ 07 Oct 2014; Tim Harder <radhermit@gentoo.org> +protobuf-c-1.0.2.ebuild:
+ Version bump.
13 Aug 2014; Anthony G. Basile <blueness@gentoo.org> protobuf-c-0.15.ebuild:
Keyword ~ppc and ~ppc64, bug #519772
diff --git a/dev-libs/protobuf-c/protobuf-c-1.0.2.ebuild b/dev-libs/protobuf-c/protobuf-c-1.0.2.ebuild
new file mode 100644
index 000000000000..c85170e184ad
--- /dev/null
+++ b/dev-libs/protobuf-c/protobuf-c-1.0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf-c/protobuf-c-1.0.2.ebuild,v 1.1 2014/10/07 06:51:28 radhermit Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+MY_PV=${PV/_/-}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="code generator and runtime libraries to use Protocol Buffers (protobuf) from pure C"
+HOMEPAGE="https://github.com/protobuf-c/protobuf-c/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/protobuf-2.5.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}