summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-plugins/wmxres/ChangeLog9
-rw-r--r--x11-plugins/wmxres/Manifest5
-rw-r--r--x11-plugins/wmxres/files/digest-wmxres-1.21
-rw-r--r--x11-plugins/wmxres/files/wmxres-debian-1.1-1.2.patch55
-rw-r--r--x11-plugins/wmxres/files/wmxres-makefile.patch16
-rw-r--r--x11-plugins/wmxres/files/wmxres.desktop11
-rw-r--r--x11-plugins/wmxres/metadata.xml5
-rw-r--r--x11-plugins/wmxres/wmxres-1.2.ebuild45
8 files changed, 147 insertions, 0 deletions
diff --git a/x11-plugins/wmxres/ChangeLog b/x11-plugins/wmxres/ChangeLog
new file mode 100644
index 000000000000..2202e0d4baf8
--- /dev/null
+++ b/x11-plugins/wmxres/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for x11-plugins/wmxres
+# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmxres/ChangeLog,v 1.1 2004/08/26 22:27:09 s4t4n Exp $
+
+*wmxres-1.2 (27 Aug 2004)
+
+ 27 Aug 2004; Michele Noberasco <s4t4n@gentoo.org> wmhdplop-1.2.ebuild:
+ Initial import. Thanks to Przemyslaw Maciag. Closes #61448.
+
diff --git a/x11-plugins/wmxres/Manifest b/x11-plugins/wmxres/Manifest
new file mode 100644
index 000000000000..921a9a21dd06
--- /dev/null
+++ b/x11-plugins/wmxres/Manifest
@@ -0,0 +1,5 @@
+MD5 092a4963173e0ca3d62aab1f2b25356a wmxres-1.2.ebuild 786
+MD5 7faef3c2696850855d3c04cf2db18b0b files/wmxres-makefile.patch 445
+MD5 be65102309ba38b2fe3e2daab694b3af files/digest-wmxres-1.2 62
+MD5 ecbe1a6bd91322603485bc0ab1198599 files/wmxres.desktop 209
+MD5 19ac74b1720f8fc5c6678e4830b0b016 files/wmxres-debian-1.1-1.2.patch 1699
diff --git a/x11-plugins/wmxres/files/digest-wmxres-1.2 b/x11-plugins/wmxres/files/digest-wmxres-1.2
new file mode 100644
index 000000000000..c1255f1345d9
--- /dev/null
+++ b/x11-plugins/wmxres/files/digest-wmxres-1.2
@@ -0,0 +1 @@
+MD5 a1b44620bd2f567c3f2a4b6767dedb33 wmxres-1.1-0.tar.gz 9948
diff --git a/x11-plugins/wmxres/files/wmxres-debian-1.1-1.2.patch b/x11-plugins/wmxres/files/wmxres-debian-1.1-1.2.patch
new file mode 100644
index 000000000000..ef7438e5e973
--- /dev/null
+++ b/x11-plugins/wmxres/files/wmxres-debian-1.1-1.2.patch
@@ -0,0 +1,55 @@
+diff -Naur wmxres.app/wmxres/wmxres.c wmxres-1.2/wmxres/wmxres.c
+--- wmxres.app/wmxres/wmxres.c 1999-11-13 22:43:12.000000000 +0000
++++ wmxres-1.2/wmxres/wmxres.c 2004-04-19 01:27:19.000000000 +0000
+@@ -29,7 +29,7 @@
+ int res_selected;
+ int res_i_active=-1;
+ char res_active[10];
+-char res_list[10][20];
++char res_list[100][20];
+ XF86VidModeModeInfo **res_modelines;
+ XEvent Event;
+
+@@ -139,7 +139,12 @@
+ }
+ }
+
+- for(c=0; c < res_count; c++) {
++ /* fix bounds on res_count -- Todd Troxell <ttroxell@debian.org */
++ if(res_count > 100) {
++ res_count =100;
++ }
++
++ for(c=0; c < res_count ; c++) {
+ sprintf(res_list[c], "%dx%d", res_modelines[c]->hdisplay, res_modelines[c]->vdisplay);
+ }
+ }
+diff -Naur wmxres.app/wmxres.1 wmxres-1.2/wmxres.1
+--- wmxres.app/wmxres.1 1970-01-01 00:00:00.000000000 +0000
++++ wmxres-1.2/wmxres.1 2004-04-19 01:02:46.000000000 +0000
+@@ -0,0 +1,25 @@
++.\" Hey, EMACS: -*- nroff -*-
++.\" wmxres.1 is copyright 2001 by
++.\" Todd Troxell <ttroxell@debian.org>
++.\"
++.\" This is free documentation, see the latest version of the GNU
++.\" General Public License for copying conditions. There is NO warranty.
++.TH WMXRES 1 "May 5, 2001"
++
++.SH NAME
++wmxres \- dockable application to change X modes
++
++.SH SYNOPSIS
++.B wmxres
++
++.SH DESCRIPTION
++dockable application to select your display mode from those available. It is written in C.
++
++.SH INFO
++This manual page was written for the Debian GNU/Linux distribution
++because the original program does not have a manual page.
++.PP
++
++.SH AUTHOR
++This manual page was written by Todd Troxell <ttroxell@debian.org>,
++for the Debian GNU/Linux system (but may be used by others).
diff --git a/x11-plugins/wmxres/files/wmxres-makefile.patch b/x11-plugins/wmxres/files/wmxres-makefile.patch
new file mode 100644
index 000000000000..62ec6cf3face
--- /dev/null
+++ b/x11-plugins/wmxres/files/wmxres-makefile.patch
@@ -0,0 +1,16 @@
+--- Makefile.orig 2004-08-23 17:25:43.471717952 +0000
++++ Makefile 2004-08-23 17:27:37.009457592 +0000
+@@ -2,10 +2,11 @@
+ LIBDIR = -L/usr/X11R6/lib
+ LIBS = -lXpm -lXext -lX11 -lXxf86vm
+ OBJS = wmxres/wmxres.o \
+- wmgeneral/wmgeneral.o \
++ wmgeneral/wmgeneral.o
++GCFLAGS =
+
+ .c.o:
+- cc -g -c -O2 -Wall -D$(shell echo `uname -s`) $< -o $*.o $(INCDIR)
++ cc -g -c -Wall -D$(shell echo `uname -s`) $(GCFLAGS) $< -o $*.o $(INCDIR)
+
+ all: wmxres
+
diff --git a/x11-plugins/wmxres/files/wmxres.desktop b/x11-plugins/wmxres/files/wmxres.desktop
new file mode 100644
index 000000000000..46f67941877b
--- /dev/null
+++ b/x11-plugins/wmxres/files/wmxres.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=WmXres
+Comment=Change resolution
+Comment[pl]=Zmiana rozdzielczości
+Exec=wmxres
+Terminal=false
+Type=Application
+Categories=Applet;
+NotShowIn=GNOME;KDE;
+Encoding=UTF-8
+# vi: encoding=utf-8
diff --git a/x11-plugins/wmxres/metadata.xml b/x11-plugins/wmxres/metadata.xml
new file mode 100644
index 000000000000..b1a9efc4f2f0
--- /dev/null
+++ b/x11-plugins/wmxres/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+</pkgmetadata>
diff --git a/x11-plugins/wmxres/wmxres-1.2.ebuild b/x11-plugins/wmxres/wmxres-1.2.ebuild
new file mode 100644
index 000000000000..428474ed89a9
--- /dev/null
+++ b/x11-plugins/wmxres/wmxres-1.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmxres/wmxres-1.2.ebuild,v 1.1 2004/08/26 22:27:09 s4t4n Exp $
+
+inherit eutils
+
+IUSE=""
+
+DESCRIPTION="Dock application to select your display mode among those possible"
+SRC_URI="http://yalla.free.fr/wn/${PN}-1.1-0.tar.gz"
+HOMEPAGE="http://yalla.free.fr/wn/"
+
+DEPEND="virtual/x11"
+
+SLOT="0"
+LICENSE="GPL-1"
+KEYWORDS="~x86"
+
+S="${WORKDIR}/${PN}.app"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-makefile.patch
+ epatch ${FILESDIR}/${PN}-debian-1.1-1.2.patch
+
+}
+
+src_compile() {
+
+ emake GCFLAGS="${CFLAGS}" || die "make failed"
+
+}
+
+src_install() {
+
+ dobin ${PN}/${PN}
+ doman ${PN}.1
+
+ insinto /usr/share/applications
+ doins ${FILESDIR}/${PN}.desktop
+
+}