summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/drush')
-rw-r--r--app-admin/drush/ChangeLog13
-rw-r--r--app-admin/drush/drush-4.4.ebuild35
-rw-r--r--app-admin/drush/metadata.xml18
3 files changed, 66 insertions, 0 deletions
diff --git a/app-admin/drush/ChangeLog b/app-admin/drush/ChangeLog
new file mode 100644
index 000000000000..b2d23e34dfce
--- /dev/null
+++ b/app-admin/drush/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-admin/drush
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/drush/ChangeLog,v 1.1 2011/05/26 22:22:01 ramereth Exp $
+
+*drush-4.4 (26 May 2011)
+
+ 26 May 2011; Lance Albertson <ramereth@gentoo.org> +drush-4.4.ebuild,
+ +metadata.xml:
+ Initial ebuild, resolves #313869
+
+ Thanks to Claes <letharion@gmail.com> and several others on the same ticket
+ for contributing to the original ebuild.
+
diff --git a/app-admin/drush/drush-4.4.ebuild b/app-admin/drush/drush-4.4.ebuild
new file mode 100644
index 000000000000..6b0a472cd8b0
--- /dev/null
+++ b/app-admin/drush/drush-4.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/drush/drush-4.4.ebuild,v 1.1 2011/05/26 22:22:01 ramereth Exp $
+
+EAPI="4"
+
+DESCRIPTION="Drush is a command line shell and scripting interface for Drupal"
+HOMEPAGE="http://drupal.org/project/drush"
+SRC_URI="http://ftp.drupal.org/files/projects/${PN}-7.x-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-lang/php[cli,simplexml] dev-php/pear"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ local docs="README.txt docs"
+
+ insinto /usr/share/drush
+ doins -r .
+ exeinto /usr/share/drush
+ doexe drush
+ dosym /usr/share/drush/drush /usr/bin/drush
+ dodoc -r ${docs}
+ # cleanup
+ for i in ${docs} LICENSE.txt drush.bat examples includes/.gitignore ; do
+ rm -rf "${D}/usr/share/drush/${i}"
+ done
+
+ use examples && cp -R examples "${D}"/usr/share/doc/"${PF}"
+}
diff --git a/app-admin/drush/metadata.xml b/app-admin/drush/metadata.xml
new file mode 100644
index 000000000000..f0999801847e
--- /dev/null
+++ b/app-admin/drush/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+ <maintainer>
+ <email>ramereth@gentoo.org</email>
+ <name>Lance Albertson</name>
+ </maintainer>
+ <longdescription lang="en">
+ Drush is a command line shell and scripting interface for Drupal, a
+ veritable Swiss Army knife designed to make life easier for those of us who
+ spend some of our working hours hacking away at the command prompt.
+
+ See http://drush.ws, the homepage for the drush project. It contains many
+ important resources for drush users.
+ </longdescription>
+</pkgmetadata>
+