summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/eselect-vi/eselect-vi-1.1.7-r1.ebuild')
-rw-r--r--app-admin/eselect-vi/eselect-vi-1.1.7-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-admin/eselect-vi/eselect-vi-1.1.7-r1.ebuild b/app-admin/eselect-vi/eselect-vi-1.1.7-r1.ebuild
new file mode 100644
index 000000000000..ada9e68b2fd2
--- /dev/null
+++ b/app-admin/eselect-vi/eselect-vi-1.1.7-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-vi/eselect-vi-1.1.7-r1.ebuild,v 1.1 2010/04/26 02:36:14 lack Exp $
+
+EAPI="3"
+inherit eutils
+
+DESCRIPTION="Manages the /usr/bin/vi symlink"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/vi.eselect-${PV}.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=app-admin/eselect-1.0.6"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-prefix.patch"
+}
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ newins "${WORKDIR}/vi.eselect-${PV}" vi.eselect || die
+}