summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/logrotate/logrotate-3.6.5-r1.ebuild')
-rw-r--r--app-admin/logrotate/logrotate-3.6.5-r1.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/app-admin/logrotate/logrotate-3.6.5-r1.ebuild b/app-admin/logrotate/logrotate-3.6.5-r1.ebuild
index b8dcb1947823..36e5308767ff 100644
--- a/app-admin/logrotate/logrotate-3.6.5-r1.ebuild
+++ b/app-admin/logrotate/logrotate-3.6.5-r1.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/logrotate-3.6.5-r1.ebuild,v 1.6 2003/09/20 19:56:29 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/logrotate-3.6.5-r1.ebuild,v 1.7 2003/10/29 03:16:04 pebenito Exp $
inherit eutils
+SELINUX_PATCH="logrotate-3.6.5-selinux.diff.bz2"
+
DESCRIPTION="Rotates, compresses, and mails system logs"
HOMEPAGE="http://packages.debian.org/unstable/admin/logrotate.html"
-SRC_URI="mirror://debian/pool/main/l/logrotate/${P/-/_}.orig.tar.gz
- selinux? http://www.nsa.gov/selinux/patches/${P}-2003011510.patch.gz"
+SRC_URI="mirror://debian/pool/main/l/logrotate/${P/-/_}.orig.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -17,12 +18,12 @@ IUSE="selinux"
DEPEND=">=sys-apps/portage-2.0.47-r10
>=dev-libs/popt-1.5
>=sys-apps/sed-4
- selinux? ( >=sys-apps/selinux-small-2003011510-r2 )"
+ selinux? ( sys-libs/libselinux )"
src_unpack() {
unpack ${PN}_${PV}.orig.tar.gz
- use selinux && epatch ${DISTDIR}/${P}-2003011510.patch.gz
+ use selinux && epatch ${FILESDIR}/${SELINUX_PATCH}
sed -i \
-e "s:CFLAGS += -g:CFLAGS += -g ${CFLAGS}:" \