summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/mcollective/ChangeLog7
-rw-r--r--app-admin/mcollective/mcollective-1.0.1.ebuild59
-rw-r--r--app-admin/mcollective/mcollective-1.1.4.ebuild60
-rw-r--r--app-admin/mcollective/mcollective-1.2.1.ebuild60
-rw-r--r--app-admin/mcollective/mcollective-2.0.0.ebuild60
-rw-r--r--app-admin/mcollective/metadata.xml3
6 files changed, 7 insertions, 242 deletions
diff --git a/app-admin/mcollective/ChangeLog b/app-admin/mcollective/ChangeLog
index 673e1351c81c..9b60440f453d 100644
--- a/app-admin/mcollective/ChangeLog
+++ b/app-admin/mcollective/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/mcollective
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/mcollective/ChangeLog,v 1.12 2013/03/25 20:52:59 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/mcollective/ChangeLog,v 1.13 2013/06/16 09:27:14 pacho Exp $
+
+ 16 Jun 2013; Pacho Ramos <pacho@gentoo.org> -mcollective-1.0.1.ebuild,
+ -mcollective-1.1.4.ebuild, -mcollective-1.2.1.ebuild,
+ -mcollective-2.0.0.ebuild, metadata.xml:
+ Cleanup due #66351
25 Mar 2013; Agostino Sarubbo <ago@gentoo.org> mcollective-2.2.0.ebuild:
Stable for x86, wrt bug #457214
diff --git a/app-admin/mcollective/mcollective-1.0.1.ebuild b/app-admin/mcollective/mcollective-1.0.1.ebuild
deleted file mode 100644
index ac6e7d4be53c..000000000000
--- a/app-admin/mcollective/mcollective-1.0.1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/mcollective/mcollective-1.0.1.ebuild,v 1.2 2012/03/09 05:20:10 ramereth Exp $
-
-EAPI="2"
-
-USE_RUBY="ruby18 ree18"
-
-inherit ruby-ng
-
-DESCRIPTION="Framework to build server orchestration or parallel job execution
-systems"
-HOMEPAGE="http://marionette-collective.org/"
-SRC_URI="http://puppetlabs.com/downloads/mcollective/${P}.tgz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc +client"
-
-DEPEND=""
-RDEPEND="dev-ruby/stomp"
-
-src_compile() {
- einfo "nothing to compile"
-}
-
-each_ruby_install() {
- doruby -r lib/*
- insinto /usr/share/mcollective
- doins -r plugins
- use client && dosbin mc-*
- newsbin mcollectived.rb mcollectived
- if use doc ; then
- dohtml -r doc/*
- insinto /usr/share/doc/${P}/ext
- doins -r ext/*
- fi
- newinitd "${FILESDIR}"/mcollectived.initd mcollectived
- insinto /etc/mcollective
- cd etc
- for cfg in *.dist ; do
- newins "${cfg}" "${cfg%%.dist}"
- dosed "s:^libdir.*:libdir = /usr/share/mcollective/plugins:" \
- /etc/mcollective/${cfg%%.dist}
- done
-}
-
-pkg_postinst() {
- einfo "Mcollective requires a stomp server installed and functioning before"
- einfo "you can use it. The recommended server to use is ActiveMQ [1] but"
- einfo "any other stomp compatible server should work."
- einfo
- einfo "It is recommended you read the \'getting started\' guide [2] if this"
- einfo "is a new installation"
- einfo
- einfo "[1] http://activemq.apache.org/"
- einfo "[2] http://code.google.com/p/mcollective/wiki/GettingStarted"
-}
diff --git a/app-admin/mcollective/mcollective-1.1.4.ebuild b/app-admin/mcollective/mcollective-1.1.4.ebuild
deleted file mode 100644
index 6058f1484722..000000000000
--- a/app-admin/mcollective/mcollective-1.1.4.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/mcollective/mcollective-1.1.4.ebuild,v 1.2 2012/03/09 05:20:10 ramereth Exp $
-
-EAPI="4"
-
-USE_RUBY="ruby18 ree18"
-
-inherit ruby-ng
-
-DESCRIPTION="Framework to build server orchestration or parallel job execution
-systems"
-HOMEPAGE="http://marionette-collective.org/"
-SRC_URI="http://puppetlabs.com/downloads/mcollective/${P}.tgz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc +client"
-
-DEPEND=""
-RDEPEND="dev-ruby/stomp"
-
-src_compile() {
- einfo "nothing to compile"
-}
-
-each_ruby_install() {
- doruby -r lib/*
- insinto /usr/share/mcollective
- doins -r plugins
- use client && dosbin mc-* mco
- newsbin mcollectived.rb mcollectived
- if use doc ; then
- dohtml -r doc/*
- insinto /usr/share/doc/${P}/ext
- doins -r ext/*
- fi
- newinitd "${FILESDIR}"/mcollectived.initd mcollectived
- insinto /etc/mcollective
- cd etc
- for cfg in *.dist ; do
- newins "${cfg}" "${cfg%%.dist}"
- sed -i -e "s:^libdir.*:libdir = /usr/share/mcollective/plugins:" \
- "${D}"/etc/mcollective/${cfg%%.dist}
- done
- insinto /etc/mcollective/plugin.d
-}
-
-pkg_postinst() {
- einfo "Mcollective requires a stomp server installed and functioning before"
- einfo "you can use it. The recommended server to use is ActiveMQ [1] but"
- einfo "any other stomp compatible server should work."
- einfo
- einfo "It is recommended you read the \'getting started\' guide [2] if this"
- einfo "is a new installation"
- einfo
- einfo "[1] http://activemq.apache.org/"
- einfo "[2] http://code.google.com/p/mcollective/wiki/GettingStarted"
-}
diff --git a/app-admin/mcollective/mcollective-1.2.1.ebuild b/app-admin/mcollective/mcollective-1.2.1.ebuild
deleted file mode 100644
index 7c75af21cc40..000000000000
--- a/app-admin/mcollective/mcollective-1.2.1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/mcollective/mcollective-1.2.1.ebuild,v 1.2 2012/03/09 05:20:10 ramereth Exp $
-
-EAPI="4"
-
-USE_RUBY="ruby18 ree18"
-
-inherit ruby-ng
-
-DESCRIPTION="Framework to build server orchestration or parallel job execution
-systems"
-HOMEPAGE="http://marionette-collective.org/"
-SRC_URI="http://puppetlabs.com/downloads/mcollective/${P}.tgz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc +client"
-
-DEPEND=""
-RDEPEND="dev-ruby/stomp"
-
-src_compile() {
- einfo "nothing to compile"
-}
-
-each_ruby_install() {
- doruby -r lib/*
- insinto /usr/share/mcollective
- doins -r plugins
- use client && dosbin mc-* mco
- newsbin mcollectived.rb mcollectived
- if use doc ; then
- dohtml -r doc/*
- insinto /usr/share/doc/${P}/ext
- doins -r ext/*
- fi
- newinitd "${FILESDIR}"/mcollectived.initd mcollectived
- insinto /etc/mcollective
- cd etc
- for cfg in *.dist ; do
- newins "${cfg}" "${cfg%%.dist}"
- sed -i -e "s:^libdir.*:libdir = /usr/share/mcollective/plugins:" \
- "${D}"/etc/mcollective/${cfg%%.dist}
- done
- insinto /etc/mcollective/plugin.d
-}
-
-pkg_postinst() {
- einfo "Mcollective requires a stomp server installed and functioning before"
- einfo "you can use it. The recommended server to use is ActiveMQ [1] but"
- einfo "any other stomp compatible server should work."
- einfo
- einfo "It is recommended you read the \'getting started\' guide [2] if this"
- einfo "is a new installation"
- einfo
- einfo "[1] http://activemq.apache.org/"
- einfo "[2] http://code.google.com/p/mcollective/wiki/GettingStarted"
-}
diff --git a/app-admin/mcollective/mcollective-2.0.0.ebuild b/app-admin/mcollective/mcollective-2.0.0.ebuild
deleted file mode 100644
index a870fd421a28..000000000000
--- a/app-admin/mcollective/mcollective-2.0.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/mcollective/mcollective-2.0.0.ebuild,v 1.3 2012/08/12 16:33:08 maekke Exp $
-
-EAPI="4"
-
-USE_RUBY="ruby18 ree18"
-
-inherit ruby-ng
-
-DESCRIPTION="Framework to build server orchestration or parallel job execution
-systems"
-HOMEPAGE="http://marionette-collective.org/"
-SRC_URI="http://puppetlabs.com/downloads/mcollective/${P}.tgz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc +client"
-
-DEPEND=""
-RDEPEND="dev-ruby/stomp"
-
-src_compile() {
- einfo "nothing to compile"
-}
-
-each_ruby_install() {
- doruby -r lib/*
- insinto /usr/share/mcollective
- doins -r plugins
- use client && dosbin bin/mc-* bin/mco
- dosbin bin/mcollectived
- if use doc ; then
- dohtml -r website/*
- insinto /usr/share/doc/${P}/ext
- doins -r ext/*
- fi
- newinitd "${FILESDIR}"/mcollectived.initd mcollectived
- insinto /etc/mcollective
- cd etc
- for cfg in *.dist ; do
- newins "${cfg}" "${cfg%%.dist}"
- sed -i -e "s:^libdir.*:libdir = /usr/share/mcollective/plugins:" \
- "${D}"/etc/mcollective/${cfg%%.dist}
- done
- insinto /etc/mcollective/plugin.d
-}
-
-pkg_postinst() {
- einfo "Mcollective requires a stomp server installed and functioning before"
- einfo "you can use it. The recommended server to use is ActiveMQ [1] but"
- einfo "any other stomp compatible server should work."
- einfo
- einfo "It is recommended you read the \'getting started\' guide [2] if this"
- einfo "is a new installation"
- einfo
- einfo "[1] http://activemq.apache.org/"
- einfo "[2] http://code.google.com/p/mcollective/wiki/GettingStarted"
-}
diff --git a/app-admin/mcollective/metadata.xml b/app-admin/mcollective/metadata.xml
index 8f60d17142ee..1c668aa1a92f 100644
--- a/app-admin/mcollective/metadata.xml
+++ b/app-admin/mcollective/metadata.xml
@@ -2,8 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer>
- <email>ramereth@gentoo.org</email>
- <name>Lance Albertson</name>
+ <email>maintainer-needed@gentoo.org</email>
</maintainer>
<use>
<flag name="client">Install client utilities</flag>