summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/dump/dump-0.4.42.ebuild')
-rw-r--r--app-arch/dump/dump-0.4.42.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/app-arch/dump/dump-0.4.42.ebuild b/app-arch/dump/dump-0.4.42.ebuild
new file mode 100644
index 000000000000..10ad383a77a2
--- /dev/null
+++ b/app-arch/dump/dump-0.4.42.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dump/dump-0.4.42.ebuild,v 1.1 2009/09/30 03:14:08 vapier Exp $
+
+MY_P=${P/4./4b}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Dump/restore ext2fs backup utilities"
+HOMEPAGE="http://dump.sourceforge.net/"
+SRC_URI="mirror://sourceforge/dump/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ermt readline selinux static"
+
+RDEPEND=">=sys-fs/e2fsprogs-1.27
+ >=app-arch/bzip2-1.0.2
+ >=sys-libs/zlib-1.1.4
+ ermt? ( dev-libs/openssl )
+ readline? ( sys-libs/readline )"
+DEPEND="${RDEPEND}
+ virtual/os-headers"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e 's:-ltermcap:-lncurses:g' \
+ -e '/BLKID=/s:=.*:=`pkg-config --libs blkid`:' \
+ configure || die
+}
+
+src_compile() {
+ econf \
+ --with-dumpdatespath=/etc/dumpdates \
+ --with-{bin,man}owner=root \
+ --with-{bin,man}grp=root \
+ --enable-largefile \
+ $(use_enable selinux transselinux) \
+ $(use_enable ermt) \
+ $(use_enable static) \
+ $(use_enable readline) \
+ || die
+ emake || die
+}
+
+src_install() {
+ # built on old autotools, no DESTDIR support
+ einstall MANDIR="${D}"/usr/share/man/man8 || die
+ mv "${D}"/usr/sbin/{,dump-}rmt
+ mv "${D}"/usr/share/man/man8/{,dump-}rmt.8
+ use ermt && newsbin rmt/ermt dump-ermt
+
+ dodoc CHANGES KNOWNBUGS MAINTAINERS README REPORTING-BUGS THANKS TODO
+ cd examples
+ local d=
+ for d in * ; do
+ docinto ${d}
+ dodoc ${d}/*
+ done
+}
+
+pkg_postinst() {
+ ewarn "app-arch/dump installs 'rmt' as 'dump-rmt'."
+ ewarn "This is to avoid conflicts with app-arch/tar 'rmt'."
+}