summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/lzip/lzip-1.10.ebuild')
-rw-r--r--app-arch/lzip/lzip-1.10.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-arch/lzip/lzip-1.10.ebuild b/app-arch/lzip/lzip-1.10.ebuild
new file mode 100644
index 000000000000..aed2a1b1e8f8
--- /dev/null
+++ b/app-arch/lzip/lzip-1.10.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lzip/lzip-1.10.ebuild,v 1.1 2010/04/20 20:38:24 vapier Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="lossless data compressor based on the LZMA algorithm"
+HOMEPAGE="http://www.nongnu.org/lzip/lzip.html"
+SRC_URI="http://download.savannah.gnu.org/releases-noredirect/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~sparc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.9-build.patch
+ tc-export CC CXX
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS README NEWS ChangeLog
+}