summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/siege/ChangeLog11
-rw-r--r--app-benchmarks/siege/files/digest-siege-2.551
-rw-r--r--app-benchmarks/siege/siege-2.55.ebuild37
3 files changed, 49 insertions, 0 deletions
diff --git a/app-benchmarks/siege/ChangeLog b/app-benchmarks/siege/ChangeLog
new file mode 100644
index 000000000000..b91cf1669c9c
--- /dev/null
+++ b/app-benchmarks/siege/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-benchmarks/siege
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/ChangeLog,v 1.1 2002/07/20 18:29:13 blocke Exp $
+
+*siege-2.55 (20 Jul 2002)
+
+ 20 Jul 2002; Bruce A. Locke <blocke@shivan.org> siege-2.55.ebuild, digest-siege-2.55:
+
+ Initial Version
+
+
diff --git a/app-benchmarks/siege/files/digest-siege-2.55 b/app-benchmarks/siege/files/digest-siege-2.55
new file mode 100644
index 000000000000..3758e9ad82b8
--- /dev/null
+++ b/app-benchmarks/siege/files/digest-siege-2.55
@@ -0,0 +1 @@
+MD5 fb07257e7cf58c8a69fd81f20be5b2eb siege-2.55.tar.gz 344618
diff --git a/app-benchmarks/siege/siege-2.55.ebuild b/app-benchmarks/siege/siege-2.55.ebuild
new file mode 100644
index 000000000000..e2bd9ff1d5c6
--- /dev/null
+++ b/app-benchmarks/siege/siege-2.55.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/siege-2.55.ebuild,v 1.1 2002/07/20 18:29:13 blocke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="An http regression testing and benchmarking utility"
+SRC_URI="ftp://ftp.armstrong.com/pub/siege/${P}.tar.gz"
+HOMEPAGE="http://www.joedog.org/siege"
+SLOT="0"
+KEYWORDS="*"
+LICENSE="GPL-2"
+DEPEND="virtual/glibc
+ ssl? ( >=dev-libs/openssl-0.9.6d )"
+
+src_compile() {
+
+ local myconf
+ use ssl && myconf="--with-ssl" || myconf="--with-ssl=off"
+
+ econf ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ # makefile tries to install into $HOME by default... bad monkey!
+ dodir /usr/share/doc/${P}
+
+ einstall SIEGERC="${D}/usr/share/doc/${P}/siegerc-example" || die
+
+ # all non-html docs must be gzip'd
+ gzip ${D}/usr/share/doc/${P}/siegerc-example
+
+ dodoc AUTHORS COPYING INSTALL KNOWNBUGS NEWS MACHINES README
+}
+