summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/gcr')
-rw-r--r--app-crypt/gcr/ChangeLog7
-rw-r--r--app-crypt/gcr/files/gcr-3.4.1-invalid-whitespace.patch46
-rw-r--r--app-crypt/gcr/gcr-3.4.1-r2.ebuild66
-rw-r--r--app-crypt/gcr/gcr-3.8.2.ebuild65
4 files changed, 6 insertions, 178 deletions
diff --git a/app-crypt/gcr/ChangeLog b/app-crypt/gcr/ChangeLog
index 2264e58392b1..513f54634efe 100644
--- a/app-crypt/gcr/ChangeLog
+++ b/app-crypt/gcr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/gcr
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gcr/ChangeLog,v 1.33 2014/04/21 10:28:28 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gcr/ChangeLog,v 1.34 2014/04/23 20:40:28 pacho Exp $
+
+ 23 Apr 2014; Pacho Ramos <pacho@gentoo.org>
+ -files/gcr-3.4.1-invalid-whitespace.patch, -gcr-3.4.1-r2.ebuild,
+ -gcr-3.8.2.ebuild:
+ Drop old
21 Apr 2014; Agostino Sarubbo <ago@gentoo.org> gcr-3.10.1.ebuild:
Stable for arm, wrt bug #507568
diff --git a/app-crypt/gcr/files/gcr-3.4.1-invalid-whitespace.patch b/app-crypt/gcr/files/gcr-3.4.1-invalid-whitespace.patch
deleted file mode 100644
index 4f3287ca7dfb..000000000000
--- a/app-crypt/gcr/files/gcr-3.4.1-invalid-whitespace.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From b7e899d45a49085e2cedbff1cf76e6d8450b0bea Mon Sep 17 00:00:00 2001
-From: Stef Walter <stefw@gnome.org>
-Date: Sat, 30 Jun 2012 13:10:31 +0200
-Subject: [PATCH] gcr: Fix invalid warning when sending a secret exchange
-
- * We checked the prefix of the sent data, but didn't correctly
- remove whitespace. In addition the check was inverted
- * Exposed by recent changes to glib, which changed the whitespace
- in the format a GKeyFile slightly
----
- gcr/gcr-secret-exchange.c | 10 +++++-----
- 1 file changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/gcr/gcr-secret-exchange.c b/gcr/gcr-secret-exchange.c
-index cb3941f..f6eb32e 100644
---- a/gcr/gcr-secret-exchange.c
-+++ b/gcr/gcr-secret-exchange.c
-@@ -292,9 +292,9 @@ gcr_secret_exchange_begin (GcrSecretExchange *self)
- result = g_key_file_to_data (output, NULL, NULL);
- g_return_val_if_fail (result != NULL, NULL);
-
-- g_strchomp (result);
-+ g_strchug (result);
-
-- if (g_str_has_prefix (result, SECRET_EXCHANGE_PROTOCOL_1_PREFIX))
-+ if (!g_str_has_prefix (result, SECRET_EXCHANGE_PROTOCOL_1_PREFIX))
- g_warning ("the prepared data does not have the correct protocol prefix");
-
- g_key_file_free (output);
-@@ -540,10 +540,10 @@ gcr_secret_exchange_send (GcrSecretExchange *self,
- result = g_key_file_to_data (output, NULL, NULL);
- g_return_val_if_fail (result != NULL, NULL);
-
-- g_strchomp (result);
-+ g_strchug (result);
-
-- if (g_str_has_prefix (result, SECRET_EXCHANGE_PROTOCOL_1_PREFIX))
-- g_warning ("the prepared data does not have the correct protocol prefix");
-+ if (!g_str_has_prefix (result, SECRET_EXCHANGE_PROTOCOL_1_PREFIX))
-+ g_warning ("the prepared data does not have the correct protocol prefix: %s", result);
-
- g_key_file_free (output);
- return result;
---
-1.7.12
-
diff --git a/app-crypt/gcr/gcr-3.4.1-r2.ebuild b/app-crypt/gcr/gcr-3.4.1-r2.ebuild
deleted file mode 100644
index 90cc7efa1f5a..000000000000
--- a/app-crypt/gcr/gcr-3.4.1-r2.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gcr/gcr-3.4.1-r2.ebuild,v 1.9 2014/03/01 22:23:44 mgorny Exp $
-
-EAPI="4"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-
-inherit autotools gnome2 virtualx
-
-DESCRIPTION="Libraries for cryptographic UIs and accessing PKCS#11 modules"
-HOMEPAGE="http://www.gnome.org/"
-
-LICENSE="GPL-2+ LGPL-2+"
-SLOT="0"
-IUSE="debug +introspection"
-KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
-
-COMMON_DEPEND=">=app-crypt/gnupg-2
- >=app-crypt/p11-kit-0.6
- >=dev-libs/glib-2.30:2
- >=dev-libs/libgcrypt-1.2.2:0
- >=dev-libs/libtasn1-1
- >=sys-apps/dbus-1.0
- >=x11-libs/gtk+-3.0:3
- introspection? ( >=dev-libs/gobject-introspection-1.29 )
-"
-RDEPEND="${COMMON_DEPEND}
- !<gnome-base/gnome-keyring-3.3"
-# gcr was part of gnome-keyring until 3.3
-DEPEND="${COMMON_DEPEND}
- dev-util/gdbus-codegen
- >=dev-util/gtk-doc-am-1.9
- >=dev-util/intltool-0.35
- sys-devel/gettext
- virtual/pkgconfig
-
- dev-libs/gobject-introspection-common"
-# eautoreconf needs:
-# dev-libs/gobject-introspection-common
-
-src_prepare() {
- DOCS="AUTHORS ChangeLog HACKING NEWS README"
- G2CONF="${G2CONF}
- $(use_enable debug)
- $(use_enable introspection)
- --disable-update-icon-cache
- --disable-update-mime"
-
- epatch "${FILESDIR}/${P}-invalid-whitespace.patch" #434422
-
- # FIXME: failing tests
- if use test; then
- sed -e 's:test-subject-public-key::' \
- -e 's:test-system-prompt:$(NULL):' \
- -i gcr/tests/Makefile.am || die "sed failed"
- eautoreconf
- fi
-
- gnome2_src_prepare
-}
-
-src_test() {
- unset DBUS_SESSION_BUS_ADDRESS
- Xemake check
-}
diff --git a/app-crypt/gcr/gcr-3.8.2.ebuild b/app-crypt/gcr/gcr-3.8.2.ebuild
deleted file mode 100644
index 673d2cd42af9..000000000000
--- a/app-crypt/gcr/gcr-3.8.2.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gcr/gcr-3.8.2.ebuild,v 1.4 2014/03/01 22:23:44 mgorny Exp $
-
-EAPI="5"
-GCONF_DEBUG="no"
-
-inherit gnome2 virtualx
-
-DESCRIPTION="Libraries for cryptographic UIs and accessing PKCS#11 modules"
-HOMEPAGE="https://developer.gnome.org/gcr/"
-
-LICENSE="GPL-2+ LGPL-2+"
-SLOT="0/1" # subslot = suffix of libgcr-3
-IUSE="debug gtk +introspection"
-KEYWORDS="~alpha amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x86-solaris"
-
-COMMON_DEPEND="
- >=app-crypt/gnupg-2
- >=app-crypt/p11-kit-0.6
- >=dev-libs/glib-2.32:2
- >=dev-libs/libgcrypt-1.2.2:0=
- >=dev-libs/libtasn1-1:=
- >=sys-apps/dbus-1
- gtk? ( >=x11-libs/gtk+-3:3 )
- introspection? ( >=dev-libs/gobject-introspection-1.34 )
-"
-RDEPEND="${COMMON_DEPEND}
- !<gnome-base/gnome-keyring-3.3
-"
-# gcr was part of gnome-keyring until 3.3
-DEPEND="${COMMON_DEPEND}
- dev-libs/gobject-introspection-common
- dev-util/gdbus-codegen
- >=dev-util/gtk-doc-am-1.9
- >=dev-util/intltool-0.35
- sys-devel/gettext
- virtual/pkgconfig
-"
-# eautoreconf needs:
-# dev-libs/gobject-introspection-common
-
-src_prepare() {
- # Disable stupid flag changes
- sed -e 's/CFLAGS="$CFLAGS -g"//' \
- -e 's/CFLAGS="$CFLAGS -O0"//' \
- -i configure.ac configure || die
-
- gnome2_src_prepare
-}
-
-src_configure() {
- DOCS="AUTHORS ChangeLog HACKING NEWS README"
- gnome2_src_configure \
- $(use_with gtk) \
- $(use_enable introspection) \
- $(usex debug --enable-debug=yes --enable-debug=default) \
- --disable-update-icon-cache \
- --disable-update-mime
-}
-
-src_test() {
- unset DBUS_SESSION_BUS_ADDRESS
- Xemake check
-}