summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/gnupg/gnupg-1.0.6.ebuild')
-rw-r--r--app-crypt/gnupg/gnupg-1.0.6.ebuild21
1 files changed, 17 insertions, 4 deletions
diff --git a/app-crypt/gnupg/gnupg-1.0.6.ebuild b/app-crypt/gnupg/gnupg-1.0.6.ebuild
index 2b4637b8519a..54cc8189ed02 100644
--- a/app-crypt/gnupg/gnupg-1.0.6.ebuild
+++ b/app-crypt/gnupg/gnupg-1.0.6.ebuild
@@ -15,6 +15,12 @@ DEPEND="virtual/glibc
nls? ( >=sys-devel/gettext-0.10.35 )
>=sys-libs/zlib-1.1.3"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+# Fix those $&*%^$%%$ info files
+ patch -p1 < ${FILESDIR}/gnupg-1.0.6.diff
+}
src_compile() {
# Check to see if we're using nls
@@ -23,8 +29,9 @@ src_compile() {
myconf="--disable-nls"
fi
- try ./configure --prefix=/usr --mandir=/usr/share --infodir=/usr/share/info \
- --enable-static-rnd=linux --enable-m-guard --host=${CHOST}\
+ try ./configure --prefix=/usr --mandir=/usr/share/man \
+ --infodir=/usr/share/info --enable-static-rnd=linux \
+ --enable-m-guard --host=${CHOST}\
${myconf}
try pmake
@@ -32,13 +39,13 @@ src_compile() {
src_install () {
- try make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
+ try make DESTDIR=${D} install
dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog INSTALL NEWS PROJECTS
dodoc README TODO VERSION
docinto doc
cd doc
dodoc FAQ HACKING DETAILS ChangeLog
- docint sgml
+ docinto sgml
dodoc gpg.sgml gpgv.sgml
docinto html
dodoc faq.html
@@ -47,3 +54,9 @@ src_install () {
chmod +s ${D}/usr/bin/gpg
}
+pkg_postinst() {
+ einfo "gpg is installed SUID root to make use of protected memory space"
+ einfo "This is needed in order to have a secure place"
+ einfo " to store yourpassphrases etc during runtime"
+ einfo "but may make some sysadmins nervous"
+}