summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/heimdal/heimdal-0.5.1.ebuild')
-rw-r--r--app-crypt/heimdal/heimdal-0.5.1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/app-crypt/heimdal/heimdal-0.5.1.ebuild b/app-crypt/heimdal/heimdal-0.5.1.ebuild
new file mode 100644
index 000000000000..a103b4467290
--- /dev/null
+++ b/app-crypt/heimdal/heimdal-0.5.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-0.5.1.ebuild,v 1.1 2002/10/26 15:24:01 aliz Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Kerberos 5 implementation from KTH"
+SRC_URI="ftp://ftp.pdc.kth.se/pub/${PN}/src/${P}.tar.gz"
+HOMEPAGE="http://www.pdc.kth.se/heimdal/"
+IUSE="ssl ldap berkdb ipv6"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="x86 sparc sparc64"
+
+DEPEND=">=app-crypt/kth-krb-1.2.1
+ ssl? ( dev-libs/openssl )
+ ldap? ( net-nds/openldap )
+ berkdb? ( sys-libs/db )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/lib/krb5
+ mv Makefile.in Makefile.in.bak
+ sed "s:LIB_crypt = @LIB_crypt@:LIB_crypt = -lssl @LIB_crypt@:g" Makefile.in.bak >Makefile.in
+
+}
+
+src_compile() {
+ local myconf
+
+ use ssl && myconf="--with-openssl=/usr" || myconf="--without-openssl"
+
+ use ldap && myconf="${myconf} --with-open-ldap=/usr"
+
+ use ipv6 || myconf="${myconf} --without-ipv6"
+
+ use berkdb || myconf="${myconf} --without-berkely-db"
+
+echo $myconf
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr/heimdal \
+ --sysconfdir=/etc \
+ --with-krb4=/usr/athena \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install () {
+ make prefix=${D}/usr/heimdal \
+ sysconfdir=${D}/etc \
+ install || die
+
+ dodir /etc/env.d
+ cp ${FILESDIR}/01heimdal ${D}/etc/env.d
+
+ dodoc COPYRIGHT ChangeLog README NEWS PROBLEMS TODO
+}