summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/qca/qca-1.0-r2.ebuild')
-rw-r--r--app-crypt/qca/qca-1.0-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-crypt/qca/qca-1.0-r2.ebuild b/app-crypt/qca/qca-1.0-r2.ebuild
new file mode 100644
index 000000000000..fc6d959a5b57
--- /dev/null
+++ b/app-crypt/qca/qca-1.0-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/qca-1.0-r2.ebuild,v 1.1 2005/01/24 18:02:19 humpback Exp $
+
+inherit eutils
+
+DESCRIPTION="Qt Cryptographic Architecture (QCA)"
+HOMEPAGE="http://delta.affinix.com/qca/"
+SRC_URI="http://delta.affinix.com/qca/qca-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86 sparc ppc ~ia64 ~hppa ~alpha"
+IUSE=""
+
+DEPEND=">=x11-libs/qt-3.3.0-r1"
+
+RDEPEND=" ssl? ( app-crypt/qca-tls ) "
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/qca-pathfix.patch || die "bad patch"
+}
+
+src_compile() {
+ ./configure --prefix=/usr || die "configure failed"
+ sed -i \
+ -e "/^CFLAGS/s:$: ${CFLAGS}:" \
+ -e "/^CXXFLAGS/s:$: ${CXXFLAGS}:" \
+ Makefile
+ emake || die "emake failed"
+}
+
+src_install() {
+ make INSTALL_ROOT="${D}" install || die "make install failed"
+ if [ "$(get_libdir)" != "lib" ]; then
+ mv ${D}/usr/lib ${D}/usr/$(get_libdir)
+ fi
+}