summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gnupg/ChangeLog8
-rw-r--r--app-crypt/gnupg/files/gnupg-2.0.17-libgrcrypt150-bugfix.patch38
-rw-r--r--app-crypt/gnupg/gnupg-2.0.17-r3.ebuild144
3 files changed, 189 insertions, 1 deletions
diff --git a/app-crypt/gnupg/ChangeLog b/app-crypt/gnupg/ChangeLog
index 0132347588c0..fc05b50d413c 100644
--- a/app-crypt/gnupg/ChangeLog
+++ b/app-crypt/gnupg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/gnupg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.415 2011/06/09 14:13:22 c1pher Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.416 2011/07/03 23:23:51 robbat2 Exp $
+
+*gnupg-2.0.17-r3 (03 Jul 2011)
+
+ 03 Jul 2011; Robin H. Johnson <robbat2@gentoo.org> +gnupg-2.0.17-r3.ebuild,
+ +files/gnupg-2.0.17-libgrcrypt150-bugfix.patch:
+ Bug #373959: critical patch to enable signing w/ libgcrypt-1.5.0.
*gnupg-2.0.17-r2 (09 Jun 2011)
diff --git a/app-crypt/gnupg/files/gnupg-2.0.17-libgrcrypt150-bugfix.patch b/app-crypt/gnupg/files/gnupg-2.0.17-libgrcrypt150-bugfix.patch
new file mode 100644
index 000000000000..34f4348bcd4f
--- /dev/null
+++ b/app-crypt/gnupg/files/gnupg-2.0.17-libgrcrypt150-bugfix.patch
@@ -0,0 +1,38 @@
+From 13290b0e0fcf3a493e4848b29329d56b69bc4dd9 Mon Sep 17 00:00:00 2001
+From: Werner Koch <wk@gnupg.org>
+Date: Mon, 13 Jun 2011 14:35:30 +0200
+Subject: [PATCH] Fix a for a bug fix in the latest Libgcrypt.
+
+ * pkglue.c (mpi_from_sexp, pk_decrypt): Use GCRYMPI_FMT_USG for
+ gcry_sexp_nth_mpi. This fixes a problem with a recent bug fix in
+ Libgcrypt.
+
+diff --git a/g10/pkglue.c b/g10/pkglue.c
+index cbfe21e..5c47511 100644
+--- a/g10/pkglue.c
++++ b/g10/pkglue.c
+@@ -34,10 +34,10 @@ mpi_from_sexp (gcry_sexp_t sexp, const char * item)
+ {
+ gcry_sexp_t list;
+ gcry_mpi_t data;
+-
++
+ list = gcry_sexp_find_token (sexp, item, 0);
+ assert (list);
+- data = gcry_sexp_nth_mpi (list, 1, 0);
++ data = gcry_sexp_nth_mpi (list, 1, GCRYMPI_FMT_USG);
+ assert (data);
+ gcry_sexp_release (list);
+ return data;
+@@ -293,7 +293,7 @@ pk_decrypt (int algo, gcry_mpi_t * result, gcry_mpi_t * data,
+ if (rc)
+ return rc;
+
+- *result = gcry_sexp_nth_mpi (s_plain, 0, 0);
++ *result = gcry_sexp_nth_mpi (s_plain, 0, GCRYMPI_FMT_USG);
+ gcry_sexp_release (s_plain);
+ if (!*result)
+ return -1; /* oops */
+--
+1.7.1
+
diff --git a/app-crypt/gnupg/gnupg-2.0.17-r3.ebuild b/app-crypt/gnupg/gnupg-2.0.17-r3.ebuild
new file mode 100644
index 000000000000..5645e1ae1bf0
--- /dev/null
+++ b/app-crypt/gnupg/gnupg-2.0.17-r3.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-2.0.17-r3.ebuild,v 1.1 2011/07/03 23:23:51 robbat2 Exp $
+
+EAPI="4"
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="The GNU Privacy Guard, a GPL pgp replacement"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="mirror://gnupg/gnupg/${P}.tar.bz2"
+# SRC_URI="ftp://ftp.gnupg.org/gcrypt/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="adns bzip2 doc ldap nls static selinux smartcard usb"
+
+COMMON_DEPEND_LIBS="
+ >=dev-libs/libassuan-2
+ >=dev-libs/libgcrypt-1.4
+ >=dev-libs/libgpg-error-1.7
+ >=dev-libs/libksba-1.0.7
+ >=dev-libs/pth-1.3.7
+ >=net-misc/curl-7.10
+ adns? ( >=net-libs/adns-1.4 )
+ bzip2? ( app-arch/bzip2 )
+ smartcard? ( usb? ( =virtual/libusb-0* ) )
+ ldap? ( net-nds/openldap )"
+COMMON_DEPEND_BINS="|| ( app-crypt/pinentry app-crypt/pinentry-qt )"
+
+# Existence of executables is checked during configuration.
+DEPEND="${COMMON_DEPEND_LIBS}
+ ${COMMON_DEPEND_BINS}
+ static? (
+ >=dev-libs/libassuan-2[static-libs]
+ >=dev-libs/libgcrypt-1.4[static-libs]
+ >=dev-libs/libgpg-error-1.7[static-libs]
+ >=dev-libs/libksba-1.0.7[static-libs]
+ )
+ nls? ( sys-devel/gettext )
+ doc? ( sys-apps/texinfo )"
+
+RDEPEND="!static? ( ${COMMON_DEPEND_LIBS} )
+ ${COMMON_DEPEND_BINS}
+ virtual/mta
+ !app-crypt/gpg-agent
+ !<=app-crypt/gnupg-2.0.1
+ selinux? ( sec-policy/selinux-gnupg )
+ nls? ( virtual/libintl )"
+
+REQUIRED_USE="smartcard? ( !static )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gpgsm-gencert.patch
+ epatch "${FILESDIR}"/${P}-libgrcrypt150-bugfix.patch
+}
+
+src_configure() {
+ local myconf=
+
+ # 'USE=static' support was requested:
+ # gnupg1: bug #29299
+ # gnupg2: bug #159623
+ use static && append-ldflags -static
+
+ if use smartcard; then
+ myconf+=" --enable-scdaemon $(use_enable usb ccid-driver)"
+ else
+ myconf+=" --disable-scdaemon"
+ fi
+
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --enable-gpg \
+ --enable-gpgsm \
+ --enable-agent \
+ ${myconf} \
+ $(use_with adns) \
+ $(use_enable bzip2) \
+ $(use_enable !elibc_SunOS symcryptrun) \
+ $(use_enable nls) \
+ $(use_enable ldap) \
+ CC_FOR_BUILD="$(tc-getBUILD_CC)"
+}
+
+src_compile() {
+ emake
+
+ if use doc; then
+ cd doc
+ emake html
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ emake DESTDIR="${D}" -f doc/Makefile uninstall-nobase_dist_docDATA
+ rm -r "${ED}usr/share/gnupg/help"*
+
+ dodoc ChangeLog NEWS README THANKS TODO VERSION doc/FAQ doc/DETAILS \
+ doc/HACKING doc/TRANSLATE doc/OpenPGP doc/KEYSERVER doc/help*
+
+ dosym gpg2 /usr/bin/gpg
+ dosym gpgv2 /usr/bin/gpgv
+ dosym gpg2keys_hkp /usr/libexec/gpgkeys_hkp
+ dosym gpg2keys_finger /usr/libexec/gpgkeys_finger
+ dosym gpg2keys_curl /usr/libexec/gpgkeys_curl
+ if use ldap; then
+ dosym gpg2keys_ldap /usr/libexec/gpgkeys_ldap
+ fi
+ echo ".so man1/gpg2.1" > "${ED}usr/share/man/man1/gpg.1"
+ echo ".so man1/gpgv2.1" > "${ED}usr/share/man/man1/gpgv.1"
+
+ dodir /etc/env.d
+ echo "CONFIG_PROTECT=/usr/share/gnupg/qualified.txt" >>"${ED}etc/env.d/30gnupg"
+
+ if use doc; then
+ dohtml doc/gnupg.html/* doc/*.png
+ fi
+}
+
+pkg_postinst() {
+ elog "If you wish to view images emerge:"
+ elog "media-gfx/xloadimage, media-gfx/xli or any other viewer"
+ elog "Remember to use photo-viewer option in configuration file to activate"
+ elog "the right viewer."
+ elog
+ if use smartcard; then
+ elog "To use your OpenPGP smartcard (or token) with GnuPG you need one of"
+ use usb && elog " - a CCID-compatible reader, used directly through dev-libs/libusb;"
+ elog " - sys-apps/pcsc-lite and a compatible reader device;"
+ elog " - dev-libs/openct and a compatible reader device;"
+ elog " - a reader device and drivers exporting either PC/SC or CT-API interfaces."
+ elog ""
+ elog "General hint: you probably want to try installing sys-apps/pcsc-lite and"
+ elog "app-crypt/ccid first."
+ fi
+
+ ewarn "Please remember to restart gpg-agent if a different version"
+ ewarn "of the agent is currently used. If you are unsure of the gpg"
+ ewarn "agent you are using please run 'killall gpg-agent',"
+ ewarn "and to start a fresh daemon just run 'gpg-agent --daemon'."
+}