summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/kencfs/ChangeLog6
-rw-r--r--app-crypt/kencfs/files/kencfs-1.2-gcc-4.7.patch10
-rw-r--r--app-crypt/kencfs/kencfs-1.2.ebuild13
3 files changed, 24 insertions, 5 deletions
diff --git a/app-crypt/kencfs/ChangeLog b/app-crypt/kencfs/ChangeLog
index 64a90e6e9d0c..e9887e36388c 100644
--- a/app-crypt/kencfs/ChangeLog
+++ b/app-crypt/kencfs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-crypt/kencfs
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/kencfs/ChangeLog,v 1.2 2012/01/10 14:44:20 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/kencfs/ChangeLog,v 1.3 2012/06/21 09:35:07 kensington Exp $
+
+ 21 Jun 2012; Michael Palimaka <kensington@gentoo.org>
+ +files/kencfs-1.2-gcc-4.7.patch, kencfs-1.2.ebuild:
+ Fix build with GCC 4.7, wrt bug #421905.
*kencfs-1.2 (10 Jan 2012)
diff --git a/app-crypt/kencfs/files/kencfs-1.2-gcc-4.7.patch b/app-crypt/kencfs/files/kencfs-1.2-gcc-4.7.patch
new file mode 100644
index 000000000000..d4b41a7e4750
--- /dev/null
+++ b/app-crypt/kencfs/files/kencfs-1.2-gcc-4.7.patch
@@ -0,0 +1,10 @@
+--- qtlocalpeer.cpp
++++ qtlocalpeer.cpp
+@@ -57,6 +57,7 @@
+ #endif
+ #if defined(Q_OS_UNIX)
+ #include <time.h>
++#include <unistd.h>
+ #endif
+
+ namespace QtLP_Private {
diff --git a/app-crypt/kencfs/kencfs-1.2.ebuild b/app-crypt/kencfs/kencfs-1.2.ebuild
index 446cc76c882b..be04af2c484b 100644
--- a/app-crypt/kencfs/kencfs-1.2.ebuild
+++ b/app-crypt/kencfs/kencfs-1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/kencfs/kencfs-1.2.ebuild,v 1.1 2012/01/10 14:44:20 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/kencfs/kencfs-1.2.ebuild,v 1.2 2012/06/21 09:35:07 kensington Exp $
EAPI=4
@@ -16,8 +16,13 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
DEPEND="kde-base/kdelibs
- x11-libs/qt-gui:4"
+ x11-libs/qt-gui:4
+"
RDEPEND="${DEPEND}
- sys-fs/encfs"
+ sys-fs/encfs
+"
-PATCHES=( "${FILESDIR}/${PN}-1.1-underlinking.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-1.1-underlinking.patch"
+ "${FILESDIR}/${P}-gcc-4.7.patch"
+)