summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/wordnet/ChangeLog6
-rw-r--r--app-dicts/wordnet/wordnet-3.0-r2.ebuild5
-rw-r--r--app-dicts/wordnet/wordnet-3.0.ebuild58
3 files changed, 7 insertions, 62 deletions
diff --git a/app-dicts/wordnet/ChangeLog b/app-dicts/wordnet/ChangeLog
index 7e35ff8a6e14..6b68a54fd681 100644
--- a/app-dicts/wordnet/ChangeLog
+++ b/app-dicts/wordnet/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-dicts/wordnet
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/wordnet/ChangeLog,v 1.17 2008/09/17 20:31:09 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/wordnet/ChangeLog,v 1.18 2008/12/16 00:48:25 pva Exp $
+
+ 16 Dec 2008; Peter Volkov <pva@gentoo.org> -wordnet-3.0.ebuild,
+ wordnet-3.0-r2.ebuild:
+ Don't clobber MAKEOPTS, bug #250144, thank SpanKY for report. Remove old.
17 Sep 2008; Markus Meier <maekke@gentoo.org> wordnet-3.0-r2.ebuild:
x86 stable, bug #211491
diff --git a/app-dicts/wordnet/wordnet-3.0-r2.ebuild b/app-dicts/wordnet/wordnet-3.0-r2.ebuild
index 9835b09fca79..7b6f2cf33b13 100644
--- a/app-dicts/wordnet/wordnet-3.0-r2.ebuild
+++ b/app-dicts/wordnet/wordnet-3.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/wordnet/wordnet-3.0-r2.ebuild,v 1.3 2008/09/17 20:31:09 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/wordnet/wordnet-3.0-r2.ebuild,v 1.4 2008/12/16 00:48:25 pva Exp $
inherit flag-o-matic autotools
@@ -44,14 +44,13 @@ src_unpack() {
src_compile() {
append-flags -DUNIX -I${T}/usr/include
- MAKEOPTS="-e"
PLATFORM=linux WN_ROOT="${T}/usr" \
WN_DICTDIR="${T}/usr/share/wordnet/dict" \
WN_MANDIR="${T}/usr/share/man" \
WN_DOCDIR="${T}/usr/share/doc/wordnet-${PV}" \
WNHOME="/usr/share/wordnet" \
econf
- emake || die "emake Failed"
+ emake -e || die "emake Failed"
}
src_install() {
diff --git a/app-dicts/wordnet/wordnet-3.0.ebuild b/app-dicts/wordnet/wordnet-3.0.ebuild
deleted file mode 100644
index 6a17fc80aca7..000000000000
--- a/app-dicts/wordnet/wordnet-3.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/wordnet/wordnet-3.0.ebuild,v 1.3 2008/09/12 19:36:30 pva Exp $
-
-inherit flag-o-matic autotools
-
-DESCRIPTION="A lexical database for the English language"
-HOMEPAGE="http://wordnet.princeton.edu/"
-SRC_URI="ftp://ftp.cogsci.princeton.edu/pub/wordnet/${PV}/WordNet-${PV}.tar.gz"
-LICENSE="Princeton"
-
-SLOT="0"
-KEYWORDS="~amd64 ~ppc x86"
-IUSE="doc"
-
-# In contrast to what the configure script seems to imply, Tcl/Tk is NOT optional.
-# cf. bug 163478 for details. (Yes, it's about 2.1 but it's still the same here.)
-DEPEND="dev-lang/tcl
- dev-lang/tk"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/WordNet-${PV}
-
-src_unpack() {
- unpack ${A}
- # Don't install into PREFIX/dict but PREFIX/share/wordnet/dict
- epatch "${FILESDIR}/${P}-dict-location.patch"
- # Fixes bug 130024, make an additional shared lib
- epatch "${FILESDIR}/${P}-shared-lib.patch"
- # Don't install the docs directly into PREFIX/doc but PREFIX/doc/PN
- epatch "${FILESDIR}/${P}-docs-path.patch"
-
- cd "${S}"
-
- # Don't install all the extra docs (html, pdf, ps) without doc USE flag.
- use doc || sed -i -e "s:SUBDIRS =.*:SUBDIRS = man:" doc/Makefile.am
-
- rm -f configure
- eautoreconf
-}
-
-src_compile() {
- append-flags -DUNIX -I${T}/usr/include
-
- MAKEOPTS="-e"
- PLATFORM=linux WN_ROOT="${T}/usr" \
- WN_DICTDIR="${T}/usr/share/wordnet/dict" \
- WN_MANDIR="${T}/usr/share/man" \
- WN_DOCDIR="${T}/usr/share/doc/wordnet-${PV}" \
- WNHOME="/usr/share/wordnet" \
- econf
- emake || die "emake Failed"
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "install failed"
- dodoc AUTHORS ChangeLog INSTALL README || die "dodoc failed"
-}