summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/linuxfromscratch/linuxfromscratch-6.5.ebuild')
-rw-r--r--app-doc/linuxfromscratch/linuxfromscratch-6.5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-doc/linuxfromscratch/linuxfromscratch-6.5.ebuild b/app-doc/linuxfromscratch/linuxfromscratch-6.5.ebuild
new file mode 100644
index 000000000000..53210e5c3e54
--- /dev/null
+++ b/app-doc/linuxfromscratch/linuxfromscratch-6.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/linuxfromscratch/linuxfromscratch-6.5.ebuild,v 1.1 2009/09/27 06:10:09 dirtyepic Exp $
+
+MY_SRC="http://www.linuxfromscratch.org/lfs/downloads/${PV}"
+
+BOOTSCRIPT_PV="20090812"
+UDEV_PV="20090523"
+
+DESCRIPTION="LFS documents building a Linux system entirely from source."
+HOMEPAGE="http://www.linuxfromscratch.org/lfs"
+SRC_URI="${MY_SRC}/LFS-BOOK-${PV}-HTML.tar.bz2
+ ${MY_SRC}/lfs-bootscripts-${BOOTSCRIPT_PV}.tar.bz2
+ ${MY_SRC}/udev-config-${UDEV_PV}.tar.bz2
+ htmlsingle? ( ${MY_SRC}/LFS-BOOK-${PV}-NOCHUNKS.html.bz2 )
+ pdf? ( ${MY_SRC}/LFS-BOOK-${PV}.pdf )"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="htmlsingle pdf"
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_install() {
+ # We don't want this stuff compressed
+ insinto /usr/share/doc/${PF}
+ doins -r * || die "Install failed."
+}