summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/e3/files/e3-2.33-gentoo.diff')
-rw-r--r--app-editors/e3/files/e3-2.33-gentoo.diff32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-editors/e3/files/e3-2.33-gentoo.diff b/app-editors/e3/files/e3-2.33-gentoo.diff
new file mode 100644
index 000000000000..085df6178c44
--- /dev/null
+++ b/app-editors/e3/files/e3-2.33-gentoo.diff
@@ -0,0 +1,32 @@
+diff -r -C2 e3-2.33.orig/Makefile e3-2.33/Makefile
+*** e3-2.33.orig/Makefile Sun Apr 22 07:40:34 2001
+--- e3-2.33/Makefile Sat Aug 18 14:25:35 2001
+***************
+*** 39,43 ****
+ # upx -q -q -q -k -9 e3 ; \
+ # fi ;
+! if which gzexe > /dev/null 2>&1 ; then gzexe e3; fi;
+ else
+ nasm $(AFLAGS) -o e3.o $(ASOURCES) -l e3.lst -D$(OS) -D$(EXMODE)
+--- 39,43 ----
+ # upx -q -q -q -k -9 e3 ; \
+ # fi ;
+! # if which gzexe > /dev/null 2>&1 ; then gzexe e3; fi;
+ else
+ nasm $(AFLAGS) -o e3.o $(ASOURCES) -l e3.lst -D$(OS) -D$(EXMODE)
+diff -r -C2 e3-2.33.orig/e3.asm e3-2.33/e3.asm
+*** e3-2.33.orig/e3.asm Sun Jul 8 12:31:25 2001
+--- e3-2.33/e3.asm Sat Aug 18 14:25:47 2001
+***************
+*** 23,27 ****
+ %define VI 8
+ %define NE 16
+! %define DEFAULT_MODE WS ;<---- select one of WS, EM, NE, PI, VI
+ %define MAKE_BACKUP
+ %define LESSWRITEOPS
+--- 23,27 ----
+ %define VI 8
+ %define NE 16
+! %define DEFAULT_MODE PI ;<---- select one of WS, EM, NE, PI, VI
+ %define MAKE_BACKUP
+ %define LESSWRITEOPS