summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/joe/joe-3.7.ebuild')
-rw-r--r--app-editors/joe/joe-3.7.ebuild6
1 files changed, 2 insertions, 4 deletions
diff --git a/app-editors/joe/joe-3.7.ebuild b/app-editors/joe/joe-3.7.ebuild
index 97a23d025893..30ca5246e813 100644
--- a/app-editors/joe/joe-3.7.ebuild
+++ b/app-editors/joe/joe-3.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-3.7.ebuild,v 1.1 2009/01/04 22:04:19 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-3.7.ebuild,v 1.2 2009/01/07 18:06:39 patrick Exp $
inherit flag-o-matic eutils
@@ -38,15 +38,13 @@ src_compile() {
# Bug 34609 (joe 2.9.8 editor seg-faults on 'find and replace' when compiled with -Os)
replace-flags "-Os" "-O2"
- econf || die
+ econf --docdir=/usr/share/doc/${PF} || die
emake || die
}
src_install() {
make install DESTDIR="${D}" || die "make install failed"
dodoc ChangeLog HACKING HINTS LIST NEWS README TODO
- # remove superfluous documentation, fixes bug #116861
- rm -rf "${D}"/etc/joe/doc
}
pkg_postinst() {