summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/jove/jove-4.16.0.58.ebuild')
-rw-r--r--app-editors/jove/jove-4.16.0.58.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/app-editors/jove/jove-4.16.0.58.ebuild b/app-editors/jove/jove-4.16.0.58.ebuild
index 1a240d242ed5..e5ad797e935a 100644
--- a/app-editors/jove/jove-4.16.0.58.ebuild
+++ b/app-editors/jove/jove-4.16.0.58.ebuild
@@ -1,22 +1,24 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jove/jove-4.16.0.58.ebuild,v 1.1 2004/02/26 03:16:01 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jove/jove-4.16.0.58.ebuild,v 1.2 2004/04/06 03:37:50 vapier Exp $
-IUSE="X"
+inherit eutils
-S=${WORKDIR}
DESCRIPTION="Jonathan's Own Version of Emacs -- a light emacs-like editor without LISP bindings"
HOMEPAGE="ftp://ftp.cs.toronto.edu/cs/ftp/pub/hugh/jove-dev/"
SRC_URI="http://ftp.debian.org/debian/pool/main/j/${PN}/${P/-/_}.orig.tar.gz
http://ftp.debian.org/debian/pool/main/j/${PN}/${P/-/_}-1.diff.gz"
-SLOT="0"
LICENSE="BSD"
+SLOT="0"
KEYWORDS="~x86"
+IUSE="X"
DEPEND="sys-libs/ncurses
X? ( x11-libs/xview )"
+S=${WORKDIR}
+
src_unpack() {
unpack ${A}
cd ${S}
@@ -31,8 +33,7 @@ src_unpack() {
src_compile() {
emake || die
- if use X
- then
+ if use X ; then
emake XJOVEJOME=/usr makexjove || die
fi
}
@@ -40,8 +41,7 @@ src_compile() {
src_install() {
make DESTDIR=${D} install || die
- if use X
- then
+ if use X ; then
make DESTDIR=${D} XJOVEHOME=${D}/usr MANDIR=${D}/usr/share/man/man1 installxjove || die
fi