summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/mp/mp-3.3.12-r1.ebuild')
-rw-r--r--app-editors/mp/mp-3.3.12-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-editors/mp/mp-3.3.12-r1.ebuild b/app-editors/mp/mp-3.3.12-r1.ebuild
new file mode 100644
index 000000000000..b9bfeb8139c7
--- /dev/null
+++ b/app-editors/mp/mp-3.3.12-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.3.12-r1.ebuild,v 1.1 2005/11/19 19:48:07 compnerd Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Minimum Profit: A text editor for programmers"
+HOMEPAGE="http://www.triptico.com/software/mp.html"
+SRC_URI="http://www.triptico.com/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gtk ncurses pcre"
+
+DEPEND="virtual/libc
+ ncurses? ( sys-libs/ncurses )
+ gtk? ( >=x11-libs/gtk+-2 >=x11-libs/pango-1.8.0 )
+ !gtk? ( sys-libs/ncurses )
+ pcre? ( dev-libs/libpcre )"
+RDEPEND="${DEPEND}
+ dev-lang/perl"
+
+src_compile() {
+ local myconf="--without-win32 --without-gtk1"
+
+ if use gtk ; then
+ ! use ncurses && myconf="${myconf} --without-curses"
+ else
+ myconf="${myconf} --without-gtk1 --without-gtk2"
+ fi
+
+ use pcre || myconf="${myconf} --without-pcre --with-included-regex"
+
+ sh config.sh ${myconf} || die "Configure failed"
+
+ echo ${CFLAGS} >> config.cflags
+ echo ${LDFLAGS} >> config.ldflags
+
+ emake || die "Compile Failed"
+}
+
+src_install() {
+ dobin mp || die "Install Failed"
+
+ use gtk && dosym mp ${DESTTREE}/bin/gmp
+
+ dodoc AUTHORS README Changelog mprc.sample
+ doman mp.1
+}