summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/nano/ChangeLog12
-rw-r--r--app-editors/nano/files/digest-nano-1.0.9-r11
-rw-r--r--app-editors/nano/files/newfile-gentoo.patch15
-rw-r--r--app-editors/nano/nano-1.0.9-r1.ebuild41
4 files changed, 53 insertions, 16 deletions
diff --git a/app-editors/nano/ChangeLog b/app-editors/nano/ChangeLog
index 5a5078da791b..94ef7b90b3b4 100644
--- a/app-editors/nano/ChangeLog
+++ b/app-editors/nano/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-editors/nano
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.7 2002/10/23 19:24:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.8 2002/11/30 10:58:06 mkennedy Exp $
+
+*nano-1.0.9-r1 (30 Nov 2002)
+
+ 30 Nov 2002; Matthew Kennedy <mkennedy@gentoo.org>
+ nano-1.0.9-r1.ebuild, files/digest-nano-1.0.9-r1,
+ files/newfile-gentoo.patch, ChangeLog :
+
+ Removed bizarre patch. Installed nano into /bin (resolves bug 11216 --
+ Lack of text editor in / mount point). Removed slang option (which
+ links into to /usr/ -- where does the madness end?)
*nano-1.0.9 (25 Sep 2002)
diff --git a/app-editors/nano/files/digest-nano-1.0.9-r1 b/app-editors/nano/files/digest-nano-1.0.9-r1
new file mode 100644
index 000000000000..542d3210e0b2
--- /dev/null
+++ b/app-editors/nano/files/digest-nano-1.0.9-r1
@@ -0,0 +1 @@
+MD5 499162ef77d0c5b9c2c171bae6052327 nano-1.0.9.tar.gz 451822
diff --git a/app-editors/nano/files/newfile-gentoo.patch b/app-editors/nano/files/newfile-gentoo.patch
deleted file mode 100644
index c52c2ae1ade6..000000000000
--- a/app-editors/nano/files/newfile-gentoo.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- nano.c.orig 2002-11-20 10:37:52.000000000 -0500
-+++ nano.c 2002-11-20 10:36:24.000000000 -0500
-@@ -2525,9 +2525,10 @@
-
- /* Now we check to see if argv[optind] is non-null to determine if
- we're dealing with a new file or not, not argc == 1... */
-- if (argv[optind] == NULL)
-+ if (argv[optind] == NULL) {
- new_file();
-- else
-+ statusbar(_("Gentoo pwns j00"));
-+ } else
- open_file(filename, 0, 0);
-
- if (startline > 0)
diff --git a/app-editors/nano/nano-1.0.9-r1.ebuild b/app-editors/nano/nano-1.0.9-r1.ebuild
new file mode 100644
index 000000000000..3fd406deacc7
--- /dev/null
+++ b/app-editors/nano/nano-1.0.9-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.0.9-r1.ebuild,v 1.1 2002/11/30 10:58:06 mkennedy Exp $
+
+DESCRIPTION="clone of Pico with more functions in a smaller size"
+SRC_URI="http://www.nano-editor.org/dist/v1.0/${P}.tar.gz"
+HOMEPAGE="http://www.nano-editor.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc sparc64 alpha"
+IUSE="nls build slang"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf="--bindir=/bin --enable-extra"
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ if use build ; then
+ myconf="${myconf} --disable-wrapping-as-root"
+ fi
+
+ econf ${myconf}
+ emake || die
+}
+
+src_install () {
+ make \
+ DESTDIR=${D} \
+ install || die
+
+ if use build; then
+ rm -rf ${D}/usr/share
+ else
+ dodoc COPYING ChangeLog README
+ fi
+}