summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/emacs-daemon/emacs-daemon-0.14.ebuild')
-rw-r--r--app-emacs/emacs-daemon/emacs-daemon-0.14.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/emacs-daemon/emacs-daemon-0.14.ebuild b/app-emacs/emacs-daemon/emacs-daemon-0.14.ebuild
new file mode 100644
index 000000000000..b9a400742559
--- /dev/null
+++ b/app-emacs/emacs-daemon/emacs-daemon-0.14.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-daemon/emacs-daemon-0.14.ebuild,v 1.1 2009/03/18 19:51:31 ulm Exp $
+
+NEED_EMACS=23
+
+inherit elisp
+
+DESCRIPTION="Gentoo support for Emacs running as a server in the background"
+HOMEPAGE="http://www.gentoo.org/proj/en/lisp/emacs/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-apps/openrc-0.4"
+
+SITEFILE="10${PN}-gentoo.el"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # compatibility code, to be removed later
+ sed -i -e "/^(/i\\" \
+ -e "(or (fboundp 'process-attributes)\\" \
+ -e " (defalias 'process-attributes 'system-process-attributes))" \
+ ${SITEFILE} || die "sed failed"
+}
+
+src_compile() { :; }
+
+src_install() {
+ newinitd emacs.rc emacs || die
+ newconfd emacs.conf emacs || die
+ exeinto /usr/libexec/emacs
+ doexe emacs-wrapper.sh || die
+ elisp-site-file-install "${SITEFILE}" || die
+ keepdir /var/run/emacs || die
+ dodoc README ChangeLog || die
+}