summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/initsplit/initsplit-1.6-r1.ebuild')
-rw-r--r--app-emacs/initsplit/initsplit-1.6-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-emacs/initsplit/initsplit-1.6-r1.ebuild b/app-emacs/initsplit/initsplit-1.6-r1.ebuild
new file mode 100644
index 000000000000..e2e3d9d2b3ce
--- /dev/null
+++ b/app-emacs/initsplit/initsplit-1.6-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/initsplit/initsplit-1.6-r1.ebuild,v 1.1 2007/10/14 09:41:19 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="Split customizations into different files"
+HOMEPAGE="http://www.emacswiki.org/cgi-bin/wiki?InitSplit"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+SITEFILE=51${PN}-gentoo.el
+
+pkg_postinst() {
+ elisp-site-regen
+ elog "Initsplit is no longer enabled as a site default. Add the following"
+ elog "line to your ~/.emacs file to enable configuration file splitting:"
+ elog " (add-hook 'write-file-hooks 'initsplit-split-user-init-file t)"
+ elog ""
+ elog "If you want configuration files byte-compiled, also add this line:"
+ elog " (add-hook 'after-save-hook 'initsplit-byte-compile-files t)"
+}