summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20080301.ebuild')
-rw-r--r--app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20080301.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20080301.ebuild b/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20080301.ebuild
new file mode 100644
index 000000000000..b5efd6d2c497
--- /dev/null
+++ b/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20080301.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20080301.ebuild,v 1.1 2008/03/01 00:22:35 flameeyes Exp $
+
+inherit elisp
+
+DESCRIPTION="Extension for nxml-mode with Gentoo-specific schemas"
+HOMEPAGE="http://blog.flameeyes.eu/"
+SRC_URI="http://www.flameeyes.eu/files/${P}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=app-emacs/nxml-mode-20041004-r3"
+
+SITEFILE=60${PN}-gentoo.el
+
+src_compile() { :; }
+
+src_install() {
+ insinto ${SITEETC}/${PN}
+ doins schemas.xml *.rnc || die "install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ dodoc DONATING
+}