summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/pymacs/pymacs-0.23.ebuild')
-rw-r--r--app-emacs/pymacs/pymacs-0.23.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/pymacs/pymacs-0.23.ebuild b/app-emacs/pymacs/pymacs-0.23.ebuild
new file mode 100644
index 000000000000..b011466e2ca3
--- /dev/null
+++ b/app-emacs/pymacs/pymacs-0.23.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/pymacs/pymacs-0.23.ebuild,v 1.1 2008/02/16 22:54:47 ulm Exp $
+
+inherit distutils elisp
+
+MY_P=Pymacs-${PV}
+DESCRIPTION="A tool that allows both-side communication beetween Python and Emacs Lisp"
+HOMEPAGE="http://pymacs.progiciels-bpi.ca/"
+SRC_URI="http://pymacs.progiciels-bpi.ca/archives/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd"
+IUSE="doc"
+
+DEPEND="doc? ( dev-python/docutils virtual/latex-base )"
+RDEPEND=""
+
+SITEFILE=50${PN}-gentoo.el
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ emake || die "emake failed"
+ elisp-compile pymacs.el || die "elisp-compile failed"
+ if use doc; then
+ emake pymacs.pdf || die "emake pymacs.pdf failed"
+ fi
+}
+
+src_install() {
+ elisp_src_install
+ distutils_src_install
+ dodoc THANKS pymacs.rst
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins pymacs.pdf
+ fi
+}