summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/cedet/ChangeLog9
-rw-r--r--app-emacs/cedet/cedet-1.0_pre6.ebuild4
-rw-r--r--app-emacs/cedet/cedet-1.0_pre7.ebuild82
-rw-r--r--app-emacs/cedet/files/50cedet-gentoo-1.0_pre6.el10
-rw-r--r--app-emacs/cedet/files/50cedet-gentoo.el2
5 files changed, 104 insertions, 3 deletions
diff --git a/app-emacs/cedet/ChangeLog b/app-emacs/cedet/ChangeLog
index b6b90ce1cc63..b63c45755c9b 100644
--- a/app-emacs/cedet/ChangeLog
+++ b/app-emacs/cedet/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emacs/cedet
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/cedet/ChangeLog,v 1.48 2010/01/03 17:55:09 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/cedet/ChangeLog,v 1.49 2010/02/27 10:30:48 ulm Exp $
+
+*cedet-1.0_pre7 (27 Feb 2010)
+
+ 27 Feb 2010; Ulrich Mueller <ulm@gentoo.org> cedet-1.0_pre6.ebuild,
+ +cedet-1.0_pre7.ebuild, +files/50cedet-gentoo-1.0_pre6.el,
+ files/50cedet-gentoo.el:
+ Version bump. Update site-init file.
03 Jan 2010; Ulrich Mueller <ulm@gentoo.org> cedet-1.0_pre6.ebuild:
Explicitly add srecode to the load-path in src_test, fixes bug 299461.
diff --git a/app-emacs/cedet/cedet-1.0_pre6.ebuild b/app-emacs/cedet/cedet-1.0_pre6.ebuild
index 3730874bfec9..8ba4b70a19b2 100644
--- a/app-emacs/cedet/cedet-1.0_pre6.ebuild
+++ b/app-emacs/cedet/cedet-1.0_pre6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/cedet/cedet-1.0_pre6.ebuild,v 1.9 2010/01/03 17:55:09 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/cedet/cedet-1.0_pre6.ebuild,v 1.10 2010/02/27 10:30:48 ulm Exp $
NEED_EMACS=22
@@ -23,7 +23,7 @@ RDEPEND="!app-emacs/semantic
S="${WORKDIR}/${MY_P}"
ELISP_PATCHES="${P}-fix-eieio-comp.patch"
-SITEFILE="50${PN}-gentoo.el"
+SITEFILE="50${PN}-gentoo-${PV}.el"
src_compile() {
emake -j1 \
diff --git a/app-emacs/cedet/cedet-1.0_pre7.ebuild b/app-emacs/cedet/cedet-1.0_pre7.ebuild
new file mode 100644
index 000000000000..6ca28088cb6a
--- /dev/null
+++ b/app-emacs/cedet/cedet-1.0_pre7.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/cedet/cedet-1.0_pre7.ebuild,v 1.1 2010/02/27 10:30:48 ulm Exp $
+
+NEED_EMACS=22
+
+inherit elisp
+
+MY_P=${P/_}
+DESCRIPTION="CEDET: Collection of Emacs Development Tools"
+HOMEPAGE="http://cedet.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cedet/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos ~sparc-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!app-emacs/semantic
+ !app-emacs/eieio
+ !app-emacs/speedbar"
+
+S="${WORKDIR}/${MY_P}"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ emake -j1 \
+ EMACS="${EMACS}" \
+ EMACSFLAGS="${EMACSFLAGS}" \
+ || die "emake failed"
+}
+
+src_test() {
+ emake -j1 \
+ EMACS="${EMACS}" \
+ EMACSFLAGS="${EMACSFLAGS} -L srecode" \
+ utest || die "make utest failed"
+}
+
+src_install() {
+ local target file dir
+ find . -type d -name tests -prune -o -type f -print | while read target
+ do
+ file=${target##*/}
+ dir=${target%/*}; dir=${dir#./}
+ case "${file}" in
+ *~ | Makefile | *.texi | *-script | PRERELEASE_CHECKLIST \
+ | Project.ede | USING_CEDET_FROM_CVS | grammar-fw-ov.txt)
+ ;;
+ ChangeLog | README | AUTHORS | *NEWS | INSTALL \
+ | renamelist.txt | semanticdb.sh)
+ docinto "${dir}"
+ dodoc "${target}" || die ;;
+ *.el | *.by | *.wy)
+ # install grammar sources along with the elisp files, since
+ # the location where semantic expects them is not configurable
+ insinto "${SITELISP}/${PN}/${dir}"
+ doins "${target}" || die ;;
+ *.elc)
+ # we are in a subshell, so collecting in a variable won't work
+ echo "${target}" >>"${T}/elc-list.txt" ;;
+ *.srt | *.xpm)
+ insinto "${SITEETC}/${PN}/${dir}"
+ doins "${target}" || die ;;
+ *.info* | grammar-fw-ov.png)
+ doinfo "${target}" || die ;;
+ *)
+ die "Unrecognised file ${target}" ;;
+ esac
+ done
+
+ # make sure that the compiled elisp files have a later time stamp than
+ # the corresponding sources, in order to suppress warnings at run time
+ while read target; do
+ dir=${target%/*}; dir=${dir#./}
+ insinto "${SITELISP}/${PN}/${dir}"
+ doins "${target}" || die
+ done <"${T}/elc-list.txt"
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+}
diff --git a/app-emacs/cedet/files/50cedet-gentoo-1.0_pre6.el b/app-emacs/cedet/files/50cedet-gentoo-1.0_pre6.el
new file mode 100644
index 000000000000..6b7abf49da30
--- /dev/null
+++ b/app-emacs/cedet/files/50cedet-gentoo-1.0_pre6.el
@@ -0,0 +1,10 @@
+(load "@SITELISP@/common/cedet" nil t)
+(add-to-list 'image-load-path "@SITEETC@/common/icons" t)
+(setq srecode-map-load-path
+ (list "@SITEETC@/srecode/templates"
+ "@SITEETC@/ede/templates"
+ (expand-file-name "~/.srecode")))
+
+;; If you wish to customize CEDET, you will need to follow the
+;; directions in the INSTALL (installed in the documentation) file and
+;; customize your ~/.emacs /before/ site-gentoo is loaded.
diff --git a/app-emacs/cedet/files/50cedet-gentoo.el b/app-emacs/cedet/files/50cedet-gentoo.el
index 6b7abf49da30..231f65a2b3c7 100644
--- a/app-emacs/cedet/files/50cedet-gentoo.el
+++ b/app-emacs/cedet/files/50cedet-gentoo.el
@@ -1,8 +1,10 @@
(load "@SITELISP@/common/cedet" nil t)
(add-to-list 'image-load-path "@SITEETC@/common/icons" t)
+(add-to-list 'image-load-path "@SITEETC@/cogre" t)
(setq srecode-map-load-path
(list "@SITEETC@/srecode/templates"
"@SITEETC@/ede/templates"
+ "@SITEETC@/cogre/templates"
(expand-file-name "~/.srecode")))
;; If you wish to customize CEDET, you will need to follow the