summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine')
-rw-r--r--app-emulation/wine/ChangeLog6
-rw-r--r--app-emulation/wine/wine-1.1.39.ebuild5
-rw-r--r--app-emulation/wine/wine-1.1.40.ebuild5
3 files changed, 11 insertions, 5 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index 5e6e15be1800..8f655ebd6676 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/wine
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.297 2010/03/05 20:17:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.298 2010/03/06 21:45:27 vapier Exp $
+
+ 06 Mar 2010; Mike Frysinger <vapier@gentoo.org> wine-1.1.39.ebuild,
+ wine-1.1.40.ebuild:
+ Fix up pulse patches #307927 by Marc-Antoine Perennou.
*wine-1.1.40 (05 Mar 2010)
diff --git a/app-emulation/wine/wine-1.1.39.ebuild b/app-emulation/wine/wine-1.1.39.ebuild
index beee2585fc44..18d6449395a0 100644
--- a/app-emulation/wine/wine-1.1.39.ebuild
+++ b/app-emulation/wine/wine-1.1.39.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.1.39.ebuild,v 1.1 2010/03/05 18:09:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.1.39.ebuild,v 1.2 2010/03/06 21:45:27 vapier Exp $
EAPI="2"
@@ -103,7 +103,7 @@ src_unpack() {
src_prepare() {
if use pulseaudio ; then
- epatch `pulse_patches "${DISTDIR}"`
+ EPATCH_OPTS=-p1 epatch `pulse_patches "${DISTDIR}"`
eautoreconf
fi
epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
@@ -142,6 +142,7 @@ src_configure() {
$(use_with oss) \
$(use_with png) \
$(use_with threads pthread) \
+ $(use_with pulseaudio pulse) \
$(use_with scanner sane) \
$(use_enable test tests) \
$(use_with truetype freetype) \
diff --git a/app-emulation/wine/wine-1.1.40.ebuild b/app-emulation/wine/wine-1.1.40.ebuild
index 26f6b9f8a098..841f2d85c035 100644
--- a/app-emulation/wine/wine-1.1.40.ebuild
+++ b/app-emulation/wine/wine-1.1.40.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.1.40.ebuild,v 1.1 2010/03/05 20:17:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.1.40.ebuild,v 1.2 2010/03/06 21:45:27 vapier Exp $
EAPI="2"
@@ -103,7 +103,7 @@ src_unpack() {
src_prepare() {
if use pulseaudio ; then
- epatch `pulse_patches "${DISTDIR}"`
+ EPATCH_OPTS=-p1 epatch `pulse_patches "${DISTDIR}"`
eautoreconf
fi
epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
@@ -142,6 +142,7 @@ src_configure() {
$(use_with oss) \
$(use_with png) \
$(use_with threads pthread) \
+ $(use_with pulseaudio pulse) \
$(use_with scanner sane) \
$(use_enable test tests) \
$(use_with truetype freetype) \