summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/libguestfs-appliance/ChangeLog11
-rw-r--r--app-emulation/libguestfs-appliance/libguestfs-appliance-1.24.8.ebuild32
-rw-r--r--app-emulation/libguestfs-appliance/libguestfs-appliance-1.26.0.ebuild32
3 files changed, 73 insertions, 2 deletions
diff --git a/app-emulation/libguestfs-appliance/ChangeLog b/app-emulation/libguestfs-appliance/ChangeLog
index 0e0dc9fd40b4..cbe2047ae775 100644
--- a/app-emulation/libguestfs-appliance/ChangeLog
+++ b/app-emulation/libguestfs-appliance/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/libguestfs-appliance
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libguestfs-appliance/ChangeLog,v 1.1 2013/03/25 12:06:45 maksbotan Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libguestfs-appliance/ChangeLog,v 1.2 2014/05/01 19:57:02 maksbotan Exp $
+
+*libguestfs-appliance-1.24.8 (01 May 2014)
+*libguestfs-appliance-1.26.0 (01 May 2014)
+
+ 01 May 2014; Maxim Koltsov <maksbotan@gentoo.org>
+ +libguestfs-appliance-1.24.8.ebuild, +libguestfs-appliance-1.26.0.ebuild:
+ Bump to 1.24.8 and 1.26.0
*libguestfs-appliance-1.20.0 (25 Mar 2013)
diff --git a/app-emulation/libguestfs-appliance/libguestfs-appliance-1.24.8.ebuild b/app-emulation/libguestfs-appliance/libguestfs-appliance-1.24.8.ebuild
new file mode 100644
index 000000000000..42a775957b91
--- /dev/null
+++ b/app-emulation/libguestfs-appliance/libguestfs-appliance-1.24.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libguestfs-appliance/libguestfs-appliance-1.24.8.ebuild,v 1.1 2014/05/01 19:57:02 maksbotan Exp $
+
+EAPI=5
+
+CHECKREQS_DISK_USR=500M
+CHECKREQS_DISK_BUILD=500M
+
+inherit check-reqs
+
+DESCRIPTION="VM appliance disk image used in libguestfs package"
+HOMEPAGE="http://libguestfs.org/"
+SRC_URI="http://libguestfs.org/download/binaries/appliance/appliance-${PV}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/share/guestfs/
+ doins -r appliance/
+
+ newenvd "${FILESDIR}"/env.file 99"${PN}"
+}
diff --git a/app-emulation/libguestfs-appliance/libguestfs-appliance-1.26.0.ebuild b/app-emulation/libguestfs-appliance/libguestfs-appliance-1.26.0.ebuild
new file mode 100644
index 000000000000..9da4960fda00
--- /dev/null
+++ b/app-emulation/libguestfs-appliance/libguestfs-appliance-1.26.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libguestfs-appliance/libguestfs-appliance-1.26.0.ebuild,v 1.1 2014/05/01 19:57:02 maksbotan Exp $
+
+EAPI=5
+
+CHECKREQS_DISK_USR=500M
+CHECKREQS_DISK_BUILD=500M
+
+inherit check-reqs
+
+DESCRIPTION="VM appliance disk image used in libguestfs package"
+HOMEPAGE="http://libguestfs.org/"
+SRC_URI="http://libguestfs.org/download/binaries/appliance/appliance-${PV}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/share/guestfs/
+ doins -r appliance/
+
+ newenvd "${FILESDIR}"/env.file 99"${PN}"
+}