summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-forensics/aide/aide-0.10.ebuild')
-rw-r--r--app-forensics/aide/aide-0.10.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-forensics/aide/aide-0.10.ebuild b/app-forensics/aide/aide-0.10.ebuild
new file mode 100644
index 000000000000..a350db2a9748
--- /dev/null
+++ b/app-forensics/aide/aide-0.10.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/aide/aide-0.10.ebuild,v 1.1 2004/09/12 06:44:02 dragonheart Exp $
+
+inherit eutils
+
+DESCRIPTION="AIDE (Advanced Intrusion Detection Environment) is a replacement for Tripwire"
+HOMEPAGE="http://aide.sourceforge.net/"
+SRC_URI="mirror://sourceforge/aide/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc ~sparc alpha ~amd64"
+IUSE="nls postgres zlib crypt"
+
+DEPEND="app-arch/gzip
+ sys-devel/bison
+ sys-devel/flex
+ app-crypt/mhash
+ crypt? ( dev-libs/libgcrypt )
+ postgres? ( dev-db/postgresql )
+ zlib? ( sys-libs/zlib )"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+ # passing --without-psql or --with-psql causes postgres to be enabled ...
+ # it's a broken configure.in file ... so lets just work around it
+ local myconf=""
+ use postgres && myconf="$myconf --with-psql"
+ use crypt && myconf="$myconf --with-gcrypt"
+
+ econf \
+ `use_with zlib` \
+ `use_with nls locale` \
+ --with-mhash \
+ --sysconfdir=/etc/aide \
+ --with-extra-lib=/usr/lib \
+ ${myconf} \
+ || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ use nls || rm -rf ${D}/usr/lib/locale
+
+ insinto /etc/aide
+ doins doc/aide.conf
+
+ dodoc AUTHORS NEWS README
+ dohtml doc/manual.html
+}