summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-forensics/aide/aide-0.9.ebuild')
-rw-r--r--app-forensics/aide/aide-0.9.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/app-forensics/aide/aide-0.9.ebuild b/app-forensics/aide/aide-0.9.ebuild
deleted file mode 100644
index 87e5f28035fb..000000000000
--- a/app-forensics/aide/aide-0.9.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/aide/aide-0.9.ebuild,v 1.3 2005/01/01 14:21:52 eradicator Exp $
-
-inherit eutils
-
-DESCRIPTION="AIDE (Advanced Intrusion Detection Environment) is a replacement for Tripwire"
-HOMEPAGE="http://aide.sourceforge.net/"
-SRC_URI="mirror://sourceforge/aide/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ppc sparc alpha"
-IUSE="nls postgres zlib crypt"
-
-DEPEND="app-arch/gzip
- sys-devel/bison
- sys-devel/flex
- app-crypt/mhash
- crypt? ( dev-libs/libgcrypt )
- postgres? ( dev-db/postgresql )
- zlib? ( sys-libs/zlib )"
-RDEPEND="nls? ( sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PF}-gentoo.diff
-}
-
-src_compile() {
- # passing --without-psql or --with-psql causes postgres to be enabled ...
- # it's a broken configure.in file ... so lets just work around it
- local myconf=""
- use postgres && myconf="$myconf --with-psql"
- use crypt && myconf="$myconf --with-gcrypt"
-
- econf \
- `use_with zlib` \
- `use_with nls locale` \
- --with-mhash \
- --sysconfdir=/etc/aide \
- --with-extra-lib=/usr/lib \
- ${myconf} \
- || die
- emake || die
-}
-
-src_install() {
- einstall || die
- use nls || rm -rf ${D}/usr/lib/locale
-
- insinto /etc/aide
- doins doc/aide.conf
-
- dodoc AUTHORS NEWS README
- dohtml doc/manual.html
-}