summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-forensics/tct/files/tct-1.15-gentoo.diff')
-rw-r--r--app-forensics/tct/files/tct-1.15-gentoo.diff116
1 files changed, 107 insertions, 9 deletions
diff --git a/app-forensics/tct/files/tct-1.15-gentoo.diff b/app-forensics/tct/files/tct-1.15-gentoo.diff
index cc4ccf5dbaa2..b66bf9aded71 100644
--- a/app-forensics/tct/files/tct-1.15-gentoo.diff
+++ b/app-forensics/tct/files/tct-1.15-gentoo.diff
@@ -1,6 +1,65 @@
+diff -urN tct-1.15.orig/Makefile tct-1.15/Makefile
+--- tct-1.15.orig/Makefile 2001-09-15 16:23:28.000000000 -0400
++++ tct-1.15/Makefile 2004-09-16 23:52:56.153253952 -0400
+@@ -16,7 +16,6 @@
+ cd src/misc; make "CC=$(CC)" MAKELEVEL=
+ cd src/fstools; make "CC=$(CC)" MAKELEVEL=
+ cd src/pcat; make "CC=$(CC)" MAKELEVEL=
+- cd src/file; make "CC=$(CC)" MAKELEVEL=
+ cd src/lastcomm; make "CC=$(CC)" MAKELEVEL=
+ cd src/major_minor; make "CC=$(CC)" MAKELEVEL=
+ cd extras/entropy; make "CC=$(CC)" MAKELEVEL=
+@@ -30,7 +29,6 @@
+ cd src/misc; make $@ "CC=$(CC)" MAKELEVEL=
+ cd src/fstools; make $@ "CC=$(CC)" MAKELEVEL=
+ cd src/pcat; make $@ "CC=$(CC)" MAKELEVEL=
+- cd src/file; make $@ "CC=$(CC)" MAKELEVEL=
+ cd src/lastcomm; make $@ "CC=$(CC)" MAKELEVEL=
+ cd src/major_minor; make $@ "CC=$(CC)" MAKELEVEL=
+ cd extras/entropy; make $@ "CC=$(CC)" MAKELEVEL=
+@@ -44,7 +42,6 @@
+ cd src/misc; make $@ "CC=$(CC)" MAKELEVEL=
+ cd src/fstools; make $@ "CC=$(CC)" MAKELEVEL=
+ cd src/pcat; make $@ "CC=$(CC)" MAKELEVEL=
+- cd src/file; make $@ "CC=$(CC)" MAKELEVEL=
+ cd src/lastcomm; make $@ "CC=$(CC)" MAKELEVEL=
+ cd src/major_minor; make $@ "CC=$(CC)" MAKELEVEL=
+ cd extras/entropy; make $@ "CC=$(CC)" MAKELEVEL=
+diff -urN tct-1.15.orig/bin/grave-robber tct-1.15/bin/grave-robber
+--- tct-1.15.orig/bin/grave-robber 2004-01-22 14:48:01.000000000 -0500
++++ tct-1.15/bin/grave-robber 2004-09-17 00:47:07.559965000 -0400
+@@ -424,9 +424,7 @@
+ die "Can't find TCT_HOME - did you run reconfig?\n";
+ }
+
+-if (!-f "$BIN/file") {
+- die "Can't find our \"$BIN/file\" command - did you type \"make\" first?\n";
+- }
++die "Can't find \"$FILE\" command \n" unless (-f $FILE);
+
+ require "logger.pl";
+ require "command.pl";
+@@ -495,15 +493,10 @@
+ #
+ # we usually carry around the alternate magic file...
+ #
+-if (-f "$ETC/magic") { $magic_file = "$ETC/magic"; }
+- else {
+- die "Can't find the /etc/magic file\n" unless (-f "/etc/magic");
+- $magic_file = "/etc/magic";
+- warn "Couldn't find $ETC/magic, switching over to $magic_file\n";
+- }
++$magic_file = "/usr/share/misc/file/magic";
++die "Can't find $magic_file" unless (-f $magic_file);
+
+ }
+-
+ #
+ # does a system have a proc file system? Returns 0 if so, !0 if no
+ #
diff -urN tct-1.15.orig/conf/coroner.cf tct-1.15/conf/coroner.cf
--- tct-1.15.orig/conf/coroner.cf 2004-01-22 14:48:00.000000000 -0500
-+++ tct-1.15/conf/coroner.cf 2004-09-16 10:16:17.209578032 -0400
++++ tct-1.15/conf/coroner.cf 2004-09-16 23:44:43.288180832 -0400
@@ -2,7 +2,7 @@
# Configuration file for coroner's toolkit
#
@@ -21,7 +80,7 @@ diff -urN tct-1.15.orig/conf/coroner.cf tct-1.15/conf/coroner.cf
# What colors to use for MACtime HTML stuff
diff -urN tct-1.15.orig/conf/grave-robber.cf tct-1.15/conf/grave-robber.cf
--- tct-1.15.orig/conf/grave-robber.cf 2004-01-22 14:48:00.000000000 -0500
-+++ tct-1.15/conf/grave-robber.cf 2004-09-16 10:16:02.543440243 -0400
++++ tct-1.15/conf/grave-robber.cf 2004-09-16 23:44:43.288180832 -0400
@@ -2,7 +2,7 @@
# Configuration file for coroner's toolkit
#
@@ -42,28 +101,67 @@ diff -urN tct-1.15.orig/conf/grave-robber.cf tct-1.15/conf/grave-robber.cf
# Don't copy file larger than this (bytes). Set to 0 if don't want limits
diff -urN tct-1.15.orig/conf/paths.pl tct-1.15/conf/paths.pl
--- tct-1.15.orig/conf/paths.pl 2004-01-08 17:29:05.000000000 -0500
-+++ tct-1.15/conf/paths.pl 2004-09-16 12:21:38.645527494 -0400
-@@ -23,7 +23,7 @@
++++ tct-1.15/conf/paths.pl 2004-09-16 23:46:48.573134624 -0400
+@@ -13,7 +13,7 @@
+
+ $CRONTAB="/usr/bin/crontab";
+ $DATE="/bin/date";
+-$DMESG="/sbin/dmesg";
++$DMESG="/bin/dmesg";
+ $DOMAINNAME="/bin/domainname";
+ $ECHO="/bin/echo";
+
+@@ -21,20 +21,20 @@
+ $FINGER="/usr/bin/finger";
+ $IFCONFIG="/sbin/ifconfig";
$IPCS="/usr/bin/ipcs";
- $LAST="/usr/bin/last";
+-$LAST="/usr/bin/last";
++$LAST="/bin/last";
-$LSOF="/usr/local/sbin/lsof";
+$LSOF="/usr/sbin/lsof";
$MKDIR="/bin/mkdir";
- $NETSTAT="/usr/bin/netstat";
+-$NETSTAT="/usr/bin/netstat";
++$NETSTAT="/bin/netstat";
$PS="/bin/ps";
-@@ -61,7 +61,7 @@
+ $PWD="/bin/pwd";
+
+-$RPCINFO="/usr/bin/rpcinfo";
++$RPCINFO="/usr/sbin/rpcinfo";
+ $SHOWMOUNT="/usr/bin/showmount";
+ $STRINGS="/usr/bin/strings";
+-$SU="/usr/bin/su";
++$SU="/bin/su";
+ $SYNC="/bin/sync";
+-$TEE="/usr/bin/tee";
++$TEE="/bin/tee";
+
+ $TOP="/usr/bin/top";
+ $UNAME="/usr/bin/uname";
+@@ -61,9 +61,9 @@
$PSTAT="/usr/sbin/pstat";
# linux
-$RPM="/usr/local/bin/rpm";
+$RPM="/usr/bin/rpm";
$KSYMS="/sbin/ksyms";
- $LSMOD="/sbin/lsmod";
+-$LSMOD="/sbin/lsmod";
++$LSMOD="/bin/lsmod";
+ # kernel modules
+ $MODINFO="/sbin/modinfo";
+@@ -77,7 +77,7 @@
+ #
+ # our stuff
+ #
+-$FILE = "$TCT_HOME/bin/file";
++$FILE = "/usr/bin/file";
+ $MD5 = "$TCT_HOME/bin/md5";
+ $PCAT = "$TCT_HOME/bin/pcat";
+ $ICAT = "$TCT_HOME/bin/icat";
diff -urN tct-1.15.orig/reconfig tct-1.15/reconfig
--- tct-1.15.orig/reconfig 2001-09-15 16:48:51.000000000 -0400
-+++ tct-1.15/reconfig 2004-09-16 09:43:15.790293315 -0400
++++ tct-1.15/reconfig 2004-09-16 23:44:43.289180680 -0400
@@ -157,7 +157,8 @@
"extras/ils2mac", "extras/realpath");