summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/aide/ChangeLog7
-rw-r--r--app-forensics/aide/aide-0.13.1-r1.ebuild136
-rw-r--r--app-forensics/autopsy/ChangeLog6
-rw-r--r--app-forensics/autopsy/autopsy-2.01.ebuild58
-rw-r--r--app-forensics/autopsy/autopsy-2.05.ebuild58
-rw-r--r--app-forensics/autopsy/autopsy-2.08.ebuild56
-rw-r--r--app-forensics/cmospwd/ChangeLog5
-rw-r--r--app-forensics/cmospwd/cmospwd-5.0.ebuild24
8 files changed, 14 insertions, 336 deletions
diff --git a/app-forensics/aide/ChangeLog b/app-forensics/aide/ChangeLog
index 032c8feb975a..f664fe39ff67 100644
--- a/app-forensics/aide/ChangeLog
+++ b/app-forensics/aide/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-forensics/aide
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/aide/ChangeLog,v 1.36 2008/05/19 16:16:13 dev-zero Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/aide/ChangeLog,v 1.37 2009/01/08 19:49:26 patrick Exp $
+
+ 08 Jan 2009; Patrick Lauer <patrick@gentoo.org> -aide-0.13.1-r1.ebuild:
+ Removing unneeded old
19 May 2008; Tiziano Müller <dev-zero@gentoo.org> aide-0.13.1.ebuild,
aide-0.13.1-r1.ebuild, aide-0.13.1-r2.ebuild:
diff --git a/app-forensics/aide/aide-0.13.1-r1.ebuild b/app-forensics/aide/aide-0.13.1-r1.ebuild
deleted file mode 100644
index a771833e61e2..000000000000
--- a/app-forensics/aide/aide-0.13.1-r1.ebuild
+++ /dev/null
@@ -1,136 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/aide/aide-0.13.1-r1.ebuild,v 1.3 2008/05/19 16:16:13 dev-zero Exp $
-WANT_AUTOCONF='latest'
-WANT_AUTOMAKE='latest'
-inherit eutils autotools
-
-DESCRIPTION="AIDE (Advanced Intrusion Detection Environment) is a replacement for Tripwire"
-HOMEPAGE="http://aide.sourceforge.net/"
-SRC_URI="mirror://sourceforge/aide/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
-IUSE="acl curl mhash nls postgres selinux static xattr zlib"
-#IUSE="acl audit curl mhash nls postgres selinux static xattr zlib"
-
-DEPEND="acl? ( sys-apps/acl )
- curl? ( net-misc/curl )
- mhash? ( >=app-crypt/mhash-0.9.2 )
- !mhash? ( dev-libs/libgcrypt )
- nls? ( virtual/libintl )
- postgres? ( virtual/postgresql-base )
- selinux? ( sys-libs/libselinux )
- xattr? ( sys-apps/attr )
- zlib? ( sys-libs/zlib )"
-# audit? ( sys-process/audit )
-
-RDEPEND="!static? ( ${DEPEND} )
- virtual/mailx"
-
-DEPEND="${DEPEND}
- nls? ( sys-devel/gettext )
- sys-devel/bison
- sys-devel/flex"
-
-pkg_config() {
- if use mhash && use postgres ; then
- eerror "We cannot emerge aide with mhash and postgres USE flags at the same time."
- eerror "Please remove mhash OR postgres USE flags."
- die "Please remove either mhash or postgres USE flag."
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gentoo.patch
-
- if ! use mhash ; then
- # dev-libs/libgcrypt doesn't support whirlpool algorithm
- sed -i -e 's/\+whirlpool//' doc/aide.conf.in || die
- fi
-
- if ! use selinux ; then
- sed -i -e 's/\+selinux//' doc/aide.conf.in || die
- fi
-
- if ! use xattr ; then
- sed -i -e 's/\+xattrs//' doc/aide.conf.in || die
- fi
-
- if ! use acl ; then
- sed -i -e 's/\+acl//' doc/aide.conf.in || die
- fi
- eautoreconf
-}
-
-src_compile() {
- local myconf="--sysconfdir=/etc/aide $(use_enable static)"
-
- # --without-* borked
- use zlib && myconf="${myconf} --with-zlib"
- use nls && myconf="${myconf} --with-locale"
- use postgres && myconf="${myconf} --with-psql"
- use selinux && myconf="${myconf} --with-selinux"
- use acl && myconf="${myconf} --with-posix-acl"
- use xattr && myconf="${myconf} --with-xattr"
-# use audit && myconf="${myconf} --with-audit"
-
- # curl doesn't work with static
- use curl && ! use static && myconf="${myconf} --with-curl"
-
- # If you use dev-libs/libgcrypt, --without-mhash is needed.
- use mhash \
- && myconf="${myconf} --with-mhash" \
- || myconf="${myconf} --with-gcrypt --without-mhash"
-
- econf ${myconf} || die
- # parallel make borked
- emake -j1 || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- keepdir /var/lib/aide
- keepdir /var/log/aide
-
- insinto /etc/aide
- doins "${FILESDIR}"/aide.conf
- # doins doc/aide.conf
-
- dosbin "${FILESDIR}"/aideinit
-
- dodoc ChangeLog AUTHORS NEWS README "${FILESDIR}"/aide.cron
- dohtml doc/manual.html
-}
-
-pkg_postinst() {
- chown root:0 /var/lib/aide
- chmod 0755 /var/lib/aide
-
- elog
- elog "A sample configuration file has been installed as"
- elog "/etc/aide/aide.conf. Please edit to meet your needs."
- elog "Read the aide.conf(5) manual page for more information."
- elog "A cron file has been installed in /etc/cron.daily/aide.cron"
- elog "A helper script, aideinit, has been installed and can"
- elog "be used to make AIDE management easier. Please run"
- elog "aideinit --help for more information"
- elog
-
- if use postgres; then
- elog "Due to a bad assumption by aide, you must issue the following"
- elog "command after the database initialization (aide --init ...):"
- elog
- elog 'psql -c "update pg_index set indisunique=false from pg_class \\ '
- elog " where pg_class.relname='TABLE_pkey' and \ "
- elog ' pg_class.oid=pg_index.indexrelid" -h HOSTNAME -p PORT DBASE USER'
- elog
- elog "where TABLE, HOSTNAME, PORT, DBASE, and USER are the same as"
- elog "your aide.conf."
- elog
- fi
-}
diff --git a/app-forensics/autopsy/ChangeLog b/app-forensics/autopsy/ChangeLog
index ada2840d5077..fc2e05c03898 100644
--- a/app-forensics/autopsy/ChangeLog
+++ b/app-forensics/autopsy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-forensics/autopsy
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/autopsy/ChangeLog,v 1.13 2009/01/04 23:52:27 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/autopsy/ChangeLog,v 1.14 2009/01/08 19:49:26 patrick Exp $
+
+ 08 Jan 2009; Patrick Lauer <patrick@gentoo.org> -autopsy-2.01.ebuild,
+ -autopsy-2.05.ebuild, -autopsy-2.08.ebuild:
+ Removing old versions
*autopsy-2.20 (04 Jan 2009)
diff --git a/app-forensics/autopsy/autopsy-2.01.ebuild b/app-forensics/autopsy/autopsy-2.01.ebuild
deleted file mode 100644
index 86837c15677a..000000000000
--- a/app-forensics/autopsy/autopsy-2.01.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/autopsy/autopsy-2.01.ebuild,v 1.5 2005/01/01 14:22:21 eradicator Exp $
-
-inherit eutils
-
-DESCRIPTION="A graphical interface to the digital forensic analysis tools in The Sleuth Kit."
-HOMEPAGE="http://www.sleuthkit.org/autopsy/"
-SRC_URI="mirror://sourceforge/autopsy/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="arm ppc s390 sparc x86"
-IUSE=""
-
-# Runtime depend on grep and file deliberate
-RDEPEND="dev-lang/perl
- app-forensics/sleuthkit
- sys-apps/grep
- sys-apps/file"
-DEPEND="dev-lang/perl
- app-forensics/sleuthkit
- >=sys-apps/sed-4"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- echo "#!/usr/bin/perl -wT" > autopsy
- echo "use lib '/usr/lib/autopsy/';" >> autopsy
- echo "use lib '/usr/lib/autopsy/lib/';" >> autopsy
- cat base/autopsy.base >> autopsy
- sed -i 's:conf.pl:/etc/autopsy.pl:' autopsy lib/Main.pm
-}
-
-src_compile() {
- einfo "nothing to compile"
-}
-
-src_install() {
- insinto /usr/lib/autopsy
- doins autopsy
- insinto /usr/lib/autopsy/help
- doins help/*
- insinto /usr/lib/autopsy/lib
- doins lib/*
- insinto /usr/lib/autopsy/pict
- doins pict/*
- insinto /etc
- doins ${FILESDIR}/autopsy.pl
-
- dodir /usr/bin
- dosym /usr/lib/autopsy/autopsy /usr/bin/autopsy
- fperms +x /usr/lib/autopsy/autopsy
-
- doman man/man1/autopsy.1
- dodoc CHANGES.txt README.txt TODO.txt docs/sleuthkit-informer-13.txt
-}
diff --git a/app-forensics/autopsy/autopsy-2.05.ebuild b/app-forensics/autopsy/autopsy-2.05.ebuild
deleted file mode 100644
index e250bc1ae807..000000000000
--- a/app-forensics/autopsy/autopsy-2.05.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/autopsy/autopsy-2.05.ebuild,v 1.1 2005/04/24 06:08:58 dragonheart Exp $
-
-inherit eutils
-
-DESCRIPTION="A graphical interface to the digital forensic analysis tools in The Sleuth Kit."
-HOMEPAGE="http://www.sleuthkit.org/autopsy/"
-SRC_URI="mirror://sourceforge/autopsy/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~s390 ~sparc ~x86"
-IUSE=""
-
-# Runtime depend on grep and file deliberate
-RDEPEND="dev-lang/perl
- >=app-forensics/sleuthkit-2
- sys-apps/grep
- sys-apps/file"
-DEPEND="dev-lang/perl
- >=app-forensics/sleuthkit-2
- >=sys-apps/sed-4"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- echo "#!/usr/bin/perl -wT" > autopsy
- echo "use lib '/usr/lib/autopsy/';" >> autopsy
- echo "use lib '/usr/lib/autopsy/lib/';" >> autopsy
- cat base/autopsy.base >> autopsy
- sed -i 's:conf.pl:/etc/autopsy.pl:' autopsy lib/Main.pm
-}
-
-src_compile() {
- einfo "nothing to compile"
-}
-
-src_install() {
- insinto /usr/lib/autopsy
- doins autopsy
- insinto /usr/lib/autopsy/help
- doins help/*
- insinto /usr/lib/autopsy/lib
- doins lib/*
- insinto /usr/lib/autopsy/pict
- doins pict/*
- insinto /etc
- doins ${FILESDIR}/autopsy.pl
-
- dodir /usr/bin
- dosym /usr/lib/autopsy/autopsy /usr/bin/autopsy
- fperms +x /usr/lib/autopsy/autopsy
-
- doman man/man1/autopsy.1
- dodoc CHANGES.txt README.txt TODO.txt docs/sleuthkit-informer-13.txt
-}
diff --git a/app-forensics/autopsy/autopsy-2.08.ebuild b/app-forensics/autopsy/autopsy-2.08.ebuild
deleted file mode 100644
index 385fca5e41ba..000000000000
--- a/app-forensics/autopsy/autopsy-2.08.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/autopsy/autopsy-2.08.ebuild,v 1.1 2007/02/05 21:06:47 dragonheart Exp $
-
-inherit eutils
-
-DESCRIPTION="A graphical interface to the digital forensic analysis tools in The Sleuth Kit."
-HOMEPAGE="http://www.sleuthkit.org/autopsy/"
-SRC_URI="mirror://sourceforge/autopsy/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~s390 ~sparc ~x86"
-IUSE=""
-
-# Runtime depend on grep and file deliberate
-RDEPEND="dev-lang/perl
- >=app-forensics/sleuthkit-2
- sys-apps/grep
- sys-apps/file"
-DEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- echo "#!/usr/bin/perl -wT" > autopsy
- echo "use lib '/usr/lib/autopsy/';" >> autopsy
- echo "use lib '/usr/lib/autopsy/lib/';" >> autopsy
- cat base/autopsy.base >> autopsy
- sed -i 's:conf.pl:/etc/autopsy.pl:' autopsy lib/Main.pm
-}
-
-src_compile() {
- einfo "nothing to compile"
-}
-
-src_install() {
- insinto /usr/lib/autopsy
- doins autopsy
- insinto /usr/lib/autopsy/help
- doins help/*
- insinto /usr/lib/autopsy/lib
- doins lib/*
- insinto /usr/lib/autopsy/pict
- doins pict/*
- insinto /etc
- doins ${FILESDIR}/autopsy.pl
-
- dodir /usr/bin
- dosym /usr/lib/autopsy/autopsy /usr/bin/autopsy
- fperms +x /usr/lib/autopsy/autopsy
-
- doman man/man1/autopsy.1
- dodoc CHANGES.txt README.txt TODO.txt docs/sleuthkit-informer-13.txt
-}
diff --git a/app-forensics/cmospwd/ChangeLog b/app-forensics/cmospwd/ChangeLog
index 43a05a460832..c93065245b9e 100644
--- a/app-forensics/cmospwd/ChangeLog
+++ b/app-forensics/cmospwd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-forensics/cmospwd
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/cmospwd/ChangeLog,v 1.9 2009/01/04 23:55:04 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/cmospwd/ChangeLog,v 1.10 2009/01/08 19:49:26 patrick Exp $
+
+ 08 Jan 2009; Patrick Lauer <patrick@gentoo.org> -cmospwd-5.0.ebuild:
+ Removing old
*cmospwd-5.0 (04 Jan 2009)
diff --git a/app-forensics/cmospwd/cmospwd-5.0.ebuild b/app-forensics/cmospwd/cmospwd-5.0.ebuild
deleted file mode 100644
index b1a97594f43e..000000000000
--- a/app-forensics/cmospwd/cmospwd-5.0.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/cmospwd/cmospwd-5.0.ebuild,v 1.1 2009/01/04 23:55:04 patrick Exp $
-
-inherit toolchain-funcs
-
-DESCRIPTION="CmosPwd decrypts password stored in cmos used to access BIOS SETUP"
-HOMEPAGE="http://www.cgsecurity.org/wiki/CmosPwd"
-SRC_URI="http://www.cgsecurity.org/${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND="virtual/libc"
-
-src_compile() {
- cd src
- $(tc-getCC) ${CFLAGS} cmospwd.c -o cmospwd || die
-}
-
-src_install() {
- dosbin src/cmospwd || die
- dodoc cmospwd.txt || die
-}