summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/ibus-m17n')
-rw-r--r--app-i18n/ibus-m17n/ChangeLog11
-rw-r--r--app-i18n/ibus-m17n/ibus-m17n-1.1.0.20090211.ebuild40
-rw-r--r--app-i18n/ibus-m17n/ibus-m17n-1.3.2.ebuild (renamed from app-i18n/ibus-m17n/ibus-m17n-1.3.0.ebuild)28
3 files changed, 32 insertions, 47 deletions
diff --git a/app-i18n/ibus-m17n/ChangeLog b/app-i18n/ibus-m17n/ChangeLog
index bd196656fe2d..15781b997567 100644
--- a/app-i18n/ibus-m17n/ChangeLog
+++ b/app-i18n/ibus-m17n/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-i18n/ibus-m17n
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-m17n/ChangeLog,v 1.15 2010/09/20 02:47:09 matsuu Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-m17n/ChangeLog,v 1.16 2011/03/07 14:01:42 matsuu Exp $
+
+*ibus-m17n-1.3.2 (07 Mar 2011)
+
+ 07 Mar 2011; MATSUU Takuto <matsuu@gentoo.org>
+ -ibus-m17n-1.1.0.20090211.ebuild, -ibus-m17n-1.3.0.ebuild,
+ +ibus-m17n-1.3.2.ebuild:
+ Version bumped. Removed old versions.
*ibus-m17n-1.3.1 (20 Sep 2010)
diff --git a/app-i18n/ibus-m17n/ibus-m17n-1.1.0.20090211.ebuild b/app-i18n/ibus-m17n/ibus-m17n-1.1.0.20090211.ebuild
deleted file mode 100644
index 4b207f115f2e..000000000000
--- a/app-i18n/ibus-m17n/ibus-m17n-1.1.0.20090211.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-m17n/ibus-m17n-1.1.0.20090211.ebuild,v 1.1 2009/02/12 14:56:19 matsuu Exp $
-
-DESCRIPTION="The M17N engine IMEngine for IBus Framework"
-HOMEPAGE="http://code.google.com/p/ibus/"
-SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="nls"
-
-RDEPEND=">=app-i18n/ibus-1.1
- dev-libs/m17n-lib
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- dev-db/m17n-db
- dev-db/m17n-contrib
- >=sys-devel/gettext-0.16.1"
-
-src_compile() {
- econf $(use_enable nls) || die
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- dodoc AUTHORS ChangeLog NEWS README
-}
-
-pkg_postinst() {
- ewarn "This package is very experimental, please report your bugs to"
- ewarn "http://ibus.googlecode.com/issues/list"
- elog
- elog "You should run ibus-setup and enable IM Engines you want to use!"
- elog
-}
diff --git a/app-i18n/ibus-m17n/ibus-m17n-1.3.0.ebuild b/app-i18n/ibus-m17n/ibus-m17n-1.3.2.ebuild
index 8d80f29d04f9..34101b75d5fc 100644
--- a/app-i18n/ibus-m17n/ibus-m17n-1.3.0.ebuild
+++ b/app-i18n/ibus-m17n/ibus-m17n-1.3.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-m17n/ibus-m17n-1.3.0.ebuild,v 1.1 2010/04/13 15:56:36 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-m17n/ibus-m17n-1.3.2.ebuild,v 1.1 2011/03/07 14:01:42 matsuu Exp $
-EAPI="2"
+EAPI="3"
DESCRIPTION="The M17N engine IMEngine for IBus Framework"
HOMEPAGE="http://code.google.com/p/ibus/"
@@ -11,9 +11,10 @@ SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="nls"
+IUSE="gtk nls"
RDEPEND=">=app-i18n/ibus-1.3
+ gtk? ( >=x11-libs/gtk+-2.12.12:2 )
dev-libs/m17n-lib
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
@@ -21,9 +22,26 @@ DEPEND="${RDEPEND}
dev-db/m17n-db
dev-db/m17n-contrib
>=sys-devel/gettext-0.16.1"
+# gtk? (
+# || (
+# >=x11-libs/gtk+-2.90.5:3
+# >=x11-libs/gtk+-2.12.12:2
+# )
+# )
src_configure() {
- econf $(use_enable nls) || die
+ local myconf
+
+ if use gtk ; then
+ myconf="${myconf} --with-gtk=2.0"
+ #myconf="${myconf} --with-gtk=3.0"
+ else
+ myconf="${myconf} --with-gtk=no"
+ fi
+
+ econf \
+ $(use_enable nls) \
+ ${myconf} || die
}
src_install() {