summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/fcitx/ChangeLog9
-rw-r--r--app-i18n/fcitx/fcitx-3.4.2.ebuild45
-rw-r--r--app-i18n/fcitx/fcitx-3.5_pre070403.ebuild47
-rw-r--r--app-i18n/fcitx/files/digest-fcitx-3.4.23
-rw-r--r--app-i18n/fcitx/files/digest-fcitx-3.5_pre0704033
5 files changed, 106 insertions, 1 deletions
diff --git a/app-i18n/fcitx/ChangeLog b/app-i18n/fcitx/ChangeLog
index e9f5ec2faa84..5ccb31957d9d 100644
--- a/app-i18n/fcitx/ChangeLog
+++ b/app-i18n/fcitx/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-i18n/fcitx
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/ChangeLog,v 1.18 2007/01/05 16:17:08 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/ChangeLog,v 1.19 2007/04/27 16:53:30 matsuu Exp $
+
+*fcitx-3.5_pre070403 (27 Apr 2007)
+*fcitx-3.4.2 (27 Apr 2007)
+
+ 27 Apr 2007; MATSUU Takuto <matsuu@gentoo.org> +fcitx-3.4.2.ebuild,
+ +fcitx-3.5_pre070403.ebuild:
+ Version bumped, bug #168303.
05 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> fcitx-3.1.1.ebuild,
fcitx-3.2.1.ebuild, fcitx-3.4.ebuild:
diff --git a/app-i18n/fcitx/fcitx-3.4.2.ebuild b/app-i18n/fcitx/fcitx-3.4.2.ebuild
new file mode 100644
index 000000000000..341599a67717
--- /dev/null
+++ b/app-i18n/fcitx/fcitx-3.4.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/fcitx-3.4.2.ebuild,v 1.1 2007/04/27 16:53:30 matsuu Exp $
+
+DESCRIPTION="Free Chinese Input Toy for X. Another Chinese XIM Input Method"
+HOMEPAGE="http://www.fcitx.org/"
+SRC_URI="http://www.fcitx.org/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="truetype"
+
+DEPEND="x11-libs/libX11
+ x11-libs/libXrender
+ x11-libs/libXt
+ truetype? ( x11-libs/libXft )"
+
+src_compile() {
+ econf $(use_enable truetype xft) || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog README THANKS TODO
+
+ rm -rf "${D}"/usr/share/fcitx/doc/
+ dodoc doc/pinyin.txt doc/cjkvinput.txt
+ dohtml doc/wb_fh.htm
+}
+
+pkg_postinst() {
+ elog "You should export the following variables to use fcitx"
+ elog " export XMODIFIERS=\"@im=fcitx\""
+ elog " export XIM=fcitx"
+ elog " export XIM_PROGRAM=fcitx"
+ elog ""
+ elog "If you want to use WuBi or ErBi"
+ elog " cp /usr/share/fcitx/data/wbx.mb ~/.fcitx"
+ elog " cp /usr/share/fcitx/data/erbi.mb ~/.fcitx"
+ elog " cp /usr/share/fcitx/data/tables.conf ~/.fcitx"
+ elog ""
+}
diff --git a/app-i18n/fcitx/fcitx-3.5_pre070403.ebuild b/app-i18n/fcitx/fcitx-3.5_pre070403.ebuild
new file mode 100644
index 000000000000..cb8544deb655
--- /dev/null
+++ b/app-i18n/fcitx/fcitx-3.5_pre070403.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/fcitx-3.5_pre070403.ebuild,v 1.1 2007/04/27 16:53:30 matsuu Exp $
+
+DESCRIPTION="Free Chinese Input Toy for X. Another Chinese XIM Input Method"
+HOMEPAGE="http://www.fcitx.org/"
+SRC_URI="http://www.fcitx.org/download/${P/_pre/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="truetype"
+
+DEPEND="x11-libs/libX11
+ x11-libs/libXrender
+ x11-libs/libXt
+ truetype? ( x11-libs/libXft )"
+
+S="${WORKDIR}/${P/_pre*}"
+
+src_compile() {
+ econf $(use_enable truetype xft) || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog README THANKS TODO
+
+ rm -rf "${D}"/usr/share/fcitx/doc/
+ dodoc doc/pinyin.txt doc/cjkvinput.txt
+ dohtml doc/wb_fh.htm
+}
+
+pkg_postinst() {
+ elog "You should export the following variables to use fcitx"
+ elog " export XMODIFIERS=\"@im=fcitx\""
+ elog " export XIM=fcitx"
+ elog " export XIM_PROGRAM=fcitx"
+ elog ""
+ elog "If you want to use WuBi or ErBi"
+ elog " cp /usr/share/fcitx/data/wbx.mb ~/.fcitx"
+ elog " cp /usr/share/fcitx/data/erbi.mb ~/.fcitx"
+ elog " cp /usr/share/fcitx/data/tables.conf ~/.fcitx"
+ elog ""
+}
diff --git a/app-i18n/fcitx/files/digest-fcitx-3.4.2 b/app-i18n/fcitx/files/digest-fcitx-3.4.2
new file mode 100644
index 000000000000..91178143ba0a
--- /dev/null
+++ b/app-i18n/fcitx/files/digest-fcitx-3.4.2
@@ -0,0 +1,3 @@
+MD5 30ca366f7c08ea96da69689adb8d55f7 fcitx-3.4.2.tar.bz2 3155032
+RMD160 dcefea101b3674cf5d3e20630b352127a4a15116 fcitx-3.4.2.tar.bz2 3155032
+SHA256 64d8f4183593c7c3a855b4b1d07afe605d9548cefdbfc07b1d0f79fc3f4c02ed fcitx-3.4.2.tar.bz2 3155032
diff --git a/app-i18n/fcitx/files/digest-fcitx-3.5_pre070403 b/app-i18n/fcitx/files/digest-fcitx-3.5_pre070403
new file mode 100644
index 000000000000..be2c6c9e2876
--- /dev/null
+++ b/app-i18n/fcitx/files/digest-fcitx-3.5_pre070403
@@ -0,0 +1,3 @@
+MD5 1acf177eef8ad4ba46417350f4c6bb74 fcitx-3.5-070403.tar.bz2 3900539
+RMD160 cf8b46ef7dc8af194c42c171a2d54caefcfccd79 fcitx-3.5-070403.tar.bz2 3900539
+SHA256 2661f133094dd3f963a6ea7d3998f713b9fd043b805aa60cc2b6a181f645491c fcitx-3.5-070403.tar.bz2 3900539